Skip navigation

Seagate Momentus XT

163924 Views 236 Replies Latest reply: Nov 9, 2013 3:39 AM by leodali83 RSS
  • Sebastian Siedentopf Calculating status...
    Currently Being Moderated
    Nov 25, 2010 7:51 AM (in response to Roman1)
    +(1) It's from begin of the ding sound till the login screen.+

    Between the startup sound and the login screen many hardware related things happen, so this process does not scale linear with you hard drive speed.

    But if you have many startup items (DropBox, Textexpander, iStatMenu, Hazel, Quicksilver …) in your user account which are loaded after you login you should see a considerable speed boost. My boot time went down from ca. 1:40 (startup sound till all startup items are loaded) down to ca. 45 sec with 90% of that improvement in the post login.
  • airflyer172 Calculating status...
    Currently Being Moderated
    Nov 25, 2010 9:45 PM (in response to Sebastian Siedentopf)
    Hello Everyone,

    Tried this drive first on my MBP 2.53 core 2 as a replacement for the standard 250-5400 drive. Terrible experience, tried clean install of snow leopard and had lockups during the install. When I finally got a clean install after 3 attempts experienced consistent lockups.
    Moved the drive to my i5 MBP. Same situation.

    My solution was to exchange the thing for 2 nice new 500GB Segate momentous 7200 drives with 16 mb cache. This improved the boot time of my core 2 by nearly 7 seconds over the 5400 drive and 3 seconds over the stick Hitachi 500/ 7200 drive that came with my new i5.

    Very happy with the momentous 7200 drive Not so with the XT I don't think the firmware or maybe even the hybrid technology is ready.

    On the other hand we stuck a 250 SSD into a MPB at work. Unbelievable and stable VERY FAST. If I didn't need the capacity and or were filthy rich that would be my direction.

    Advice... Don't waste time on the hybrid not worth the frustration and when the $$$$ of SSD's drops in the near future you will just be replacing it anyway.
    MacBook Pro, Mac OS X (10.6.5), iPhone
  • Roman1 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 26, 2010 11:52 AM (in response to airflyer172)
    Gosh, I can imagine the frustration. Poor you!

    I'm responding, because your information may not be valid with the latest release of the drives. There is a firmware update on Seagate website to address Mac issues. You must have been one of the early adopter sufferers.

    Also, I don't really agree with the SSD option, because some of us want the higher capacity. SSD, when chosen carefully, is certainly the fastest, but higher capacities don't make economical sense for the majority.
    MacBook Pro 2.4 GHz (main) - iMac - PowerBook - Mac mini, Mac OS X (10.6.4), 4GB - 2 GB - 768 MB - 4 GB RAM respectively
  • Cornelius Qualley Calculating status...
    Currently Being Moderated
    Nov 30, 2010 7:00 AM (in response to Roman1)
    So, I've read this entire thread and I can't really determine whether or not the firmware fixes the issue? I purchased two of these drives, then just happened to search for some info on the drive and stumbled upon this thread. I have two of the 500GB XTs which I plan on installing on two MPBs (2009)--one 2.4GHz and one 2.53GHz. Is there any consensus as to whether or not these drives will work on these machines with the newest firmware, or are people having issues with this combination as well?
    MacBook Pro 2.4GHz 15" Unibody, Mac OS X (10.6.5), 4GB RAM/320GB HD/1.5TB External • www.SiteOMite.com
  • Delta5 Calculating status...
    Currently Being Moderated
    Nov 30, 2010 7:21 AM (in response to Cornelius Qualley)
    Cornelius Qualley wrote:
    Is there any consensus as to whether or not these drives will work on these machines with the newest firmware, or are people having issues with this combination as well?


    From this thread, there are some pretty significant disagreements as to whether this drive works and "is worth it". Some have problems, some don't. My advice would be to buy them from someplace with a good return policy, just in case.

    My 500GB XT shipped with the latest firmware and has been running flawlessly in my circa 2009 Macbook Pro (C2D-2.53ghz, 4GB, 512mb 9600, fully updated SL) for almost a month now. Installation went smoothly. Daily usage is great; no hiccups, no beachballs, no vibration, no stuttering, even when playing HD video at full screen. It just works. Fast and quiet; as any good hard drive should be. And as a side benefit, my MBP is running cooler and quieter than with the previous 320GB WD Black drive (which was great, but kind of loud & hot compared to the OEM). Battery life seems unaffected.

    So, I'm quite happy with the drive. I know others aren't, and that's unfortunate. Since we're seeing similar (identical!) setups with varied results, I can't help but think that perhaps Seagate has some QC issues to work out.

    And of course, when SSD prices fall enough this kind of drive will be totally obsolete. But we're not there yet. This drive (for me) is a good compromise.
    Macbook Pro, Mac OS X (10.6.5), 64GB iPad 3G, iPhone 4 (16 and 32)
  • Cornelius Qualley Level 2 Level 2 (300 points)
    Currently Being Moderated
    Nov 30, 2010 7:20 AM (in response to Delta5)
    Well, I already have the drives so I guess I'll try them out and hope for the best. I'm assuming that there are a large number of people that have these drives running without issue which aren't reflected on this forum since they have no reason to post about their success. The only reason I purchased these drives in the first place was by recommendation from a fellow MPB user, he was very happy with his install. I guess I will install these two drives and post my results to add to the discussion.
    MacBook Pro 2.4GHz 15" Unibody, Mac OS X (10.6.5), 4GB RAM/320GB HD/1.5TB External • www.SiteOMite.com
  • slowth84 Calculating status...
    Currently Being Moderated
    Nov 30, 2010 7:22 AM (in response to Delta5)
    Ok so I sent my new-refurb MBP in for repairs.. kept thinking it was the stupid HD.

    glad to know that it was the screen which means my HD is fine. So a positive review from me.

    Now the only thing i'd be confused is how to tell if the flash portion of the HD is actually working and not just the 7200 rpm. =)
    Macbook Pro '10, Mac OS X (10.6.5), 2.4 GHz 8GB Ram
  • johnwaynegacy Calculating status...
    Currently Being Moderated
    Dec 3, 2010 7:35 AM (in response to teof74)
    Hello there.

    I've just bought Seagate Momentus XT, 500GB SD23 for my 15-inch MacBook Pro 2010. I'm not an Apple newbie, I used to work for a local premium reseller for a couple of years and I decided to replace the drive on my own. Just a few screwes later it was done, so I inserted the MacOS Snow Leopard 10.6 disc, booted from dvd and... nothing happend, stuck on Apple logo (without the booting animation).

    I have the dvd image permanently mounted on my Lacie external hard drive, so I tried it that way, same result.

    I set the MBP15 into Target Disk Mode, plugged it to my MBP13 via FireWire 800 and ran the Disk Utility. I was able to format the drive, rename it, mount, browerse and even install the OS, what I actually did. Well, I had thought that should do it, but guess what... I still can't pass the Apple logo. Neither with Snow Leopard already installed on the drive, nor DVD and external drive boot.

    I replaced Seagete Momentus with my old drive and pooofffff.... everything works.

    I don't think the new drive could be broken, if it was so then I shouldn't be able to do all the stuff with Disk Utility.

    Any ideas what's wrong with the drive/Pro/both?

    (Sorry for all the grammar mistakes, English past tenses have always been too deep for me.)
    MacBook Pro 15" 2010, Mac OS X (10.6.3)
  • Enrique Garcia Calculating status...
    Currently Being Moderated
    Dec 6, 2010 1:02 PM (in response to teof74)
    My 2 cents.
    I cloned the disk thru a restore booting from OS X Snow Leopard and using Disk Utilities to do it.
    Installed XT on MBP Penryn and 4 GB RAM for a total of 6 GB.
    Boot went down from 1:15 to 1:00 but I could care less for that.
    What really impressed me is launching apps and also a Virtual PC I have on Parallels.... very zippy indeed.
    The machine feels so much 'alive'.

    BTW, had to run the Office 2011 installer again. Please read correctly: I did not have to do a complete Office 2011 re-install, rather just run the installer and no further updates, or dealing with user files, just run the installer.
    MacBook Pro 15" 4.1 aka Penryn, Mac OS X (10.6.5), 6 GB RAM
  • hgw90026 Calculating status...
    Currently Being Moderated
    Dec 8, 2010 12:54 AM (in response to teof74)
    I first got the Momentous XT drive and sat it down on the Voyager firewire dock with my MacBook Pro with no problems. I was able to load Snow Leopard and transfer the user directory. I even boot through the drive. Once I installed it into the MacBook, it would not boot at all. I was getting some funny symbols on the Mac Bootup screen. I then proceeded to just reinstall the OS and the install hangs at 27 minutes. The install finally delivered a failed message. So I've concluded there is a problem with MacBook Pro when using the drive as an internal drive.
    A1286, Mac OS X (10.6.5), MacBook Pro 2009
  • CESNET Calculating status...
    Currently Being Moderated
    Dec 10, 2010 12:05 PM (in response to hgw90026)
    waooooo,

    I just received my momentus XT and then searched for info when I saw this discussion. I'm really scared now. I'm even not sure what's the best method to follow.
    any advise?
    MACBOOK pro 13" 2,4Ghz 4Mb, Mac OS X (10.6.5)
  • matthew.beco Calculating status...
    Currently Being Moderated
    Dec 13, 2010 7:40 AM (in response to teof74)
    Hi everyone! I have some info that may help everyone. I bought a 500GB Momentus XT a couple of months ago and it shipped with the newest firmware. When I installed it there were tons of issues, battery life being majorly affected, I went from 4-5 hours of battery to 20 min literally. I could sit and watch my percentage drop in a matter of min.... very weird. I took it back to the store to exchange for a black or some other standard 7200 but at the last min figured, what the heck, Ill get another XT and try again. Long story short, Its perfect now... no issues whatsoever. The bottom line is that a bad batch got out from the factory so a percentage of the drives out there right now are defective and theres nothing you can do about it. When you find one thats right, youll love it! fantastic drive! I havnt heard it once it 2 months and its smoking fast... battery life is fine.
    macbook pro 2.26 8GB 500GB Hybrid, iphone 4, iOS 4
  • CESNET Level 1 Level 1 (35 points)
    Currently Being Moderated
    Dec 13, 2010 1:33 PM (in response to matthew.beco)
    Hi Matthew,

    many thanks for your info I'm much more optimistic now.
    any recomendation for the installation?
    I had thought to do it with the standard process published by apple at their manuals webpage, so using time machine.

    thanks
    MACBOOK PRO 13", Mac OS X (10.6.5)
  • Enteraliashere Calculating status...
    Currently Being Moderated
    Dec 15, 2010 5:04 AM (in response to CESNET)
    For those of you who have not seen it yet, a new firmware (SD24) came out a week or so ago.
    Al Macbook, None
1 2 3 4 5 6 ... 16 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.