Skip navigation

Itunes 10 homesharing not working

214074 Views 182 Replies Latest reply: Oct 24, 2013 5:28 AM by kcullinan RSS
  • puzzo Calculating status...
    Currently Being Moderated
    Nov 23, 2010 1:21 PM (in response to ediblecrayon)
    I've the same situation on Windows 7 box, MacBook and Apple TV. The problem was in ASUS RT-N16 router. Windows box was connected to router with ethernet cable, apple tv and macbook is connecting wireless. I saw macbook media on window but didn't see windows media on macbook. After I connect macbook with ethernet cable, it starts working in a second. So the problem may be in WIFI router. Maybe something with multicast and maybe there some restrisctions for multicast in wireless network. Now I'm downloading new firmware for router.
  • NightflyWJAZ Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 27, 2010 9:12 AM (in response to puzzo)
    I am having the same issues... I cannot get Home Sharing to work. After I try to enable Home Sharing within iTunes, the "Shared" folder, in the left side pane, disappears as soon as I click the "Done" button.

    My hardware is as follows:
    - I have a Windows PC with Windows 7 Home Premium 64 Bit. This is the PC for which i have iTunes 10.1.0.54 installed.
    - I am using a D-Link DIR-655 Router with firmware version 1.34NA installed.
    - I have the new Apple TV with the latest update installed.
    iPad 64GB, Apple TV Gen 2, Windows 7
  • Cletus heaps Calculating status...
    Currently Being Moderated
    Nov 27, 2010 12:24 PM (in response to txfeinbergs)
    Like the rest of you I am having problems with home sharing. I have a apple tv 2 and two macs the apple tv 2 see the bedroom mac but not the main media mac. I have tried everything I could find online to no avail. they are on the same network, I have delete and re authorized the macs re installed itunes, turned sharing on and off, bought a new router, reset the apple tv, yada yada any ideas are welcome...
    mac pro, Mac OS X (10.6.5), none
  • NightflyWJAZ Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 27, 2010 2:19 PM (in response to NightflyWJAZ)
    I finally figured out the issues with "Home Sharing" on my network.

    My connection issue was related to the fact that the Ethernet cable coming from Windows 7 PC was incorrectly connected to my Verizon FIOS Modem when it should have been directly connected to my D-Link DIR-655 Wireless Router. I have so many cables behind my desk that I didn't catch this issue right away. Once I connected the Ethernet Cable from my Windows 7 PC to my Wireless Router I was able to use "Home Sharing". Problem solved.

    Note: I use a wireless connection with Apple TV2.

    Also, I spoke with Apple Support. When enabling "Home Sharing" in iTunes the "Shared" folder is no longer displayed in iTunes when using Apple TV2. This is normal.
    Windows 7
  • Nikole2774 Calculating status...
    Currently Being Moderated
    Nov 27, 2010 9:04 PM (in response to ediblecrayon)
    for those having problems - turn your share on and off, check your firewall and reboot your router.

    I was ready to pull my hair out. My computer could access his but not vice versa. And then eventually his could see mine but not connect. Ultimately, after rebooting the router it all worked fine.
  • mdfrancois Calculating status...
    Currently Being Moderated
    Nov 28, 2010 1:10 AM (in response to Natilus13)
    This did not work for me.
    Macbook Pro 2Ghz Intel Core Duo, Mac OS X (10.5.6), 2gb RAM
  • NightflyWJAZ Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 28, 2010 4:59 PM (in response to Nikole2774)
    Regarding a firewall, I had issues with ZoneAlarm Free. To work with ZoneAlarm (free version), you will need to do the following:

    1. Open ZoneAlarm
    2. Click on "Firewall"
    3. Click on "Main"
    4. Change the "Internet Zone Security" to "Medium" (Med.)

    Once the changes above are completed, Home Sharing on Apple TV2 will work.
    Windows 7
  • yyzgwm Calculating status...
    Currently Being Moderated
    Dec 3, 2010 9:45 AM (in response to ediblecrayon)
    I fixed this! -- thanks to Merhej's post. I went to iTunes Edit>Preferences>Sharing, and discovered that Bonjour (I'd never heard of this thing) was disabled. I then went to Start>Control Panel>Add or remove progams>Bonjour>Support information>Repair. I then rebooted. Same for the other computer. After the reboot, they were sharing again. Does installing 10 disable Bonjour??
    Dell, Windows XP
  • UdellFam Calculating status...
    Currently Being Moderated
    Dec 4, 2010 11:37 PM (in response to yyzgwm)
    i have been having the same problem, we have An IMac, Mac Book, HP Mini(my computer)and a Sony viso net book. the first three all work on home sharing through wifi but the Sony wont connect. I did exactly as everyone has said, i even went a far a repair itunes, nothing but all other computers still work. My computer even recognizes the computer is on the network but cant pull up its files. I even have gotten a 3259 error when trying to turn on home sharing.
    I'm about to delete itunes and then re-install it. post about that once done.
    any new ideas anyone
    HP Mini, Windows XP Pro, IMac, Mac Book, Sony viso mini
  • justmegan82 Calculating status...
    Currently Being Moderated
    Dec 12, 2010 11:45 AM (in response to UdellFam)
    I'm having a somewhat similar problem. I have an old PC and my new MacBook Pro and I'm trying to set up my library on the new Mac.

    I can drag my Playlists but not my Library. I have songs that aren't in a playlist but I would like them on the Mac. If I drag a playlist to the new Mac, it works and adds it to the Library but if the same song is in multiple playlists, I'll get duplicate copies of the song in the library. Am I doing something wrong? I have turned Home Sharing off and on, deauthorized & authorized both machines, made sure it was the same wireless network, etc. Help! This is very frustrating.
    MacBook Pro, Mac OS X (10.6.5), New Mac user as of 12/12/10
  • mkreilein Calculating status...
    Currently Being Moderated
    Dec 13, 2010 8:57 PM (in response to ediblecrayon)
    I have this issue as well. In short..

    iTunes10 (it10) on win7 cannot homeshare with it10 on MBP. When you set it up, the icon disappears never to appear again.
    it10 on MBP CAN homeshare with it10 on win7
    AppleTV2 CAN homeshare with it10 on Win7 and MBP

    However, iTunes9 on win7 can homeshare with it10 on MBP.

    I've been round and round and round with Apple on this and they are 100% clueless. They've had me remove/reinstall it10 on win7 6 different ways...nothing. I've sent screenshots of each computer step by step. Tried with firewall, no firewall, etc.

    They have a software bug & are not admitting it or doing anything about it. I was told to call support and pay for an answer. I doubt they have one. SOmething's broken and they're in no hurry to fix it...and they obviously don't check their forums as they offer nothing here...unless you trash them somehow, then the posts get pulled faster than you can save it.

    It's an issue, and likely won't be fixed until it11 if then.

    Best advice, download it9 and stick with it.
    MacBook Pro, iPhone 4, ATV2, iPad, iPod, Mac OS X (10.6.5)
  • theross03 Calculating status...
    Currently Being Moderated
    Dec 16, 2010 6:17 PM (in response to ediblecrayon)
    I am running into this same issue as well. I have a ubuntu machine with rhythmbox installed (also getting same behavior with firefly/mt-daapd and forked-daapd) and a winXP PC with itunes 10.1.0.56. In trying to share across the two computers, the ubuntu machine with rhythmbox can see the itunes library on the PC, but it shows as having 0 songs/playlists/etc. The PC with itunes cannot even see the rhythmbox's library.

    Packet sniffing analysis:

    PC trying to retrieve library from ubuntu:
    I have done packet sniffing on the PC and can easily see the mDNS request from the winXP PC to the multicast address where the PC is looking for daap.tcp and then the ubuntu box responding saying yes, I offer that service. But then itunes doesn't respond to start a handshake. It definitely looks like something that iTunes is dropping once the daap provider responds.

    Ubuntu trying to retrieve library from PC:
    Packet sniffing shows that the Ubuntu machine running Rhythmbox sends the mDNS request and iTunes responds. A handshake actually occurs this time, but before any data is transferred across the network, the Ubuntu machine attempts a DAAP/GET function and the Itunes box returns an HTTP/1.1 403 FORBIDDEN error (no password is set). Once the 403 occurs, the transmission stops, and thus, no songs transmitted.

    Anyone else done analysis along these lines?
    Windows XP Pro
  • jonathan.gate Calculating status...
    Currently Being Moderated
    Dec 21, 2010 8:18 AM (in response to sydneygerb)
    That's exactly what my sister suggested... I'll try it today! Hope it works!
    MDG, Windows Vista
  • kreichenbach Calculating status...
    Currently Being Moderated
    Dec 23, 2010 8:32 AM (in response to ediblecrayon)
    Ok, I had the same problem that most everyone else on this topic had. I found a fix that worked for me and hopefully will work for you. This is the short answer. Go to control panel, administrative tools, services, and then look for Bonjour service. Mine was showing "started" but I stopped the service and restarted Bonjour. When I went back in itunes the other computers now show under home share. It worked for me. Good luck.
    PC, Windows XP Pro, Itunes Home Share Fix
  • bakerdal Calculating status...
    Currently Being Moderated
    Dec 23, 2010 7:31 PM (in response to ediblecrayon)
    *It is most definitely a bug with ITunes version 10.* My son and I use home sharing constantly. We were using it two days ago just before we both upgraded to the latest version. Home Sharing was dead immediately and will not work. And even though it was working perfectly up to the upgrade, I still spent time going through troubleshooting just to be completely sure and eliminate any other possibility. ITunes 10 is buggy. Kills Home Sharing on the Windows 7 platform.
    Alienware, Windows 7
1 2 3 4 5 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.