Skip navigation

Empty Trash error -8003

122537 Views 105 Replies Latest reply: Mar 19, 2014 3:40 PM by Simon Paterson RSS Branched to a new discussion.
  • gianna13 Calculating status...
    Currently Being Moderated
    Sep 17, 2010 2:22 PM (in response to Mishutka Europe)
    "Main Menu" works great!

    http://incrediblebee.com/mainmenu
    several Macs, Mac OS X (10.6.4)
  • MaddAddam Calculating status...
    Currently Being Moderated
    Oct 9, 2010 2:06 PM (in response to gianna13)
    Quick erase in "Clean My Mac" also works. Just drop and drag all the files in the "Trash"

    http://macpaw.com
    MacBook Pro, Mac OS X (10.6.4)
  • Jim Sky Calculating status...
    Currently Being Moderated
    Oct 27, 2010 12:12 PM (in response to MiamiJ)
    This process worked for me as well. I never touch TM backups manually, but TM had previously gotten hosed and tried to backup 189GB one day rather than its usual 2 to 3GB, and so I clicked the "X" to stop TM backup, but didn't manually delete any files.

    Today after running MacUpdate and updating a bunch of apps, I got error -8003 and couldn't empty trash.

    Created a temporary directory on the HDD, then opened package contents one by one right in the trash itself, moved each -Resources- directory to the temporary directory (just dragged 'em out of the trash one at a time), leaving everything else in the trash, and was able to Empty Trash. While copying I sometimes created a new directory name and sometimes just over-wrote the -Resources- directory that was in my temp directory. It didn't seem to matter as long as I removed them from the trash.

    Keep in mind that some -Resources- directories contain packages within themselves which contain further -Resources- directories ... have to pull all of them out of the trash.

    Then I right-clicked and executed "Move to Trash" one at a time on the -Resources- directories, emptying the trash after each directory was trashed, and was able to (over about 15 minutes) delete all files. Finder didn't complain at all if I was deleting Resources folders one at a time.

    Message was edited by: Jim Sky
    Macbook Pro 15" 2009, Mac OS X (10.6.4)
  • NemesysSoft Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 10, 2010 6:28 PM (in response to Shuttle guy)
    That sounds really like the Windows nightmares have come true on the Mac! A small problem, quick, re-install the OS!
    MacBook Pro 17" 2.5GHz - iPhone 4, Mac OS X (10.6.4), 4GB RAM - 320GB HD
  • randy_harris Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2010 5:41 PM (in response to Mishutka Europe)
    Unlike some others here, I deleted nothing from a Time Machine or any other backup but I was also getting the -8003 error when trying to empty my trash, even after a reboot.

    Trash It! worked like a champ though.
    iMac 24", Mac OS X (10.6)
  • MSM126 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 20, 2010 4:43 PM (in response to Mishutka Europe)
    Thank you for posting the update. TrashIt worked perfectly for me!
    Mac
  • WaldenGreen Level 1 Level 1 (0 points)
    I'm seeing this error whenever I try to delete anything at all. So at least for me it appears to be unrelated to time machine.

    I have to use a utility to "force empty the trash" whenever I wish to delete even a single file. I've been using BatchMod for this and it works well.

    Anyone have a permanent solution that actually fixes the underlying problem rather than just a workaround like we have all been using? Thanks.
    Many Macs, Mac OS X (10.6.2)
  • fireiron Calculating status...
    Currently Being Moderated
    Dec 15, 2010 10:33 AM (in response to Mishutka Europe)
    I tried having an Apple Tech call me. He had me start in safe mode (hold down shift while your computer is turning on). It DID NOT resolve the issue.

    I tried using Trash It! (http://www.macupdate.com/app/mac/8214/trash-it!). It takes a while, but it did the trick.

    I had trouble because I was trying to delete old backups off of an external hard drive. Once I got them cleaned up, the regular empty trash functions normally.
    iMac, Mac OS X (10.6.5)
  • manctaff Calculating status...
    Currently Being Moderated
    Dec 20, 2010 9:17 AM (in response to MaddAddam)
    Same problem with switching external HDDs and wanting to delete TM backups. Trashit didn't do anything, by CleanmyMac worked really well, so thanks to tip.
    MacBook, Mac OS X (10.4.11)
  • jmpdd Calculating status...
    Currently Being Moderated
    Jan 14, 2011 3:50 PM (in response to Mishutka Europe)
    Just had this 8003 error trying to dump off Time Machine files. After trying unsuccessfully Trash It, I went to another start-up disk, emptied the Trash, went back to my Mac HD and there it was ... garbage gone.
    24" Intel IMac, 8 gigs of Ram, 4 external drives, OS 10.6.6
    G5 PC IMC, Mac OS X (10.6.6)
  • ajross31 Calculating status...
    Currently Being Moderated
    Jan 18, 2011 3:57 PM (in response to Mishutka Europe)
    My solution to Trash Error -8003:

    If you have moved the backup files to the Trash, use the "Put Back" command (right click the file) in the Trash to put it back where it came from. Then you can delete the other files.

    Make sure to right click and select "Put Back" - don't try drag and drop, and dont apple + z it.
    MacBook Pro, Mac OS X (10.6.4), 2.4 GHz Intel Core 2 Duo, 4 GB 667 MHz DDR2 SDRAM
  • moonduck Calculating status...
    Currently Being Moderated
    Mar 25, 2011 10:00 AM (in response to Mishutka Europe)
    "Trash-it" works great. Save yourself a lot of time and hassle.
    http://www.macupdate.com/app/mac/8214/trash-it!
    Download it for free. Send the guy some money if you want. Delete your trash in about 3 seconds. I had over 80 GB of stuff in my trash that wouldn't delete and I was getting the -8003 error. Trash-it took care of it immediately.
    Mac Pro, Mac OS X (10.6.6)
  • JoeTheCoder Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 2, 2011 8:33 PM (in response to Mishutka Europe)

    I THINK I HAVE SOLVED THIS.

     

    I seems to be a caching issue. I did a full automation using the Onyx App. Although I did the full thing, leaving out only the Spotlight reset, I believe it was ultimately the clearing of the caches which broke the link that caused my error -8003. So I could finally empty the Trash.

     

    I wouldn't be brave enough to use Trash It. I don't know enough about the App and am very cautious about using weird Apps.

     

    I used the trusty old Onyx. Clear your caches. Try Empty Trash again.

     

    P.S. Secure Empty Trash didn't work for me. Use Onyx, select the Automation tab > check all the "Cleaning" checkboxes. If it doesn't work for you you can go back to check all the checkboxes - even ones not in the Cleaning section. But I don't think you'll need to go this far. There is no need to reset Spotlight, so you can leave that one unchecked.

     

    P.P.S iCab was the App that caused this issue for me. That App is never getting back on my machine.

     

    P.P.P.S Never touch the App iClock with a ten foot barge pole. iClock had nothing to do with this issue, but I just thought I'd warn you all. If you think it's tough deleting iCab, iClock is a vicious worm of an App that infests your Mac like poison Ivy.

  • j.dyson Calculating status...
    Currently Being Moderated
    May 8, 2011 6:44 PM (in response to JoeTheCoder)

    Joe, Onyx also has a Trash section under Utilities where you can Delete or Secure Delete the Trash contents for all users and all volumes in one swoop. For most people, this is enough, but if you need to empty Trash on only one volume, perhaps your approach is the way to go.

     

    I've had nothing but good luck with Onyx, so thumbs up from me.

  • JoeTheCoder Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 10, 2011 4:41 AM (in response to j.dyson)

    I see that option now. Good find.

     

    It is worth pointing that that option empties all Trash from All Accounts on your Mac.

1 2 3 4 5 6 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.