Skip navigation

iPhone Configuration Utility - Can't Remove Profiles

30164 Views 12 Replies Latest reply: May 7, 2012 11:35 AM by MR650 RSS
Shaun K Calculating status...
Currently Being Moderated
Nov 28, 2010 9:34 PM
Hi folks, A few months back I configured 7 iPhones using IPCU. Each iPhone had a profile installed and set so that the users could not remove the profile.

Initially we started with all iPhones being very limited in what the end user could do, e.g. can't install apps, can't remove profiles, can't set up wifi etc.

We now want to remove some of these restrictions and I can't remove the original profiles. In attempting to remove a profile from the phone via IPCU (on the same computer that originally set them up), the following errors occur:

"The configuration profile could not be removed from the device".

The console log in IPCU shows:
Mon Nov 29 16:06:54 unknown mcmobiletunnel[518] <Warning>: MC|Error: NSError 0x11bd30:
Desc : The profile Profile Name does not have the expected certificate for removal.
US Desc: The profile Profile Name does not have the expected certificate for removal.
Domain : MCInstallationErrorDomain
Code : 4008
Type : MCFatalError
Params : (
"Profile Name"
Extra info:
isPrimary = 1;

How can I remove these profiles to allow the users to do more?
iPhone 3GS, Windows XP, IPCU 3.1
  • Bonesaw1962 Level 4 Level 4 (1,200 points)
    Currently Being Moderated
    Dec 15, 2010 8:37 AM (in response to Shaun K)
    We were told if you set removal to "never" the profile couldn't be removed from the device, only from the same computer( and IPCU instance) that installed it. It's disturbing that now they can't be removed by the same computer with the same instance of IPCU. It sounds like the only option would be to "hard reset" (when i say this, I mean, in the IOS world, "erase all content and settings"). The only problem is that we've found that if the end users have backed up their devices, the profile is included in the backup. This means if you erase all contents and settings, then restore the device from backup, the profile will come back.
    Dell, Windows XP
  • DocDavexyzzy Calculating status...
    I hate to burst any bubbles here but I have the removal value set to password, I am using the same computer and the same instance (unfortunately updated to most recent version) of IPCU and I get the same error. It would be great if I could remember the password (I can probably find it somewhere) but the thing that scares me is that IPCU and the iPad both know the correct name of the profile and it isn't "Profile Name"
    anyone, Windows ME
  • Krzzna Calculating status...
    Currently Being Moderated
    Dec 28, 2010 9:40 AM (in response to Shaun K)
    Facing similar issues with IPCU. Currently, i am working with 50 ipads, the number has been increasing for me from 2 ipads to 50 now and probably going to 100. I would like to use a Mobile Device management tool like Mobile Iron or so now to configure these devices OTA. All the profiles for the 50 ipads are set to never remove and they are all flying somewhere in US now.
    How do i transfer the iPCU from my machine to another machine, or may be transfer to a MDM.
    It looks like, no one at Apple monitors these discussions.
    Hello Apple, is this the response you give for people trying to make more money for you?
    Lack of proper Enterprise outreach can kill Apple at some time....
    Lenovo, iOS 4, Windows 7 and MacOSX
  • chubbychoc Calculating status...
    Currently Being Moderated
    Jan 17, 2011 6:20 PM (in response to Shaun K)
    I reiterate the guys comments above - Apple lift your game!

    I am also having issues and I believe it is because I have upgraded the IPCU on the PC where these were originally created.

    All my profiles now have a password but it doesn't help with the earlier ones that were created before this "gotcha" was discovered.

    Someone from Apple please respond?

    Windows 7
  • McDom Calculating status...
    Anyone have any further resolution from Apple on this one?

    I'm at the tail end of a pilot for acceptance of iPads into our enterprise as an accepted mobile device; I discover today that I can't update or remove profiles now. This may be a deal breaker for us...

    The only change on the PC I set them up from is that I have upgraded IPCU.
    iPad, iOS 4
  • Alexroet Level 2 Level 2 (320 points)
    Currently Being Moderated
    Apr 5, 2011 5:53 AM (in response to McDom)
    I am a user, who's run in to this problem... I installed the profile, without fully realizing what I was doing (i.e. committing myself to an 8 character device password that can't be disabled)- and now I want to get rid of it. Unfortunately, I backed up in the meantime. (usually i don't think backing up is a bad thing). so last night I restored it from the backup, but the profile is still there. I need it OFF! there must be some way, short of just setting it up as a new device?!

    If I could somehow pull an older backup out of Time Machine, could that work? I'm not sure if that's even possible... i don't know where backups are stored. And, of course, my Time Machine crashed last night. But I have a SuperDuper backup from last week... any chance that could save the day? The only other saved backup I have is from September,and I don't want to go that far back...
    20" iMac (Intel 2.33), MBA 1.8/80, Mac OS X (10.6.5), AEBS, AX, iPhone, iPad, iMac, AppleTV
  • mgm612 Calculating status...

    I had a problem similar to this and turns out I was using a newer version of the configuration utility(IPCU).  I reinstalled the older version of the utility and I was able to remove the profile.  I had to search online to find the older versions but I found them.  I had updated to version 3.3 but had to go back to 3.2 to remove the profile.

  • Jeff_B_ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 16, 2012 6:36 AM (in response to Shaun K)

    I had the same problem as you. I've followed mgm612's suggestion and downloaded all versions of IPCU that I could find:


    3.1 : ipcu-3-1-mac-windows/ 

    3.2 : 1666367.html

    3.3 :

    3.4 : 0969175.html


    then uninstalled IPCU 3.5 and started to test with 3.1 and went up one version at a time until I reached version 3.4 which allowed me to uninstall the configuration profile from my device...


    Don't know about you but I find that Apple pretty much dropped the ball with this and many other issues *such as recurrent Outlook event...) . Being unable to remove a configuration profile from your device because you've updated your software is absolutely ridiculous!


    Good luck to others!

  • MR650 Calculating status...
    Currently Being Moderated
    May 7, 2012 11:35 AM (in response to Jeff_B_)

    Remove using the PC where you installed the profile. 


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.