Skip navigation

"Press Run to run this script..." confirmation started appearing...why?

7745 Views 20 Replies Latest reply: Jul 30, 2013 10:31 AM by Bill Eccles RSS
1 2 Previous Next
Network 23 Level 6 Level 6 (11,505 points)
Currently Being Moderated
Nov 26, 2010 11:23 PM
I've got a set of AppleScripts I run from Spotlight, and all of a sudden they run with a confirmation alert that I've never seen before. Upon launch, each of these scripts puts up an alert that says "Press Run to run this script, or Quit to quit." So I gotta hit a button before the script will continue running.

I did a web search on it, and they all said the same thing: You saved your script with the Startup Screen option on. But I didn't! They've been running headless for months, some for years, and none of them started displaying the confirm dialog until now. I even opened and resaved them with the Startup Screen option off (it wasn't even checked when I went to resave them) and they still do this.

I guess I'll try fixing permissions unless somebody has a better idea. As far as I can tell, I've done everything right.
Mac Pro, MacBook Pro, iPhone 3GS, Mac OS X (10.6.5), PowerBook G4 15" Al, PowerBook G3 FireWire, PowerCenter Pro, PowerBook 160
  • red_menace Level 6 Level 6 (14,275 points)
    I believe the setting for that dialog is in the applet.rsrc file in the Contents/Resources/ folder of the application bundle. You might check to see if there is a problem with that file - note that the Disk Utility permissions repair doesn't do anything in a user account, or with applications that aren't installed with an Apple installer (e.g. drag and drop).
    MacBook Pro, Mac OS X (10.6.4), (and various older stuff keeping dust off the shelves)
  • red_menace Level 6 Level 6 (14,275 points)
    I don't know the format of the .rsrc file (you can use TextWrangler to get a hex dump), just that it is different when the options are changed and if it is not there you will get the confirmation dialog. I was thinking that if there was some kind of corruption or you couldn't read the file it would act the same way. If a new blank script application does the same thing, you might try from a new user account to see if it is something in your user preferences vs the system.
    MacBook Pro, Mac OS X (10.6.4), (and various older stuff keeping dust off the shelves)
  • osimp Level 1 Level 1 (120 points)
    You're dealing with scripts saved as applications, correct?
    I've encountered this issue in a somewhat different context, and I suspect that red_menace is correct that it has to do with the .rsrc file in the resources folder -- but I haven't figured out a "direct" fix.

    No guarantees, but try this:

    • Display the main script on the desktop by dragging the applet to whatever script editor you are using.

    • From the script editor menu (top of screen) select "file > save as." You'll get a drop down window over the script, showing the name of the original applet (without the name extension ".app"). Leave the name alone or change it as you wish. In any event, save the "save as" script as an application bundle in the same location as the original applet (e.g., desktop). If you didn't change the name, you'll have to choose to replace the original applet with the "save as" version; if you did change the name, you'll retain the original and get another with the new name.

    • At this point, double-click on the applet with the new name (if that's the approach you took); otherwise, double-click on the replacement applet. Do you still get the "Press Run to run this script..." message??

    As I said, no guarantees, but I'll be most interested in what you find.
    2.7G5 AND OTHERS, Mac OS X (10.4.11)
  • osimp Level 1 Level 1 (120 points)
    Very strange indeed.
    2.7G5 AND OTHERS, Mac OS X (10.6.3)
  • walkie84 Calculating status...
    I am having this exact same problem. I just (finally) updated to 10.6.5 yesterday, so I'm suspicious that this is the cause. Like the OP, all of my applescripts now pop-up this dialog. I have tried re-saving them, ensuring that the "Startup Screen" is not selected, but this has not fixed the problem.
    MacBook Pro, Mac OS X (10.6.5)
  • red_menace Level 6 Level 6 (14,275 points)
    You might try creating a new account and see if the behavior continues there. This may indicate a system vs user issue.
    MacBook Pro, Mac OS X (10.6.4), (and various older stuff keeping dust off the shelves)
  • jeremynk Calculating status...
    Hi there,

    Just following this up to see if there was a solution? I have the exact save problem - intermittently and seemingly without any direct cause. Any luck?

    Thanks
    MacBook Pro, Mac OS X (10.6.6)
  • Barry Margolin Calculating status...
    This just started for me, too. I have a script in my non-admin account that I've been using for over a year, and today it started popping up this dialogue. I tried re-saving it and making sure the Startup Screen option is unchecked, but it didn't help.

    I have an almost identical script in my admin account, and it doesn't do this.
    iMac, Mac OS X (10.6.6)
  • Barry Margolin Level 2 Level 2 (430 points)
    I just installed the 10.6.7 update and the prompt went away. I don't know if it was because of the update or just the reboot.
    iMac, Mac OS X (10.6.7)
  • fedeboraxx Calculating status...

    Well just in case anyone is still wondering about this, I think I figured it out. Make sure whatever app you're using to trigger the script (Alfred in my case) does not use the CONTROL Key as part of the keyboard shortcut. That fixed it for me

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.