Skip navigation
This discussion is archived

USB storage unavailable after 7.4.2 upgrade

43964 Views 117 Replies Latest reply: Dec 17, 2010 10:04 PM by ssphotodesign RSS
  • Marly Thomas1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 15, 2010 3:41 PM (in response to DDDDan)
    Just applied the 10.6.4 update, reset my airport extreme firmware to 7.4.2, and ran a time machine backup. Time machine could not find the external drive connected to the airport extreme. Downgraded to 7.4.1 and backup works fine, connects the external drive automatically.

    So far after the 10.6.3 update I have not had one finder error. But the connect to external drive for Time Machine backups is still an ABSE 7.4.2 firmware bug.
    Macbook, iMac G5, 2 G4 Mac Mini's, ABSE, Apple TV, Mac OS X (10.6.3)
  • Gnat999 Calculating status...
    Currently Being Moderated
    Sep 10, 2010 4:37 AM (in response to rbeer)
    Many folks have discussed this issue, so I'm not sure that adding my comments at this time will be productive. But, the change from 7.4.1 to 7.4.2 did two things to my network. It improved the ability of the AEBS to move data (I've got an Apple TV, iPod Touch and Macbook all using the Airport wireless) and it made the attached USB hard drive more susceptible to being dropped. When this happens neither my iMac (attached via ethernet cable) or Macbook can see the back up hard drive. The Time Machine system fails until I unplug and replug the USB connection to the hard drive. Once I do that the AEBS advertises the presence of the hard drive again and all is well until some time later and the connection is lost again.

    The improved networking capability of 7.4.2 keeps me using that firmware, but it gets frustrating. Surely some smart soul at Apple will take pity on us and figure out what conflict is causing that problem... Thanks for listening.
    Macbook, Mac OS X (10.6.4), AEBS, iMac, Apple TV...
  • umo Calculating status...
    Currently Being Moderated
    Sep 10, 2010 7:56 AM (in response to rbeer)
    Same problem here, nothing much new to report, but thought I would add to the list. 7.4.2 definitely improves other network connectivity issues, mainly AirTunes for me, but makes any attached usb disk un-useable. USB drives do work after an unplug and replug, but always only for a brief period of time. 7.4.1 didn't have this problem, but AirTunes was really unreliable with 7.4.1 here. Tried tons of different settings, older firmwares, and nothing seems to give decent performance for both of those things. Here's hoping for a fix...
    MacBook Pro, Mac OS X (10.6.4)
  • jimmybagwell Calculating status...
    Currently Being Moderated
    Sep 11, 2010 8:57 PM (in response to umo)
    I see many folks downgrading to prior firmware versions to get around this problem while (hopefully) Apple sorts it out...how do you do that?
    iMac
  • Gnat999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 14, 2010 7:20 PM (in response to jimmybagwell)
    Within AirPort Utility under the Base Station menu item, choose Upload Firmware... Choose a previous version (I have 7.4.1, 7.3.2, 7.3.1, 7.2.1, etc. listed) and choose OK. I've only tried 7.4.1, but others have used other versions without fixing the problem. Good luck.
    Macbook, Mac OS X (10.6.4)
  • tbharber Calculating status...
    Currently Being Moderated
    Oct 25, 2010 3:17 PM (in response to rbeer)
    I have had this issue for some time now but just finally got around to Googleing to find this thread and the answer. I have an Airport Extreme (802.11n model) with an external hard drive connected to it via USB. My connection to the drive seems to drop when I am moving large files or streaming video from the drive to my Macbook or Apple TV.

    As with many of you I get the "Connection Failed" error and the only fix seems to be unplug/plug the USB cable for the hard drive or reboot the AE. This issue has got more annoying recently because I have moved all of my movies onto the external drive so it drops during every movie.

    After trying everything under the sun including replacing the drive it seems the issue is defiantly the Airport Extreme. I reverted the firmware back to 7.4.1 and as of right now it seems to have fixed the issue with the drive dropping.

    The problem I have now is due to reverting the firmware my Airplay is no longer working correctly. Now when I goto play a song from my Macbook to the Apple TV my iTunes hangs with the error "Connecting to Apple TV."

    I am extremely disappointed to see this problem has been going on for over a year and is clearly a software issue but Apple has not provided a fix for yet. I was going to upgrade to a Time Capsule but am definitely not going to now because 1. It may have the same problem, and 2. Why would I want to purchase something from a company who doesn't support its users after they buy something.

    It would be one thing if this was some $20 cheap-o router but considering it is one of the most expensive on the market this is unacceptable. I would also understand if this issue just came up but I have found threads all over the internet for this exact issue going back a year and a half. They have had plenty of time to fix the problems.

    I really want to support Apple. I love my Apple TV, iPhone, iPad, Macbook, and Macmini. It is just a pain in the *** that everything is not working correctly together. I like the Apple ecosystem because of the integration of being able to stream my movies to my TV and control it via the remote app on the iPhone, but it is irrelevant because it doesn't even all work correctly.

    Please don't let me down Apple!
    Macbook, Mac OS X (10.4.6)
  • tbharber Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 30, 2010 10:40 AM (in response to tbharber)
    Just wanted to give an update since my last post...

    Since downgrading to 7.4.1 it defanetly fixed my drive dropping issue. I still had glitches now and then when using Airplay. After dealing with it's headaches for a couple days I decided to downgrade AGAIN to 7.3.2 like others have suggested. 7.3.2 did not show up in the firmware list like it did before so I had to upgrade to 7.4.2 then downgrade to 7.3.2.

    Since doing this it is working much better. I had an issue once with the remote Apple tv speaker not picking up the audio but after turning it off and back on it worked fine.

    In closing it seems 7.3.2 is not perfect but the way to go for those with the same issues. Due to the headaches I have decided to go with a Netgear/Linksys router in the future instesd of purchasing a time capsule but for now the couple year old firmware will have to due.
    Macbook, Mac OS X (10.4.6)
  • ssphotodesign Calculating status...
    Currently Being Moderated
    Nov 22, 2010 12:11 PM (in response to tbharber)
    Really apple? we have to downgrade our equipment to get decent functionality?
    Macbook Pro 15 2.53, PMAC G5 Dual 2.0, Mini 1.25 G4, 2x Mini Server 2.53, Mac OS X (10.6.4), iBook G3 500 running X Server, AEBS, Express b/g, Express N, AppleTV, Touch Gen1
  • Gnat999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 25, 2010 5:24 PM (in response to ssphotodesign)
    Well I've downgraded to 7.4.1 for awhile and get really annoyed when Time Machine backups are running and my email can't connect or Safari loses internet access. With 7.4.2 running on the AirPort Extreme there is no break in other network access when Time Machine is running. That's a really handy thing and I miss it so much I keep going back to 7.4.2 to try ways of reconnecting to the USB drive. I've come up with this method.

    When you lose connection log into the AEBS using AirPort Utility and click Manual Setup then choose the Disks tab, then File Sharing. Click off Enable File Sharing and Update the AEBS. When the AEBS comes back re-enable file sharing and update. It's not pretty, but better then running downstairs and unplugging the drive and re-connecting it and hoping that does the trick... Apple, please help us out and take another look at the firmware changes between 7.4.1 and 7.4.2 and upgrade using the best of both. Thanks.

    Nat
    Macbook, Mac OS X (10.6.4), & lots of other Apple stuff...
  • Gnat999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2010 4:54 AM (in response to Gnat999)
    Of course there is also Restart... But neither of these is sufficient when other devices depend on the internet connection and now that is out until the AirPort Extreme restarts.

    I've moved my Time Machine back up disk to hang off my iMac instead and continue to use 7.4.2. I realize the intent of the AEBS firmware changes which is to promote a purchase of a Time Capsule. I'm content to have a backup available through Time Machine and the AEBS works well doing what a wireless router is supposed to do.
    Macbook, Mac OS X (10.6.4)
  • Some_air Calculating status...
    Currently Being Moderated
    Dec 1, 2010 8:28 PM (in response to Gnat999)
    does 7.5.1 have the same issue with 7.4.2 as I seem to be having the drive connection drop as well when transferring larger files.
    Voodoo Envy 133, Windows 7
  • Gnat999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2010 4:59 AM (in response to Some_air)
    I don't know about 7.5.1 as that has not been available as an upgrade for my AE (older generation I guess).

    However, it was a pleasure to see the notice of updated AE firmware (to 7.5.2) and Apple Utility software (to 5.5.2) yesterday evening. I've made the upgrades and switched the Time Machine hard drive back to hang off the AE USB port. So far so good... Thank you Apple!
    Macbook, Mac OS X (10.6.5), delighted AE user and other Apple products
  • ssphotodesign Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2010 10:04 PM (in response to Gnat999)
    here, here!
    Macbook Pro 15 2.53, PMAC G5 Dual 2.0, Mini 1.25 G4, 2x Mini Server 2.53, Mac OS X (10.6.4), iBook G3 500 running X Server, AEBS, Express b/g, Express N, AppleTV, Touch Gen1
1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.