Skip navigation

UPS unrecognized

4102 Views 10 Replies Latest reply: Jun 22, 2013 8:50 AM by wintersgrass RSS
xaruqui Calculating status...
Currently Being Moderated
Dec 16, 2010 11:05 AM
Hi! I don't know If I have to write this post in this category, well, let's try it. I bought a Riello UPS, downloaded lastest soft from official website (10.5) and Installed it, but doesn't recognize my UPS. Software doesn't run in background (I checked it in System Monitor).

I connect it with USB directly to my iMac, I tried 2 different cables, but nothing happens. When I start manually UPSView it can't find the UPS.

I surfed the web looking for some info, but I found nothing. A workmate bought the same UPS, he's running 10.6 and neither worked.

There aren't Riello Forums and support is only for resellers... I don't know what to do!! Any idea of whats happening??
iMac24" & MacMini & MBP 13'3 & iPhone 4, Mac OS X (10.6.1)
  • Kappy Level 10 Level 10 (221,010 points)
    Currently Being Moderated
    Dec 16, 2010 12:17 PM (in response to xaruqui)
    Either contact the manufacturer's or vendor's tech support. Their software is apparently not compatible. Consider returning it and buying an APC device instead.
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; 11" MBA, Mac OS X (10.6.4), iMac C2D 17"; MB 2.0 Ghz; iPad 32G; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Dec 16, 2010 3:38 PM (in response to xaruqui)
    See what the maker's instructions say.

    You may not need their software at all -- OSX has UPS support built in, at least for those UPS systems that behave normally.

    Try uninstalling it -- some UPS software (APC's for example), actually prevents OSX from handling a power failure properly (on Leopard or later).

    See [Using a U.P.S. System with a Mac|http://web.me.com/pondini/AppleTips/UPS.html].

    It may not matter, but what version of OSX are you running? This is the Leopard forum, and you say you've downloaded software for Leopard, but your signature says you're running Snow Leopard.
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.5), dual-band AEBS v. 7.4.2 iWeb 3.0.2
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Dec 18, 2010 12:24 PM (in response to xaruqui)
    xaruqui wrote:
    Pondini, That's awesome! BUT, Leopard doesn't support this UPS...


    How do you know that?

    You can tell if OSX recognizes the UPS, via +System Profiler.+ Click the Apple logo at the left of your menubar, select +About This Mac,+ then +More Info.+

    Click USB in the sidebar, and look in the center to see if your UPS is listed. If it is, and the software that came with it isn't working, uninstall it, and Restart your Mac. OSX may work with it.

    So, after reading this I understand less than before. It seems that USB is supported!!


    Yes, a USB link is supported, but that doesn't say the software will work with Leopard.
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.5), dual-band AEBS
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Dec 18, 2010 12:42 PM (in response to xaruqui)
    xaruqui wrote:
    Actually, I already tried this before opening the thread and it doesn't appear anywhere.


    Then there must be a problem with the UPS, the USB cable, or the port on your Mac.

    Try different USB cables, ports, and combinations of the two (a plug that works fine in one port may not quite make contact in another).

    If it's still unrecognized, exchange or return it.
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.5), dual-band AEBS
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Dec 18, 2010 12:51 PM (in response to xaruqui)
    xaruqui wrote:
    . . .
    For sure it's heavy enough to break some bones if well throwed.


    Probably not the best approach

    Thanks a lot.


    You're quite welcome. Keep us posted.
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.5), dual-band AEBS
  • PeterLboro Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 13, 2011 5:09 AM (in response to Pondini)
    I had similar problems with a Riello iPlug 800VA and UPSMON 5.1.0 for Mac OS X 10.6. I installed the software but it couldn't see the UPS from my iMac using a USB port that had worked fine with a previous APC UPS.

    I got it working in the end by uninstalling/deleting my previous attempts and reinstalling whilst logged into an admin account. My "mistake" was installing the software initially in my standard account and then trying to reinstall over this in my admin account. Even though it was reported as a successful installation on both occasions, clearly it wasn't as it didn't work!

    A significant stupidity of the UPSMON software is the need to input a "PRTK code" during installation. There is no warning about this and the suggestion of where to find this code on the UPS and/or its box is WRONG. It is NOT on the UPS nor its box and it is not any of the 3 numbers that can be found on both! Nor is it anywhere obvious on the Riello web site. Only if you jump to the Mac pages in the 83 page manual (a separate download to the software), will you find what is needed, i.e the PRTK code "GPSER11201RU" (for the Riello iPlug series)! Who the heck scrolls through a separately downloaded manual before running a standard Mac installer to find a critical install code you're not warned about?!

    When installed UPSMON provides 3 programs: "Ups Wizard", "Upsetup" and "Upsview". However, NONE of these can be used in a standard account, only in an admin account. In fact if you "Show Package Contents" for any of these, then change the permissions for the Contents folder (and its contents) from "No Access" to "Read Only", you can use these from a standard account. Upsview is particularly important as it is the only way of seeing the status of your UPS since the Riello and UPSMON do not provide any support for the Energy Saver panel (unlike APC).

    I now have Upsview working from my standard account and I can check that the UPS is functioning correctly. However, if I want to change any of the UPS parameters, I have to run "Ups Wizard" or the very opaque "Upsetup" and then, by unspecified means, restart the UPS agent, i.e. do a system restart!

    So it works, but the process is FAR WORSE than it should be and compares poorly with APC's Mac support. I just hope the Riello UPS proves to be as good or better than the APC UPS I've just replaced!

    Regards

    Peter
    iMac 27" i7, Mac OS X (10.6.6), Riello iPlug 800 UK UPS, UPSMON 5.1.0 for 10.6
  • wintersgrass Calculating status...
    Currently Being Moderated
    Jun 22, 2013 8:50 AM (in response to PeterLboro)

    Thanks for this. Had the same problems trying to get this working on OSX 10.8. This worked perfectly. Software needs to be installed as root but nowhere does the manual mention this.

     

    Thanks,

    Rob

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.