Skip navigation

iMovie on iPhone 4 has lost links to my clips!

2634 Views 5 Replies Latest reply: Dec 27, 2010 6:42 AM by Atlanta Yankee RSS
John North1 Calculating status...
Currently Being Moderated
Dec 1, 2010 7:36 PM
I spent hours editing my iMovie on my iPhone 4, showed it to my wife once. Now when I go to the movie on my iPhone it is there, but all the clips have a yellow triangle with "!" inside. The movie plays but is just blank. I checked and all the clips are still in my iPhone. Why would it have lost the links to these clips and can I get them back into the edited movie? I did upgrade to OS 4.2 from 4.1 since I created the movie. Somebody please help me.
iPhone 4, iOS 4, recently updated to 4.2
  • Criac Calculating status...
    Currently Being Moderated
    Dec 3, 2010 9:53 AM (in response to John North1)
    Same thing happened to me after the update to iOS 4.2. Did you try restoring your phone from a backup? I am not pleased with the media management in iMovie.
    iPhone 4, iOS 4, iMovie for iPhone
  • Hugoniot Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 11, 2010 8:46 AM (in response to Criac)
    I have only encountered this if I remove the event with the videos from the phone, then later add the event and videos back to the phone. I can see the videos in the Photos app, and any still images appear in my timeline, but no videos.

    I had hoped to do some additional editing to my movie after I freed up space. Sad.
    IPhone 4, iOS 4
  • glassbygarrett Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2010 11:31 AM (in response to Criac)
    i tried removing imovie app from the phone, then re loaded it
    that worked for a few days
    now imovie is not recognicing the clips at all for several minutes, then after a few minutes the recent clips show up blank with caution sign
    i have never ' restored' my phone and am a bit concerned - last note - none of this happened until i upgraded to 4.2
    thanks
    g
    iphone, iOS 4
  • Hugoniot Level 1 Level 1 (5 points)
    Interesting. I never tried this until recently, so I can't say if it has anything to do with the 4.2 update.
    iPhone 4, iOS 4
  • Atlanta Yankee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2010 6:42 AM (in response to John North1)
    I noticed this problem recently as well but it now makes sense that it was probably the recent iOS updates. I built my movie back in the summer and had been playing it for family and friends for awhile until recently I tried to export a high-quality version and the iMovie app alerts me to missing clips. I was dumbfounded to say the least.

    I've confirmed that my missing clips are still available on my phone and MORE INTERESTING TO NOTE is that some clips in my movie have been replaced (incorrectly linked) to other video clips in my library that were never part of the original movie. Weird.

    Apple, any help here would be appreciated.
    iPhone 4, iOS 4, iMovie app

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.