Skip navigation

10.6.5 and MySQLCOM not starting

23881 Views 23 Replies Latest reply: Feb 4, 2011 2:03 AM by happysmile RSS
1 2 Previous Next
eddy kestemont Level 2 Level 2 (475 points)
Currently Being Moderated
Nov 11, 2010 12:46 AM
Automatic startup of MySQL server under 10.6.5 doesn't seem to work although MySQL can be started manually.
On startup (or fast user switching) following alert is displayed:

Insecure Startup Item disabled.
“/Library/StartupItems/MySQLCOM” has not been started because it does not have the proper security settings.

Any ideas ?
(No update yet seen on MySQL site)
MacBook Pro Core 2 Duo, MacBook Core 2 Duo, PowerBook G4, iMac G4, iMac G3, Mac OS X (10.6.4), 2.33 GHz 3 GB RAM disk 160 MB, iPhone 3G 4.0.2
  • catalinpetrisor Calculating status...
    Currently Being Moderated
    Nov 11, 2010 2:20 AM (in response to eddy kestemont)
    I experienced the same minutes ago and this is what I found in Console All Messages:

    /System/Library/CoreServices/SecurityFixer.app/Contents/MacOS/SecurityFixer[617] "/Library/StartupItems/MySQLCOM" failed security check: not owned by GID 0

    So what I did was:
    sudo chown -R root:wheel /Library/StartupItems/MySQLCOM

    After that I logged out and found this message in Console All Messages:

    SecurityFixer[912] No insecure startup items found!

    So I guess problem is solved.
    Hope it helps. Good luck!
    iMac
  • debenriver Calculating status...
    Currently Being Moderated
    Dec 15, 2010 2:36 PM (in response to eddy kestemont)
    I have the same problem and your suggestion fixed it – no startup message. Except that I cannot get MySQL to start up at all! On Terminal I get "can't connect to MySQL server through socket 'tmp/mysql.sock'. I changed the php.ini defaults from /var/mysql/mysql.sock to /tmp/mysql.sock but this hasn't made any difference.

    I have previously installed it and had it working on both my macs with earlier systems (10.4 and 10.5). I have just done a complete erase and re-instal of 10.6 on the MacBook, which is why I need to re-instal MySQL etc. So it is a very clean instal.

    I installed the 64 bit version of MySQL (I also tried the 32 bit version - but same problem).

    Any help would be much appreciated - George
    imac and MacBook, Mac OS X (10.6.5), both Intel Core 2 duo
  • Riquez Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 19, 2010 3:47 AM (in response to debenriver)
    I have the same problem debenriver, mysql.sock is not on the system anywhere i can find & cant start mysql.

    I've installed mysql countless times on os x & ive even had this mysql.sock issue before, but this time (new iMac i3 10.6.5) something else is awry & i'm stuck too.
    iMac i3 3.2Ghz, Mac OS X (10.6.5)
  • Riquez Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 19, 2010 5:44 AM (in response to Riquez)
    ok, somehow my install is now working. sort of.

    I say "somehow" because for about 4 hours I have been trying to find a solution & nothing was working. I didnt really make many significant or sensible changes, mostly googling & nothing was working or seemed to fit - then after pondering for 20 mins I suddenly noticed my mysql system pref window in the background was green & said "running"

    I know this isnt entirely helpful, but here are the few changes i made in terminal... in order..

    i didnt have /etc/php.ini
    +$ sudo cp /etc/php.ini.default /etc/php.ini+
    then i changed the 3 refs to mysql.sock to /tmp/mysql.sock in the new php.ini file
    & chmod to 666

    I tried to start mysql using this
    +$ sudo /Library/StartupItems/MySQLCOM/MySQLCOM start+
    Password:
    Starting MySQL database server

    (seemed to work but wasnt)

    Then I cd'd to /usr/local/mysql
    +sudo chown -R mysql data+

    $ ./mysql start
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

    ****!

    +$ sudo /usr/local/mysql/bin/mysqld_safe --user=mysql &+
    $ 101219 21:44:46 mysqld_safe Logging to '/usr/local/mysql/data/oberon.local.err'.
    101219 21:44:46 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data

    above might be it?

    +$ sudo ln -s /usr/local/mysql/run/mysql_socket /var/mysql/mysql.sock+
    Password:
    ln: /var/mysql/mysql.sock: No such file or directory

    Then I noticed mysql was running, so maybe in safe mode. Its a start.

    At this point I was able to set root password
    $ ./mysqladmin -u root password "****"

    mysql is running, i can connect using SequelPro. I have yet to see if it will stay up after reboot.

    Never been though this much pain with mysql before, ive installed it on os x 30+ times & even with old mysql.sock probs its never been like this. im officially stumped this time.
    iMac i3 3.2Ghz, Mac OS X (10.6.5)
  • Riquez Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 19, 2010 4:33 PM (in response to Riquez)
    sigh
    it still didnt work after re-boot. I began to think that mysql 5.5 is just not playing well with OS 10.6.5

    I removed mysql & installed version 5.1.49 - worked fine, no problems.

    To remove mysql:

    sudo rm /usr/local/mysql
    sudo rm -rf /usr/local/mysql*
    sudo rm -rf /Library/StartupItems/MySQLCOM
    sudo rm -rf /Library/PreferencePanes/My*
    edit /etc/hostconfig and remove the line MYSQLCOM=-YES-
    sudo rm -rf /Library/Receipts/mysql*
    sudo rm -rf /Library/Receipts/MySQL*
    sudo rm -rf /var/db/receipts/com.mysql.*
    MacBook Pro 2.4Ghz 4GB RAM, Mac OS X (10.5.2)
  • Kemi Eke Calculating status...
    Currently Being Moderated
    Dec 21, 2010 7:34 PM (in response to eddy kestemont)
    Had exactly the same problem on OS X 10.6.5 with the 64bit build of MySQL server 5.5.8 as Debenriver and Riquez. Tried different tacks to get it to work to no avail. Downgraded MySQL server to the 64 bit build version 5.1.54. It installed and ran perfectly first time. Thanks Riquez for the deinstall sequence.
    Mac Mini 2010 2.4 Ghz 8GB RAM, Mac OS X (10.6.5)
  • Christopher Alemany Calculating status...
    Currently Being Moderated
    Dec 21, 2010 10:32 PM (in response to Riquez)
    I've had exactly the same problem with 5.5

    It all worked great right after installing it. However as soon as I restarted things started to go bad.

    The service did not restart automatically... "unauthorized" it says, and then I could not restart it using the

    sudo /Library/StartupItems/MySQLCOM/MySQLCOM start

    command

    I fiddled around with the /etc/my.cnf file and the local /usr/local/mysql/my.cnf and tried again and it worked!

    But then I restarted and once again no joy.

    Worse, now no matter what fiddling I did, it simply would not start.

    After some further googling I tried the old fashioned way of starting mysql:

    sudo /usr/local/mysql/bin/mysqld_safe

    And it worked the first time.

    So moral of the story... I personally think the startup script is no good. Maybe I'll take a look at it tomorrow morning.

    Hope that helps a few people. This is with the newest 64bit mysql pkg from mysql community 5.5 distribution on Mac OS X Server 10.6
    XServe Intel, Mac OS X (10.6.5)
  • outoforderorder Calculating status...
    Currently Being Moderated
    Dec 22, 2010 1:42 PM (in response to Riquez)
    thanks Riquez - uninstall and reinstall of 5.1 works at least - wasted too much time trying to figure out 5.5 wont work!
    MacPro 8 core 2.8ghz | 15"MacBook Pro 2.2ghz | 23" ACD, Mac OS X (10.5.6), 10 gb NVIDIA GeForce 8800 GT | 4gb ram 128 NVidia
  • gauvins Calculating status...
    Currently Being Moderated
    Dec 23, 2010 10:48 AM (in response to Riquez)
    Thanks Riquez.

    Same problem. Tried workarounds that didn't solve anything.

    Down to mySql 5.1.54
    iMac, macPro, MacBook, Mac OS X (10.5.5)
  • João Paraná Calculating status...
    Currently Being Moderated
    Dec 23, 2010 11:02 AM (in response to catalinpetrisor)
    Tanks catalinpetrisor. MySQL works fine for me now.

    I executed :

    sudo chown -R root:wheel /Library/StartupItems/MySQLCOM
    Mac Mini 2.26 GHz, Mac OS X (10.6.5), GPU: NVIDIA GeForce 9400
  • Jay Khimani Calculating status...
    Currently Being Moderated
    Dec 25, 2010 5:24 AM (in response to catalinpetrisor)
    Thanks caalinpetrisor. Your solution worked.
    MacBook Pro 13, Mac OS X (10.6.5)
  • debenriver Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2010 7:49 AM (in response to eddy kestemont)
    Thanks to all who replied. I finally worked out a schema that worked! Here it is in the order I did it:

    Activate PHP

    Use a text editor that will find hidden files (like TextWrangler)

    Navigate to /etc/apache2/httpd.conf

    Find and uncomment (take away the #) the line: #LoadModule php5_module libexec/apache2/libphp5.so

    Go to /etc/php.ini.default

    Open and save a copy in the /etc directory as php.ini

    Open php.ini

    Find ;date.timezone =

    Uncomment (take away the and enter your time zone – such as America/New_York (find time zones at http://php.net/manual/en/timezones.php)

    Find:

    pdomysql.defaultsocket= /var/mysql/mysql.sock
    mysql.default_socket = /var/mysql/mysql.sock
    mysqli.default_socket = /var/mysql/mysql.sock

    And change to:

    pdomysql.defaultsocket=/tmp/mysql.sock
    mysql.default_socket = /tmp/mysql.sock
    mysqli.default_socket = /tmp/mysql.sock

    Go to System Preferences and turn on Web Sharing (if it is already on, turn it off and then on again)

    Make a note of the path to your personal website (it will be something like http"//macintosh.home/~yourname/)

    To test whether PHP is working make a simple PHP file with this single function:

    phpinfo()

    Save it as, say, phpinfo.php in your Home Directory/Sites. Then open it in your browser (something like http://macintosh.home/~yourname/phpinfo.php). This should come up with the PHP configuration of your PHP. If it comes up with the code instead, then PHP is not working.

    MySQL

    Download MySQL, Community Edition for Mac OS X ver. 10.6 (x86, 64-bit), DMG Archive. If you have an older 32-bit machine, use the 32-bit download.

    Open the disk image. Install (in order) mysql-5.5.8-osx10.6-x86_64.pkg, MySQLStartupItem.pkg, MySQL.prefPane. MySQL won't start at the moment.

    Open Terminal

    Type:

    sudo chown -R root:wheel /Library/StartupItems/MySQLCOM

    At this point probably best to do a restart.

    Open Terminal

    Type:

    cd /usr/local/mysql to navigate to the mysql interface.

    Type: sudo echo

    You will be asked for your computer admin password

    Then type:

    sudo bin/mysqld_safe &

    Then type:

    bin/mysqladmin -u root password 'xxxxxxxx' to enter a root password for the MySQL database (replace xxxxxx with your chosen password. This should probably be different from your computer password. Don't forget the single quotes). Logout of Terminal.

    Then look at System Preferences. Under "Other", click the MySQL button. It should say "The MySQL Server Instance is running". If you want MySQL to start on StartUp, check the box "Automatically Start MySQL Server on Startup"


    phpMyAdmin

    Download a suitable version of phpMyAdmin (I used phpMyAdmin-3.3.8.1-english.zip).

    Move the entire folder to Home/Sites. Rename the folder something a bit more user-friendly (I renamed mine to PMA).

    I used the Setup facility to produce config.inc. You can also hand code the config file from the sample file supplied.

    First make a new folder in the PMA directory called config. Set the permissions for this folder (Apple-I) to Read and Write for everyone.

    In your browser enter something like http"//macintosh.home/~yourname/PMA/setup

    Click New Server. I used the following settings:

    Server hostname: localhost
    Server socket: socket
    PHP extension: mysql
    Authentication type: cookie
    User for config auth: root
    Password for config auth: The password you set for user "root"

    Leave all the others blank.

    Hit the Save button. If it can't save it is probably because you haven't set permissions correctly for the config folder.

    You should now see your server #1, Name:localhost, Authentication type:cookie, DSN: mysql://

    Under Configuration File you should see:

    Default language: English (or the language you chose originally)
    Default server: localhost[1]
    End of Line: select Unix/Linux (\n)

    Hit Download. This should download config.inc to your config folder.

    Now go to the PMA folder (in Finder). Move config.inc out of the config folder into the main PMA foder. Throw away the config folder.

    In your browser enter something like http"//macintosh.home/~yourname/PMA

    You should get a screen asking for Username (root) and Password (the one you set). This will then go to the phpMyAdmin page where you will see the MySQL databases. Don't mess with the three MySQL databases. Don't use the database "test" because this is available to everyone. Instead use the "Create a new database" facility to make a new database and tables. Or use the SQL facility to do the same thing. You can set passwords and priveleges etc. for new databases.
    imac, Mac OS X (10.6.5)
  • ekkedesign Calculating status...
    Currently Being Moderated
    Dec 28, 2010 8:32 PM (in response to debenriver)
    I cannot thank debenriver and Riquez enough, and everyone on this forum. It is clear that MySQL 5.5 distribution from mysql.com is aimed at OS X Server edition, and is very problematic for the regular desktop version. Three days of frustration (and thinking I was losing my abilities), and of searching mysql.com's forums, all to no avail. Thank you, thank you thank you, all!
    24" iMac Intel Core 2 Duo, Mac OS X (10.5.6)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.