Skip navigation

VPN running but not responding to clients

8590 Views 14 Replies Latest reply: May 23, 2013 12:27 AM by einord RSS
Patrick Savelberg (Private) Calculating status...
Currently Being Moderated
Dec 30, 2010 5:51 AM
I have a MacPro 2008 with MacOs X Server 10.6.5
Have setup the server, and want to use VPN.

Setup LT2P, made a shared secret etc.
FireWall is turned off
VPN is running and vpnd is shown as process

When i try locally to setup a VPN connection, i keep getting LT2P Server not responding
When i do a port scan no port that uses VPN (500, 4500, 1701) are open.

i Use only one ethernet port.
Where to look, log is not shoming anything execpt listining ....
Multiple Systems, Mac OS X (10.6.5), MacOS X Server 10.6.5
  • Nachos Libres Level 4 Level 4 (1,205 points)
    Just to make sure - you don't have your starting and ending IP addresses for VPN overlapping or using the same IP addresses that you DHCP server hands out - do you?

    Also, can you post the output of $ sudo serveradmin fullstatus vpn
    Mac mini Server, MacBook Pro, iPad 3G, iPhone 4, Time Capsule, Mac OS X (10.6.5)
  • Nachos Libres Level 4 Level 4 (1,205 points)
    The only other thing I can think of is to make sure you have a DNS entry on your DNS server for the server hosting VPN and making sure you have the IP address of the DNS server entered under Settings and Client Information in VPN.

    It could also be that those ports are being firewalled but you already said your firewall wasn't running.
    Mac mini Server, MacBook Pro, iPad 3G, iPhone 4, Time Capsule, Mac OS X (10.6.5)
  • Leif Carlsson Level 5 Level 5 (4,950 points)
    You can't use Network Utility to scan for open UPD ports, you need something like nmap.

    Nothing in ppp.log?

    Entering login name exactly as it is entered in WGM/account from OD or Local db, use either the long name or the first short name.

    No SACL is used for the VPN service (default is SACL is not in place for VPN)?
  • Gordon Davisson Level 3 Level 3 (520 points)
    Check to make sure the shared secret is entered correctly (on both server and client) -- if it's wrong, you get the same error as if the server just isn't responding at all.
    MacBook Pro, Mac OS X (10.6.4)
  • kjelt Level 1 Level 1 (5 points)
    I am having the same problem...vpnd is sitteng there, listening, but does not react to any connection attempts (not even from the same machine)

    ppp.log says

    Sun Jan 23 01:28:51 2011 : L2TP connecting to server '' (
    Sun Jan 23 01:28:51 2011 : IPSec connection started
    Sun Jan 23 01:29:01 2011 : IPSec connection failed
    iMac 27, Mac OS X (10.6.6)
  • kjelt Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 24, 2011 7:22 AM (in response to kjelt)

    I had an error in the "shared secret" set-up, now its working without the advice above is true: check the authentication throughly, as errors here show up very much like no connection between client and server was established

    cheers, kjelt

    (I think, my testing it locally was senseless, that can't work in any case)
    iMac 27, Mac OS X (10.6.6)
  • MrHoffman Level 6 Level 6 (11,720 points)
    IP routing does not appreciate having the same subnet on both ends of a VPN.

    I'd get out of and subnets given the prevalence of those subnets on home WiFi and coffee shop networks and given the connectivity problems that the use of duplicate IP subnets causes for VPN IP routing, and preferably get your networks entirely out of the block, and preferably into a subnet somewhere in the or blocks.

    I'd also suggest adding a VPN-capable firewall.

    VPN pass-through with a NAT device is problematic at best. Add to that that various of the Apple Airport and Time Capsule devices have had various forum reports of firmware issues with VPN passthrough with L2TP over the years. And yes, these are among the reasons why I tend to go immediately to a server-grade gateway firewall device.
  • koa_noise Calculating status...
    Currently Being Moderated
    Feb 1, 2011 6:39 PM (in response to MrHoffman)
    I have had issues with this from the beginning. Just had the girl friend turn VPN off and then back on to get it to work since I'm out of town. Apple needs to fix this before they post sites like this...

    You do have to be a network guru to set up Snow Leopard server. Now if I could just get my Airport express to work with the server. Man!
    Macbook Pro, Mac Mini Sever, Mac OS X (10.6.6)
  • MrHoffman Level 6 Level 6 (11,720 points)
    Currently Being Moderated
    Feb 4, 2011 8:15 AM (in response to koa_noise)
    Welcome to the forums.

    Consider purchasing equipment suited for the task.

    Airport Extreme (AX) and Time Capsule (TC) are not what I would consider server-grade gateway devices; they're fairly feature-weak when server-oriented networking is involved.

    These Apple devices are NAT-based firewalls, and can be appropriate for home use.

    If you are planning to perform inbound connections typical of servers, these devices lack port-mapping flexibility, VPN end-point capabilities, multiple public IP addresses, and DMZ features.

    And FWIW, if you're going to operate with VPN pass-through and NAT using an AX or TC, there is an [Apple tech note (HT3944)|] around shutting off MobileMe on the AX or TC to get the L2TP VPN pass-through connections to function.
  • Jerry Z. Level 1 Level 1 (120 points)
    Currently Being Moderated
    May 21, 2011 6:30 PM (in response to MrHoffman)

    Brilliant! This is the document that I have been looking for and which clears up hours of frustration for me.



  • koa_noise Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2012 5:07 PM (in response to koa_noise)

    I'm happy to say that the VPN on my Snow Leopard server has been flawless over the last few months. Maybe the fix was through my Airport Extreme or the server either way this is awesome!

  • einord Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 23, 2013 12:27 AM (in response to MrHoffman)

    Fantastic! Thanks!


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.