Skip navigation

MACBOOK PRO & SNOW LEOPARD - OVERHEATING

112371 Views 248 Replies Latest reply: Apr 24, 2011 3:18 AM by Timiambeing RSS
  • oscalitoburito Calculating status...
    Currently Being Moderated
    May 2, 2010 3:57 AM (in response to Deyong)
    ya... i took my mbp late 2007 model 15 inch in to the genius bar and told them that my temperatures were getting up to 189F and they said that its still within operating conditions. I explained a lil further that i was barely using any apps...maybe just browser with my email tab open and that this was not normal. they recommended that i get my system rebooted and so i did.

    They took it in and an hour later handed it back to me. Everything was fresh again as far as software; and they even said my hardware was tested and eveerything was running in good condition. I turned my laptop on when i got home...and still hot
    currently at 128F which is not bad...but its all thanx to smc fancontrol
    MBP 15" 2., Mac OS X (10.6.2)
  • pooryorick2 Calculating status...
    Currently Being Moderated
    May 11, 2010 9:27 PM (in response to kingofgc)
    In the case of my model A1150, the issue was poorly applied cheap thermal compound (nice work, Apple). I carefully applied better compound and the temperature of the CPU under load went from 120 degrees celsius to 55 degrees celsius!

    http://www.ynform.org/w/Pub/MacbookProA1150OverheatingProblem

    If anyone is interested in having me try this on their computer, get in touch with me. I think it's lame that Apple can't take care of this themselves.
    A1150, Mac OS X (10.5.6)
  • thrunobulax Calculating status...
    Currently Being Moderated
    Jun 5, 2010 10:41 AM (in response to kingofgc)
    My MacBook Pro has ben overheating like mad since upgrading to snow leopard. I purchased the external Moshi Zefyr fan and cooling plate and still not good - helps a little. If you leave it alone it gets to 6000 rpm fans and 70 Deg C if you use too many programmes at once then it gets above 80 Deg C not long after that it will crash with kernel panic and shut down. Checking logs shows that one CPU has shut don. Cant be god for the Mac Book. It was fine under leopard. Also constantly running out of free RAM I have 2GB and it is not enough under snow leopard. Ifreemem hels to clear that problem and stop the beachball spinning.

    There is a real issue here APple - why not tell us what the cause is?

    Simon
    MacBook Pro, Mac OS X (10.6.3)
  • JasonZeppelin Calculating status...
    Currently Being Moderated
    Jun 9, 2010 5:05 AM (in response to thrunobulax)
    Just an FYI on how I solved this on my MBP core duo (1,2). I downgraded from Snow Leopard to Leopard 10.5.8 via TimeMachine. everything works great now. Dont know if its the older hardware or SL trying to push the CPU like its a Core Duo 2 (or what) but....

    I still use smcFanControl but my comp rarely gets over 60 C now and I run World of Warcraft with max settings. thanks!
    MacBook Pro Core Duo 1,2, Mac OS X (10.5.8)
  • nunavut20 Calculating status...
    Currently Being Moderated
    Jun 22, 2010 10:21 AM (in response to JasonZeppelin)
    I just wanted to chime in on this, since I recently acquired a used Macbook Pro 17" 2.4 Ghz. I swapped out my hard drive from an older MB Pro 15" 2.16 machine, and for about the last week, the fans would run very loudly, even without anything open or me using it. Finally I got fed-up, and decided I would try fixing it, or failing that reinstall SL from scratch.

    Like me I'm guessing many users have probably upgraded their OSes over time, instead of a new install. I think I've done this since 10.2. What this means of course is that stuff that's been installed over time into your OS, has probably polluted the upgrade.

    Anyway, this was my guess, and I started with Activity monitor and tried to determine which processes weren't sleeping. Saw Launchd kept restarting and dying. Next took a look with Console, and looked at all the errors; and noted a number of things were generating errors.

    In my case, I had things like Frontbase, Primebase, MySQL, and Adobe's VersionCue (part of CS3) that weren't starting up properly. Some of these apps aren't compatible with SL, others like VersionCue I don't use. Next, I determined there are various directories /Library/LaunchDaemons, /Library/StartupItems, /etc/machinit_peruser.d, that other applications can install their services too.

    I copied all these files and moved them out of the above directories; restarted, and after monitoring for a day - my cpu usage is still 98% idle.

    Keeping a small story short ..

    Since then my fans have not come on at all, and though my cpu spikes normally while doing intensive tasks, but drops right back down, even though I have numerous apps like Lightroom 3, Photoshop, XCode, the iPhone Simulator, Mail, Safari (with Flash sites), running simultaneously.

    My problem is solved, and I'm happy once again.

    Good luck
    Macbook Pro 17" 2.4ghz 4gb 1900x1200, Mac OS X (10.6.4)
  • Tim Moose Calculating status...
    Currently Being Moderated
    Sep 26, 2010 12:20 AM (in response to kingofgc)
    My late 2008 MBP has been idling around 70C since upgrading to Snow Leopard. Two round trips with AppleCare didn't help. I've had some temporary success periodically resetting the PRAM and PMU, but even that hasn't worked in a while. Yesterday I booted into the 64 bit kernel to see if it made a difference and BOOM! Just like that I'm idling at 45C. The CPU used to idle around 6.5W and now it idles around 1.5W. I'm keeping my fingers crossed that this lasts.
    MBP Late 2008 15", Mac OS X (10.6)
  • danois Calculating status...
    Currently Being Moderated
    Sep 29, 2010 10:40 AM (in response to Tim Moose)
    Tim, can you tell me what program you used to show your wattage? The only one I have found is CoolBook (unpaid just to monitor), but am afraid to install, and that supposedly monitors voltage. I have never had constant heat problems, but I have identified that after I use an intensive program, sometimes my temps stay ramped up after I quit the program, and it takes a restart to reset the temps back to normal idle approx. 40-45 C. I have attributed this to the "Penryn" T9600 chip that is in our MBPs having SpeedStep technology issues. No one has been able to confirm, but I would like to monitor more than just temp. Any suggestions would be greatly appreciated. I have not tried 64 bit kernel yet, as I am waiting for 64 bit updates. Thanx (and this all happens when CPU at 98% idle)
    15" Macbook Pro late 2008 (5,1), Mac OS X (10.6.4), 2.8 GHz, 4GB RAM, 7200 drive
  • Tim Moose Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2010 11:34 AM (in response to danois)
    I'm using iStat Menus. Still running cool here in 64 bit.
    MBP Late 2008 15", Mac OS X (10.6)
  • SockRolid Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 27, 2010 12:45 PM (in response to kingofgc)
    I've had this problem ever since installing Snow Leopard. Tried un-checking Safari's 32-bit mode checkbox in "Get Info," which helped a little. Tried removing the battery, unplugging power, and pressing the Power button for 5 seconds. But this is only a temporary fix.

    I've had no heat problems since installing several recent OS X updates though. I've installed the "ProKit 6.0.1 (SnowLeopard)" update and the "Java for Mac OS X 10.6 Update 3", but NOT the "MacBook Pro SMC Firmware Update 1.4" since my MBP doesn't qualify. Seems to be fine now.

    If that doesn't hold, I'll try booting in 64-bit mode. Not sure if the MBP is already doing that.
    MacBook Pro 2.53GHz (1st gen unibody), iMac 2.4 GHz (2008 aluminum), Mac OS X (10.6.4), iPhone 4, G4 Cube 450MHz
  • kismoore Calculating status...
    Currently Being Moderated
    Dec 15, 2010 2:24 AM (in response to kingofgc)
    Did anyone ever get a fix for these issues?
    I have a Mac PowerBook Pro laptop from 2007 and I have not had too many probs with it until I upgraded to Snow.
    My reason for the upgrade? 2 children in the home that run on newer systems that had snow pre-installed. Since we are a tech savy fam and both kids are in online virtual academies, and both run on mac os... one for music needs, one for art needs... I had to upgrade for cohesive purpose.
    I'm starting to seriously regret my choice.
    Since the upgrade, my battery has become pregnant and had to be tossed (fairly new battery but about 60 days past warranty-go figure), I have had to buy a fan table for my machine (never needed that before), and so many programs seem to run choppy or slightly interrupted.
    I've spent about $200 over the last 6 months trying to get things fixed but I keep hearing the same response, "I think your just expecting more from this laptop than it's capable of".
    ???? I never had these probs before snow moved in and Apple has been cold as ice about helping me fix the issues.
    Mac PowerBook, Mac OS X (10.4.8), Free from wires, free to roam!
  • DimitrisOH Calculating status...
    Currently Being Moderated
    Dec 26, 2010 11:59 AM (in response to kingofgc)
    Hello.
    I've had similar problems with my MBP Core 2 Duo 2.4GHz. CPU temp was on an average of 15C more than it used to be e.g. in normal use (internet, itunes, maybe some Lightroom) I was rarely over 50C but now it was heating up to 70s very often, without any intensive tasks running. Minimum was: 61-62C
    For a moment I thought it was caused by the RAM upgrade (2->4GB) but then I realized it was SL.
    I followed what other people said and I booted in 64-bit mode. I'M BACK TO UPPER 40s and it feels really nice!
    For now, I haven't noticed any incompatibilities with the 64-bit mode and I hope I don't.
    Cheers!
    MacBook Pro (late 2008), Mac OS X (10.6.5), 15" 2.4GHz 4GB 500GB
  • 4marcus Calculating status...
    Currently Being Moderated
    Dec 27, 2010 7:52 AM (in response to Tim Moose)
    I experience the same original behaviour of my macbook pro in regards to having a higher CPU A Wattage (above 5.00W) displayed in iStat menu together with higher temperatures. Whenever it happend a cold(!) reboot fixed it until the next time.

    Tim Moose wrote:
    I'm using iStat Menus. Still running cool here in 64 bit.


    @Tim: Do you have another update in regards to the 64bit mode? On my machine it happens rarely (sometimes not in one month, but sometimes on three days in a row), so I would like to ask you how often it occured on your machine before the 64bit startup.

    On my SL there are still some kernel extension without 64bit support (from Apple), so wouldn't this impact the systems' operation?
    15'' MacBook Pro (5,1) 2,53Ghz 4GB, Mac OS X (10.6.4), 24" LED Cinema Display, iPad 32GB Wi-Fi
  • Tim Moose Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2010 10:19 AM (in response to 4marcus)
    @4marcus

    No. Unfortunately, my MBP ran in the 1.5W range for a few weeks and then jumped back to the 6W range. As far as I can tell, it went back to running hot after connecting an external monitor for a few hours. My initial success must have been due to some of the other remedies I had tried. Latetly I've gone back to resetting the SMC, which keeps me cool for a few days.
    MBP Late 2008 15", Mac OS X (10.6)
  • AD London Calculating status...
    Currently Being Moderated
    Jan 1, 2011 8:32 AM (in response to Tim Moose)
    I have an early 2009 model 15" MBP and upgraded to SL on release. I had a lot of overheating issues and the battery would run down within minutes. At the time there was very little discussion about it and certainly no solutions. I reverted back to Leopard using Time Capsule and everything was OK again. I haven't missed SL at all but I now read that the new App Store requires SL. I'm very reluctant to reinstall SL and am hoping that Lion will resolve everything. I believe it is due out in the Summer (2011).
    MBP 15", Mac OS X (10.5.8)
  • kismoore Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 1, 2011 6:13 PM (in response to kingofgc)
    Unfortunately, there is a solution.
    The battery I had bloated and became huge, so I removed it.
    I can not afford to replace the battery so I am plugged into the wall.
    No problems since. Guess what Apple... the batteries suck! This is my second one in 3 years.
    I care for them well, I prime them, I recharge then use, then recharge, as instructed.
    My Cannon G3 camera has had the same battery since I purchased it. My cell phone has had the same battery since I purchased it. My iPod... dito. What's the deal Apple?
    Usually I'm so proud to post: "Free from wires, free to roam!"
    Now I'm bound to an outlet!!!!
    Mac PowerBook, Mac OS X (10.6.5), Free from wires, free to roam!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.