Skip navigation

External Hard Drive Not Showing Up

118605 Views 37 Replies Latest reply: Mar 28, 2014 11:04 PM by fitzlefrog RSS
1 2 3 Previous Next
mustngpny50 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 3, 2011 8:25 PM
Ok so Im not sure what is going on here. I come in to use my computer yesterday and notice the external HD is not on my desktop. It is running, but not displaying on the desktop. My first step is to restart the computer. I restart the computer and still nothing. Today, I opened up disk utility. The hard drive shows up in the disk utility. I have run both Verify and Repair disk to the external HD and after the scans it says the HD appears to be OK. I restart the computer and nothing happens. I can also eject the HD from the disk utility. After it is ejected I can unplug it and plug it back in and it will display in the Disk Utility, but nowhere else. It does not show up on the desktop and does not show up in the side bar. I have also gone into to preferences to verify that the box is checked to show the external HD.

I am trying to give as much detail as I can to help diagnose the problem and I have searched through the forums but can't seem to find anything or anyone that has had a similar problem. I need pointed in the right direction to try and figure out why the HD is not showing up on the Desktop. Any help or suggestions would be greatly appreciated.

Thanks
iMac, Mac OS X (10.6.5)
  • jsd2 Level 5 Level 5 (6,200 points)
    Currently Being Moderated
    Jan 4, 2011 12:44 AM (in response to mustngpny50)
    It sounds as if your external drive volume may have picked up a "hidden" flag. See
    http://www.pinkmutant.com/articles/invisible.html

    To test for this flag, and also to check the access permissions, go to your Utilities folder and open Terminal. Copy-paste the following line into the Terminal window, and type Return.

    ls -laeO@ /Volumes


    Copy the response and post it back here.
    Mac Mini, Mac OS X (10.6.5)
  • jsd2 Level 5 Level 5 (6,200 points)
    Currently Being Moderated
    Jan 4, 2011 6:10 PM (in response to mustngpny50)
    The external volume ("Iomega HDD", correct?) did not show up in /Volumes at all, indicating that it was not mounted, a different issue than "invisibility". Be sure it is connected and look again at the left pane of Disk Utility - you should normally see a non-indented "drive" icon for each disk drive, with one or more indented "volume" icons (partitions) below it. Mounted volumes will have their "mount points" reported at the bottom of the Disk Utility window. One of my flash USB drives contains a volume named USB2, and looks like this:
    .
    !http://i55.tinypic.com/28hofpu.jpg!

    What do you see in Disk Utility when you connect the external drive? If you see an indented volume icon that is not mounted, can you select it and mount it (DU toolbar or File menu)?
    Mac Mini, Mac OS X (10.6.5)
  • jsd2 Level 5 Level 5 (6,200 points)
    Currently Being Moderated
    Jan 4, 2011 8:57 PM (in response to mustngpny50)
    It's a puzzle, then. It doesn't sound like a hardware issue, but you could still try using different cable connections or seeing if it mounts when connected to a different Mac.

    I guess the next step if the data there is important and not backed up anywhere else would then be to try [DiskWarrior|http://www.alsoft.com/diskwarrior/index.html], a stronger but expensive repair utility, and then if unsuccessful next try a data recovery program such as [Data Rescue|http://www.prosofteng.com/products/data_rescue.php] . Perhaps others here can offer further suggestions.

    If the data there is just a backup or otherwise non-essential, you could of course just try to re-format (erase) the drive.
    Mac Mini, Mac OS X (10.6.5)
  • Ehaughian Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 18, 2011 3:53 PM (in response to mustngpny50)
    Hi,
    This is a follow on from the original posters query. My friend gave me his ext HD for me to load it up with notes and stuff from uni.
    It was formatted to NTSF so I backed up his files already on the HD and then reformatted the HD to ms-dos. All worked fine and I reloaded his existing files back on with no problem. When I started loading my files onto the HD though it started ok but an error message then appeared saying the process couldn't be completed as some of the files were not writable (or something along those lines).
    Anyways, the problem now is that the ext HD does not appear anywhere on my mac...not in finder, disk utility, I also found some command in another forum and copied it into terminal but the only ext HD that shows up is my own. It isn't in the USB device tree in system profiler either.
    All that said though, the devices sounds like its running with the only visible difference is a light with the letters R/W etched beside it is no longer lights up.
    I have tried it on my macbook as well with the same, worrying results.

    For the moment I don't know the name of the ext HD and knowing my friend may not be able to get it, but I'm hoping that won't prevent a fix as I don't think it is a problem with the ext HD!

    All help is much appreciated!!!!!!!!!!
    Imac, Mac OS X (10.6.4), Ext HD not showing anywhere
  • thomas_r. Level 7 Level 7 (26,930 points)
    Currently Being Moderated
    Jan 18, 2011 4:39 PM (in response to mustngpny50)
    Select the item "500.11 GB Iomega" and look at the SMART status info at the bottom of the window. What does that say?

    IMHO, this sounds like the drive has died, but it's hard to be sure at this point. Certainly, though, I've only ever had two drives fail to mount in all my years of using Macs, and in both cases the drives were dead. Of course, in both those cases, they didn't show up +at all+ in Disk Utility, so your drive might only be mostly dead... and a pill from Miracle Max won't help there.
    17" MacBook Pro, Mac OS X (10.6.6)
  • macintoshforlife Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 21, 2011 9:09 PM (in response to mustngpny50)
    im having the exact same problem as mustngpny50. I have tried plugging in my external drive to three different macs. They all show the drive in disk utility with the indented drive grayed out.

    I look forward to finding an answer. I was just using my external drive the other day and it was fine. And I don't think it is dead because I just purchased it in August 2010.

    I would normally reformat my drive, but I have a lot of important data i need on it. So reformatting is not an option until i can copy those files elsewhere.
    MacBook Air 13 inch, Mac OS X (10.6.6), 2.13 intel Core 2 Duo 4GB RAM 256gb HD
  • panbin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 5, 2011 6:48 PM (in response to mustngpny50)

    Hey,

     

    Have you finally solved the problem? Same problem happened to me a month ago, tried everything but in vain. though I noticed that beside what you described, I found the following problem.

     

    Owners Enabled :           No

    Can Turn Owners Off :           Yes

     

     

    Trying to use 'sudo' command to enable it. but the disk does not respond to the 'ls' command.

    If you happened to solve the problem, please kindly let me know.

     

    Thanks so much

  • henrybutz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 19, 2011 7:04 AM (in response to macintoshforlife)

    I came to this page looking for a solution to a similar problem.  I installed a bare Seagate Constellation HD into an external USB 2 enclosure onto a Mac Mini running Snow Leopard.  A warning popped up which said the drive was not readable, Initialize, Ignore, or Retry? (I think).  I clicked on Initialize.  It did nothing.  The drive did not show up at Disk Utility.

     

    On the same machine, I started Parallels running XP and clicked over the USB to ATA bridge device to the VM.  Windows Disk Manager recognized the drive right away - no problems at all.  There were no partitions.  I added an NTFS partition and formatted half the drive.  When I released the drive from Parallels then it came right up in SL's Disk Utility.  I created the second partition as FAT and it was available for r/w while NTFS was r/o.

     

    I'm thinking SL has some issues with external USB drives when they have no partitions defined.  If you can't see the drive, try partitioning it on a WindowsXP system first.

  • MacApple258 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 20, 2011 8:37 AM (in response to mustngpny50)

    1. Change visibility of the drive(s) from "hidden" to "show" using a tool such as Onyx. Then restart your Mac. Go to step 2 if step 1 is not helpful.

     

    2. Close all items in Finder. Delete /Users/yourname/Library/Preferences/com.apple.finder.plist  Restart your Mac.

  • UtahRugby Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 14, 2012 9:51 PM (in response to mustngpny50)

    Not sure if people are still needing such a simple solution or if it will work for everyone but one of the 4 externals in my chain unmounted today and I couldn't figure out how to remount. Read many fourums and tried DiskUtility, restarted, allsorts of crap.

     

    ...then I turned the Power button off and back on and it mounted automatically again 

     

    Maybe just make sure stuff you're working on or still open in other apps is saved and backed up before you do it.

     

    Bam!!!

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.