2 Replies Latest reply: Jan 6, 2011 7:14 PM by Pedro_NZ
Gcar Level 1 Level 1 (0 points)
I am currently trying to setup a podcast producer server and have followed the install guide to the word but for both installs I have tried (local open directory and bound to AD) everything appears to be running fine but fails when it gets to the publish2library or publish2folder part.

Xgrid agent output is below for both failures.

Wed Nov 17 12:20:00 MMSPodcasting.abcol.ac.uk xgridagentd[3059] <Notice>: Notice: agent task "7772" failed for user "pcastadmin" executable "/usr/bin/pcastaction" arguments (
publish2folder,
"--prb=/Network/Servers/MMSPodcasting.abcol.ac.uk/Library/PodcastProducer/Share d/UUIDs/DE9FB95C-383B-4262-BAAF-8E87EAD6CCF5.prb",
"--file=export-plugin-quicktime-E43D860D-31BB-454F-83AD-B2ECFFED9E92.m4v",
"--folder=/test",
"--usedayfolders=YES",
"--create_folder=YES",
"--outfile=publish-plugin-folder-3f97743ea8412a66bfb44156ce53bdd2.yaml",
"--mimetype=video/x-m4v"
)

and

Wed Nov 17 13:54:41 MMSPodcasting.abcol.ac.uk xgridagentd[3059] <Notice>: Notice: agent task "11336" failed for user "pcastadmin" executable "/usr/bin/pcastaction" arguments (
publish2library,
"--prb=/Network/Servers/MMSPodcasting.abcol.ac.uk/Library/PodcastProducer/Share d/UUIDs/8323ACF7-F6BE-4A8E-B9E5-76FD84EB5FFD.prb",
"--file=edit-core-master.mov",
"--outfile=publish-plugin-podcastlibrary-edit-core-master.yaml",
"--type=master",
"--mimetype=video/quicktime"
)

To test i copied the commands and ran them in terminal as root. The publish2folder command completes successfully but the publish2library command outputs the following error -


Wed Nov 17 12:07:03 MMSPodcasting.abcol.ac.uk pcastaction[6636] <Error>: PodcastProducer::Actions::Publish2Library: An error occured when trying to synchronize the new published document with Podcast Library (at https://MMSPodcasting.abcol.ac.uk:8170/podcastproducer): '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>

Bad Request


Your browser sent a request that this server could not understand.


<hr>
<address>Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/0.9.8l Server at mmspodcasting.abcol.ac.uk Port 8170</address>
</body></html>
'. Trying again...
warning: peer certificate won't be verified in this SSL session
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
115 347 115 347 0 0 27239 0 --:--:-- --:--:-- --:--:-- 338k

Surely someone has had this issue and can point me in the right direction.

Thanks in advance

g

iMac 27" Core i5, Mac OS X (10.6.5)