Skip navigation

When tagging faces do not stick

4299 Views 11 Replies Latest reply: Apr 21, 2013 8:37 PM by tallgaloot2 RSS
Nathan Zamprogno Calculating status...
Currently Being Moderated
Nov 4, 2010 7:20 PM
Read this. I think a lot of people are having this problem but the descriptions have been poor:

I double click the face for Bob in the Faces gallery and review the other recommended faces that 'might be' Bob.
In this list I see many photos of Bob, and also of Jim, his similar brother.
I confirm all the photos of Bob with one click, and I right click all the photos of Jim, select 'Name', and start to type his name, selecting 'Jim' from the pop-up list.
I correct many dozens of such photos using both methods.

I click done, and then check the number of photos now actually tagged as 'Bob' and of 'Jim'. The number of photos tagged as Bob has risen correctly, but all the hand-tagged photos of Jim DO NOT appear. The number of photos tagged as Jim has not increased. My time has been wasted.

I see this as a clear bug. This is iPhoto 9.1 and OS 10.6.4.

Chime in if this is happening to you.
15" Macbook pro, Mac OS X (10.6.4)
  • Brandon Yates1 Calculating status...
    Currently Being Moderated
    Nov 4, 2010 7:57 PM (in response to Nathan Zamprogno)
    I am also having this issue. I'll confirm the faces in the "Faces" section of iPhoto, but when I hit 'Done', it doesn't stick. Those confirmations/rejections are lost & the same photos are marked as needing to be confirmed.

    Mine was also an upgrade from '09 -> '10. My library isn't nearly as large. I only have 2800 photos & 14 tagged faces. Local HDD as well.
    Powerbook G4, Intel iMac 20", MacBook Pro 15" 4GB, Mac OS X (10.4.6)
  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Nov 5, 2010 12:34 AM (in response to Nathan Zamprogno)
    "5/11/10 11:52:26 AM iPhoto95435 Can't open input server /Users/localadmin/Library/InputManagers/Edit in WriteRoom".


    Try disabling the 'Edit In Write Room' plug-in and see if it works then.

    Regards

    TD
    MacBook Pro 15 2.4 C2D / iMac 20" 2.66 C2D, Mac OS X (10.6), 4 gig RAM/ 4 gig RAM
  • Kristi Gerrior Calculating status...
    Currently Being Moderated
    Nov 13, 2010 3:40 PM (in response to Nathan Zamprogno)
    I am having the same issue under iPhoto 9.1. I also saw it under 9.0.1. For me I was able to confirm some but not all the photos.

    1. Upgrade under 9.0.0 went smoothly as far as I could tell. This library has been around for a long time.
    3. No messages in console log
    4. 7,414 photos. 367 items for this Face. 27 cannot be confirmed.
    5. Drive is local.
    Mac OS X (10.6.4)
  • jagron11 Calculating status...
    Currently Being Moderated
    Dec 5, 2010 3:48 PM (in response to Nathan Zamprogno)
    Having the issue, where I have 15 pictures that might be John Doe. Confirm the individual pictures, click done and NADA, still have 15 pictures. Been working this all morning and just stopped work, who knows why. Ugghhh

    1. Upgraded library, upgrade went smoothly.
    2. Haven't tried.
    3. No messages related to iPhoto, only to Sync.
    4. 10,667 objects (pictures/video) and 72 faces
    5. Local drive

    Help please!
    MBP 2.53 Core 2 Duo, 4GB, 250GB HD, Mac OS X (10.6.5)
  • Mark Hollingsworth Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 9, 2011 9:43 AM (in response to jagron11)
    I have a problem that I think is related.

    On iPhoto 09 I had a picture of a peson, full head shot. No 'face' was detected, but I flecked to add a face.
    It allowed me to do so and name it. It appeared to take, but won't appear in faces, and when I look at the pic again, no face is shown.
    I recently upgraded to iPhoto 11, exactly the same thing.
    Mac Pro- 2x2.26 Quad-Core, Mac OS X (10.6.6), 6 gig RAM- 30" monitor
  • TheWolffpack Calculating status...
    Currently Being Moderated
    Jan 12, 2011 6:17 PM (in response to Nathan Zamprogno)
    I have a rather large iPhoto database. Currently, at 49,567 pics. I was experiencing the same issue you described, as well as not being able to add pics to the corkboard on faces and I could not empty my iPhoto trash. I read through some of these forums about trying iPhoto Library Manager. I downloaded the free version of this app. It took a solid 8 hours to create a rebuild of my original library (the original library is kept intact) the rebuilt library is a replica. Best 8 hours spent!!!! All features now work in iPhoto.

    This fixed all of my issues I hope it solves yours!!!
    iMac 27 inch, Mac OS X (10.6.6)
  • Tasel Calculating status...
    Currently Being Moderated
    Feb 8, 2011 8:36 AM (in response to TheWolffpack)
    You can rebuild your iphoto library in the app itself. http://support.apple.com/kb/ht2638

    (short version: start while holding opt & command)
    Mac OS X (10.4.8)
  • akositzke79 Calculating status...
    Currently Being Moderated
    Mar 1, 2011 2:38 PM (in response to Nathan Zamprogno)
    I had this problem all the time with iPhoto 09...and was rather frustrated to see that it still exists in iPhoto 11. As far as I can tell, whenever you manually add a face, iPhoto rescans the photo and tries to "fix" your newly added face by either adjusting it to where it thinks a face is (which results in it moving it on top of another, already tagged face), or removing it completely. The only work around that I have ever found for this is to simply put the tag somewhere else on the picture - on the person's shoulder, arm or something of that sort, and I can eventually get iPhoto to accept it. The most frustrating thing for me is that iPhoto doesn't notify you when it "fixes" one of your manually added faces - the only way to make sure that all of your faces stayed where they were supposed to is to go through every photo twice!

    I wish that iPhoto would stop assuming that it's smarter than we are, and not adjust anything that we manually tag on the photo.
    Mac Book Pro, Mac OS X (10.6.4)
  • soxno1fan Calculating status...
    Currently Being Moderated
    Oct 15, 2012 4:03 PM (in response to Nathan Zamprogno)

    So, for me, I haven't had any recent problems with unnamed suggested faces sticking when I type in the name, that usually works.

     

    My problem is that when there are two (or more) faces in a photo but only one is automatically detected, it will not allow me to manually add another.  Rather, it will appear to allow me, but as soon as I select a different photo and then return, all of my entered information (name and face shape/size) have disappeared.

     

    Curiously, I do not encounter this problem of manually added faces not sticking when there are no auto-detected faces in the photo, then the manually added ones stick just fine.

     

    However, one unrelated problem that I do have is that when starting to add a face, if one is already occupying the center of the photo, it is nearly impossible to select the new face with the cursor in order to name it and move it to the right position since the cursor automatically selects the currently added face.

  • tallgaloot2 Calculating status...
    Currently Being Moderated
    Apr 21, 2013 8:37 PM (in response to Mark Hollingsworth)

    I believe I may have solved one of these problems.

     

    The problem I was experiencing:

    As I was tagging pictures with names, I would come across a picture that was missing the box.  I would manually add the face, type in the name and move on to the next picture.  Looking back I would realize that the photo was not tagged and now the "Add Face" button was greyed out.  I am using Iphoto 11 and this was soon after a library rebuild (that Iphoto told me to do).  If you were experiencing the same problem, read on...

     

    If you look in the upper left hand corner of Iphoto, you will see the "faces" button/folder.  Clicking this button will normally bring you to your page with everybody's face.  I think you will notice that there is a spinning wheel next to the word faces.  This is Iphoto redetecting faces on your library.  It does this after you add new pictures or in my case, when I rebuilt the library.  It can take hours to run.  It only runs when Iphoto is open.  So, if you didn't know you would probably close Iphoto and experience the same problem each time you opened the program (because it was still detecting faces.)

     

    What I believe is happening is that because it is working hard to detect faces, it doesn't have the time to add the tag you just made to the database/file/computer mumbo jumbo  (hang with me here.)  But it still is tagging the photo, you just can't see it on the photo itself.  I confirmed this (and you can try this) by clicking a picture and adding a face with a name that I had never used before like "Jack".  I add the face, go to the next picture, go back and just as before the tag is not there and add faces is greyed out.  However, when I click "Faces" at the top of the page, and scroll through the face "albums".  Boom.  "Jack" now has an album and inside is the picture I just tagged.  Opening the picture in here reveals that it is still not recognizing the tag in every way, but Iphoto obviously knows it is tagged.

     

    What I think is happening is that Iphoto is allowing you to tag faces while it's working.  You tag the photo, move on to the next and Iphoto throws the photo to the back of the queue, so to speak.  It blocks out the ability to add another face at this point to keep you from adding the same face over and over again in a desperate attempt to get it to work. 

     

    For me, allowing Iphoto to run overnight and let all the faces get "detected" fixed the problem and I was able to tag photos normally the next morning (so far anyway.)  I will let everyone know if there are more developments.

     

    And yes, I know I'm resurecting a dead board, but I saw no answer when searching the problem myself, so I'm adding to a few walls where I see the problem mentioned.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.