Skip navigation

iPod Classic problem with BeoSound 8 Dock

3827 Views 5 Replies Latest reply: Dec 29, 2012 12:58 PM by Philg6akk RSS
Snagglepuss1956 Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 31, 2010 4:36 AM
We bought a Beosound 8 yesterday. The sound is wonderful, but it only works properly with my iPhone. My iPod (Classic 80GB) menu can't be accessed - the screen and 'click wheel' appear to be locked, with the display showing "OK to disconnect". The only way I can get the music to play is to select the desired album/track before docking the iPod, which rather defeats the object. The iPod works fine when not connected to the BeoSound. I've tried re-setting the iPod but that doesn't seem to change anything. The iPod software is up to date. Please can anybody help?
iPod Classic 80GB
  • the fiend Level 5 Level 5 (6,890 points)
    Currently Being Moderated
    Jan 9, 2011 3:35 PM (in response to Snagglepuss1956)
    I didn't respond to your first post because I wasn't sure that I could give you any useful information. However, since you have posted again and have yet to receive any reply, I thought I would chip in.

    You can confirm the software version on the iPod by either of the following methods:
    1. On the iPod, go to Settings/About and when the "amount used" bar shows, press the centre button twice to move to the screen that shows the serial number, model and version.
    2. Connect the iPod to iTunes and look at the Summary screen which will show you the *Software version.*

    However, you need to be aware of the following; my 160GB Classic has *1.1.2 for PC* on it and is up to date. As far as I can tell (and I'm not expert at this) the Software 2.0.2 and later is only for iPod classic 160GB _*(Late 2009).*_ So for example, my iPod's software "is up to date" because it has the latest version _for my model,_ which is older than "late 2009". Likewise, I'm not convinced that your iPod will have 2.0.4 on it because it isn't for the 80GB Classic. If anyone knows differently, I suggest they add to this thread and let us know.

    So that begs the question "are B&O correct to imply that your 80GB iPod can have that software?" If they are not, and their Beosound only likes iPods with that software, perhaps that's why your iPod doesn't work correctly - because B&O have got it wrong. (It's not impossible! I've seen one car stereo that the vehicle manufacturer claims to be iPod friendly, but it isn't. I tried using it and found it complete rubbish.)

    Anyway, back to your situation: once you start the iPod playing, if you then connect it to the B&O, does it continue to play the rest of the tracks that you expect it to? For instance, if I connect my iPod Classic to my car's stereo, I start it playing the section I want (usually all songs on shuffle) and just let it do its thing. I can skip to the next track and back to the beginning of the "now playing" track, but I cannot use the playlists (despite instructions suggesting that I can) nor can I access the menus or change to a different selection (such as changing from one genre to another or one album to another.)

    So I've got used to this quirk and simply decide what I'm going to listen to, start it playing and then connect it up.

    By the way, when your iPod is coneected to iTunes, there is a button to check for software updates. I've not known it to be wrong.

    Phil
    PC, Windows XP, 160GB Classic iPod and iPod Touch
  • P.allen59 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2011 6:30 AM (in response to Snagglepuss1956)
    Hi, I was hoping you could post a response to what B&O told you, as they clearly say on their website the 80gb iPod is supported. I received mine today, iPad and iPhone both work great with it, but not my 80gb iPod classic.
  • Philg6akk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2012 12:58 PM (in response to Snagglepuss1956)

    Hi

     

    Just bought a beosound 8 today from John Lewis sale only £630

     

    Great sound but it doesn't work on our 30gb classic IPods ok on the new 150gb classic iPhone 3G & 3gs

     

    Just put mt iPad on to my Mac mini and it says that 1.3 is the latest level and so I get the ok to disconnect message the only quick workaround is to use a phono to 3.5mm jack lead that I have, but not tried that yet as my wife's watching corrie

     

    Looks like B & O have made a mistake do post if they come up with a fix

     

    Phil

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.