Skip navigation

Canon MX860 "offline" when trying to print over wifi

33960 Views 21 Replies Latest reply: Dec 3, 2013 2:56 AM by Noel139 RSS
1 2 Previous Next
RubyRedder Calculating status...
Currently Being Moderated
Jan 11, 2011 7:26 PM
Help (please)!

I've been printing over wifi with no problems to my Canon MX860 for months. Now, as of the last week or so, it just... won't work. I've tried reinstalling the drivers and setting everything up from scratch, I've tried every bit of advice I can find online, and... nothing. The printer setup will seem to go OK, the Canon LJ utility tells me there is a good connection between the printer and my Airport Express base station, but when I actually try to print, I get the bouncing printer icon in the dock with a red exclamation point, and it turns out that the printer is allegedly "offline".

I have tried everything I can think of, over and over and over again, and am getting incredibly frustrated with this. I have no idea what has happened to stop my printer working (or rather, to stop me being able to print to it - it works just fine if I want to use the USB cable, which I don't) or what I'm doing wrong, but it is driving me nuts. So... any advice MUCH appreciated!
Mac OS X (10.5.8)
  • PAHU Level 6 Level 6 (14,400 points)
    If you haven't done so already then I would suggest you reset the printing system. This will delete all printer queues on the Mac and require you to add them again.

    1. Open System Preferences > Print & Fax
    2. Move your mouse over the Printers list
    3. Hold down the Control button and click the mouse
    4. Click the "Reset printing system ..." popup
    5. Restart your Mac
    6. Open Print & Fax, click + to Add and select the MX860 from the Default view

    If this process still fails to get you printing then please reply.
    MacBook Pro 17, Mac OS X (10.6.5), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 4
  • PAHU Level 6 Level 6 (14,400 points)
    RubyRedder wrote:
    I just followed your instructions, but now when I go back to Print & Fax and click the plus sign to add a printer, the MX860 doesn't show up in the Default view. It didn't show up before, either... If I click on "More Printers", "Canon IJ Network" shows up, but I have no option to actually do anything or anything to select.

    Sorry about the misleading step. I have been so accustomed to Snow Leopard that I forgot you need to use More Printers > Canon IJ Network on Leopard with the older driver.

    But there is a new 'CUPS' driver available for this printer that will let you add the printer via the Default Add Printer view. Here is a [link|http://support-au.canon.com.au/contents/AU/EN/0100165602.html]. With the driver installed the MX860 should be visible, assuming that it is still connected to the wireless network.

    So if the MX860 still fails to show then I suggest you open Safari, click the Bookmarks icon and then select Bonjour in the list. The MX860 should be in this view and selecting it should connect to the printers internal web page.

    If the printer is not seen in the Bonjour view then it would suggest that it is no longer connected to your network. I believe you can print a network configuration page from the device. This may be located under Device Settings > LAN Settings > Wireless LAN setting list. This information will show the IP address currently being used by the printer. Typing this IP address into Safari should also open the internal web page.

    If connecting to the internal web page does not succeed then you will have to connect the printer back to the Mac via USB cable and run through the network setup again.
    MacBook Pro 17, Mac OS X (10.6.5), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 4
  • PAHU Level 6 Level 6 (14,400 points)
    Just wondering if you are using the USB printer queue to print to the wireless printer. With the USB printer disconnected the queue will show Offline if you tried to print to this queue.

    Open Print & Fax and select the MX860. Then open Options & Supplies and with the General tab displayed you will see the print queue URL. Using the v7.x driver for OS X 10.5 and earlier the URL will look something like;

    bjnp://Canon:MX860%20series/00:00:85:XX:XX:XX (where X is an alpha or numberic value)

    If you were using the v10.26 or later driver for 10.5 and 10.6 then the URL would look like;

    canonijnetwork://Canon/CanonMX860%20series?00:00:85:XX:XX:XX

    If your URL shows usb://Canon/MP860%20series?serial=100265 then this is for a USB connected printer.
    MacBook Pro 17, Mac OS X (10.6.5), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 4
  • PAHU Level 6 Level 6 (14,400 points)
    With the v10.26 driver you need to use the Default Add Printer view. In testing yesterday on 10.5.8 I saw that the Canon wireless devices took several seconds before they appeared in the Default view. So click to add and select Default and wait.

    If you were using the v7.x driver then you would need to use the More Printers > Canon IJ Network menu.
    MacBook Pro 17, Mac OS X (10.6.6), MacPro 2x3GHz Quad-Core, iMac i7 27", Xserve G5, iPhone 4, iPad
  • PAHU Level 6 Level 6 (14,400 points)
    RubyRedder wrote:
    Canon IJ Network shows up on the dropdown menu, but the printer itself doesn't appear. Do you think I just need to wait longer and it will eventually show up?

    No. In testing with an MP980 on wireless I found that the printer would appear as soon as I selected More Printers > Canon IJ Network. It was only when using the Default Add Printer with the v10.26 driver that I needed to wait.

    Just with regards to using the Canon IJ Network menu I did find that I needed to install a later version of utility. When I first tried Canon IJ Network, which was a version that was installed a couple of years ago for an older model of Canon that is no longer around, the MP980 was not showing. So I installed [v2.70|http://support-au.canon.com.au/contents/AU/EN/0200082701.html], restarted and then when I used the Canon IJ Network menu the Canon was present.

    Given that the printer is not appearing in either view it sounds like the printer is connected to a different network than your Mac. You mentioned being able to connect to its web browser by typing in its IP address but not using the Bonjour view in Safari. This could be a clue.

    Have a look at your wireless network settings in your Mac (System Preferences > Network > Airport > Advanced > TCP/IP). This will show your IP address, subnet mask and router values.

    With these noted use the web browser to connect to the Canon and select the Advanced tab from the Home Page. This will then show the network settings being used by the Canon and you should find that the subnet mask and the router (aka gateway) are the same. And for the IP address, the first three sets of numbers should be the same with only the last number being different to the Mac. Is this the case?

    Sorry for being such a pain - and again, thank you so much for all your help with this thing!

    No apologies needed. I'm very happy to help.
    MacBook Pro 17, Mac OS X (10.6.6), MacPro 2x3GHz Quad-Core, iMac i7 27", Xserve G5, iPhone 4, iPad
  • Aleksander Calculating status...
    Currently Being Moderated
    Jan 22, 2011 5:36 PM (in response to PAHU)
    I had the same problem with my MX860. It would scan just fine over the network, however it would always indicate that the printer was offline if attempting to print over the network. It printed just fine over USB.

    It took me several hours to resolve this issue. It now works great.

    I did the following:

    1. In system preferences open Print and Fax under the Hardware category.
    2. You should see the printers that are available. Before I resolved the printing issue I only saw Canon MX860 Series and it indicated that it was offline.
    3. Click on the add button
    4. Under the default tab your wireless printer should appear. It may take about 5 seconds for the field to populate. Select 'Canon MX860 Series (xx.xx.xx.xx.xx.xx IP Address) and add it. It should now appear under printers in the Print and Fax preferences.
    5. If the printer is on it should appear with a green dot and indicate that it is idle. If you select this printer you will get the printer queue window.
    6. Now, when you print you will have two Canon MX860 to choose from when printing.
    Canon MX860 Series - for Printing via USB
    Canon MX860 Series (xx.xx.xx.xx.xx.xx IP address) - for wireless printing.

    This worked for me, hopefully it will also work for you.
    imac 333 - tray loading - lime, Mac OS 8.6 or Earlier
  • jembwilliams Calculating status...
    Currently Being Moderated
    Jan 29, 2011 8:43 PM (in response to PAHU)
    I've been following this thread with interest because I've had this same problem for months. I can get every computer in the house to work with the MX860 except the iMac -- and I can even get it to scan -- but print wirelessly it will not!

    In 'Print & Fax' I can see the printer (and the mac address) and it is 'Idle, Default'.

    In the Print Queue, it shows I am using Driver Version 1.0 (the latest for 10.6?), and the URL shows up as bjnp://Canon:MX860%20series/00.00.85.f4.10.cf

    Whenever I try and print, the status messages reads something like:

    Error:/System/Library/Printers/Libraries/PrintJobMgr/Contents/MacOS/PrintJobMgr failed

    Any suggestions you might have Pahu, would be gratefully accepted!
    iMac, Mac OS X (10.6.6)
  • Aleksander Level 1 Level 1 (140 points)
    Hello,

    Have you tried to install the following driver from the Canon site?

    MX860 series CUPS Printer Driver Ver. 10.26.2.0 (Mac OS X 10.5/10.6)

    You can find it by selecting Mac OS from the drop down menu at the following link:

    http://www.canon.ca/inetCA/serviceDetail?m=load&id=5&sid=39&mid=0002200514&type= D&opt=1

    Install this driver.

    Go to 'Print and Fax' and click on the add (Plus) button and you should see this printer populate. Select the printer. Do you have two printers listed here - should both be Canon MX860, one with the IP address.
    imac 333 - tray loading - lime, Mac OS 8.6 or Earlier
  • HK Dynasty Calculating status...
    Currently Being Moderated
    Apr 17, 2011 2:15 AM (in response to PAHU)

    Hello,

     

    I have read your post and hope you are able to help.

     

    I am facing the same problem with wireless printing from Mac to Canon MX860. I have tried all options, installed all drivers, but the printer continues to be connected to the USB URL. How can I change this into

     

    canonijnetwork://Canon/CanonMX860%20series?00:00:85:XX:XX:XX.

     

    Please help! Thanks

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.