Skip navigation

Used to read/write, now can only read SD cards

25808 Views 25 Replies Latest reply: Apr 9, 2014 5:34 AM by Roy Caratozzolo RSS
1 2 Previous Next
skatalite13 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 18, 2010 7:14 PM
Hey all. I've got two micro SD cards and a normal SD card that I've been able to read/write on with no problems... Until tonight. Now, I can only read them.

My SD card is the one I use in my digital camera. When I plug it right into my MacBook Pro's SD card slot, I can't delete items from it via Finder or Disk Utility. I also cannot delete images from it through iPhoto.

However, if I hook the camera up to the laptop using a USB cable, I can delete the images through iPhoto.

All three cards are Fat16 which, I assume, has always been the case. I've never had a problem until now. I've even tried formatting the cards in the digital camera, but it hasn't changed anything.

When I look at the cards through Disk Utility, I can only Verify the discs and nothing else.

None of the cards are locked. I'm using an SD card adapter to load up the micro SD cards.

What could the issue be? I'm hoping to try a USB micro SD adapter tomorrow, to see if the issue could be my SD card slot. Any information would be appreciated.


Message was edited by: skatalite13
MacBook Pro, Mac OS X (10.6.4)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.