Skip navigation

Can't eject DVD; tried everything ... HELP!

2480 Views 4 Replies Latest reply: Sep 1, 2012 6:24 PM by Kharps RSS
UltimateWines Calculating status...
Currently Being Moderated
Jan 20, 2011 3:24 PM
Can't eject a DVD. Tried the following -
Eject disc command from the DVD player - DVD just starts up again
Eject disc command from Finder - same result
Highlight disc on desktop and move to trash - same result
F12 - no longer an eject disc button on this version of the OS
Restart while holding down trackpad button - nothing happens
Shutdown and restart - nothing happens
Firmware command - eject cd - the disc image is now gone from the desktop but it didn't eject and now I can't even find it again (not after restart, shutdown and restart, open DVD player and it doesn't appear).

So now I have a disc in my disc drive but I can't even see it. How can I get it to eject?
Powerbook G4 17", Mac OS X (10.5.8)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.