Skip navigation

iOs4 upgrade, Now car stereo doesnt work with iphone

236880 Views 539 Replies Latest reply: Feb 21, 2012 9:32 AM by KiltedTim RSS
  • kimbra8 Calculating status...
    Currently Being Moderated
    Dec 12, 2010 6:27 AM (in response to rbp87)
    Well first, I apologize for it taking me till this morning to do that, we had an extremely full day yesterday. He does not have the "little blue envelope button" on his 3GS. The one thing I thought of is we have different make car stereos and of course I have the iphone4 and he has the 3GS. Maybe others could post which phone and stereo brand they have and if they have the blue envelope. It might help to solve this mystery. It's weird that it showed up after the last upgrade and wouldn't on the older phone styles when it is the same software.
    Iphone4, iOS 4, JVC head unit
  • JuanSkom Calculating status...
    Currently Being Moderated
    Dec 12, 2010 6:39 AM (in response to kimbra8)
    No the icon you see that looks like an envelope is the icon for airplay. As apple only supports airplay on iphone4 it's not available on 3GS and 3G. However at the same location you can get a bluethoot icon if you send audio trough bluthoot.

    Still on OS4 especially on OS4.2 the problem could still be connected. So try setup your phone and car stereo as entirely new connection. That means deleting any settings you might have on the both ends of this connection if there exists such ones. This could help, I'm sure the setting file is the same on os4.2 independent on what model you have. So if the setting is wrong and your on a 3G-3GS you have no way to poke that setting other than deleting old ones that you might have.

    I'm not myself connecting the phone in similar way so all this is on a theoretical basis.
    MacPro 2.0GHz, Mac OS X (10.6.5)
  • diesel vdub Level 7 Level 7 (20,745 points)
    JuanSkom wrote:
    No the icon you see that looks like an envelope is the icon for airplay. As apple only supports airplay on iphone4 it's not available on 3GS and 3G.


    That is not accurate. Both the 3GS and iPhone 4 support Airplay.

    Here is a list of the feature breakdown by device. http://support.apple.com/kb/HT4204
    3GS, iOS 4
  • JuanSkom Level 1 Level 1 (0 points)
    Hmm in that case the icon should be there on 3GS, but I think I read somewhere that, they removed support for 3GS???
    MacPro 2.0GHz, Mac OS X (10.6.5)
  • kimbra8 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2010 11:23 AM (in response to JuanSkom)
    Even if they don't have support though the updates are still updating the 3GS so it makes no sense to me where the icon is. I wonder if everyone with the iphone4 has the icon. Wish we could get more feedback from others as to what phone they have and whether they have the mystery icon
    Iphone4, iOS 4, JVC head unit
  • JuanSkom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2010 11:51 AM (in response to kimbra8)
    The icon only shows when iPhone recognizes multiple output possibilities. So no it does not show on iPhone 4 either all the time. Anyway go to iPod and play some song the icon shows on the right side of volume control and rev/forward controls.
    MacPro 2.0GHz, Mac OS X (10.6.5)
  • kimbra8 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2010 12:27 PM (in response to JuanSkom)
    Yes you are right.. I forgot to mention that you only see this when it is plugged into the stereo system.... However, it does not show up on hubby's 3gs when plugged into the usb car stereo input but everything is functioning for us so I am not complaining.. Just wish I could help others a little more then I have
    iphone4, iOS 4, jvc KW-XR810 car audio head unit
  • JDMils Calculating status...
    I have the following devices:

    * Car headunit Kenwood DNX7340- Bluetooth phone, bluetooth audio, DVD/CD, iPhone via Kenwood iPhone cable, DivX/AVI, USB, SatNav.
    * iPhone 3GS V4.1
    * iPhone 4 V4.1

    Here's what happens when my 3GS is plugged into the Kenwood via the iPhone cable:

    1. Music plays thru iPhone.
    2. Turn headunit on.
    3. Music continues playing on headunit.
    4. After 5 seconds, headunit & iPhone connect via bluetooth. A2DP connects as well (bluetooth audio) and music stops playing.
    5. This is then displayed on the iPhone: http://users.tpg.com.au/jdmils/miscimages/3GS/IMG0118.PNG
    Note the headunit name & bluetooth icon at the bottom. Press the bluetooth icon. This screen then shows: http://users.tpg.com.au/jdmils/miscimages/3GS/IMG0119.PNG
    6. Select the Dock Connector item and music continues playing, thru the iPhone cable.

    Here's what happens when my 4 is plugged into the Kenwood via the iPhone cable:

    Everything above is the same with these images:

    http://users.tpg.com.au/jdmils/miscimages/4/IMG0422.PNG
    http://users.tpg.com.au/jdmils/miscimages/4/IMG0424.PNG

    In summary, both the 3GS & 4 iPhones act in the same way with the same icons displayed on the iPod screen.
    CustomGamer, Windows XP
  • tnttroy Calculating status...
    Very frustrated like everyone else here.

    I have iPhone 3Gs (ios 4.2) and a JVC KD-R600.

    After emailing JVC with my problem, they have just replied and sent me a new firmware, with instructions, for my unit. I'll give that a try and see how it goes as none of the other suggestions here have worked for me.

    Will report back soon!
    iPhone 3Gs, iOS 4
  • robertofool Calculating status...
    I just recently started to have this problem. My specific problem has probably been solved but it's difficult to search through 34 long pages to find it.

    Here's what I have: Stock 2009 Scion XB w/ stock Pioneer stereo, iPhone 4 running 4.1., iPhone connected to Scion's Hands-Free Bluetooth

    My problem: Music will play for about a minute then cuts out and the only way I can play music again is if I disconnect my iPhone from the supplied dock connector.

    I've tried turning my bluetooth off and closing all running apps but nothing works.
    Macbook Pro, Mac OS X (10.6.5)
  • wdetmar Calculating status...
    I've been wanting to upgrade my iPhone 3GS from 3.1.3 to 4.x, but I was afraid the iPhone 3GS and the Sony CDX-GT630UI car stereo would stop playing nice together.

    I spoke with Sony for the 2nd time in the past month or so and it shows that the 3GS isn't supported at all. I'm not sure if I noticed this when I bought the unit last summer.

    http://esupport.sony.com/US/perl/support-info.pl?template=&info_id=269

    Sony says that there is a fix in the works for iOS4 or the iPhone 4 - the guy I spoke to couldn't keep it straight, but no ETA on when the fix will be available. Come on, iOS4 has been out for more than 6 months right? How long does it take? However, I'm not even sure if it's a Sony issue or an Apple issue. But they should at least post an iOS 4 statement. Or if is there on their site -maybe I'm missing -it they should make it more prominent on the site.

    Regardless, I took the plunge last night. I have been seeing some apps that I wanted to purchase that were for iOS 4 only. Worst case I could use the ALT input jack if it failed.

    Before I upgraded I decided to try my iPad running iOS4 and I found that I was able to plug in the CDX-GT630UI and play music in iPod Mode and Stereo mode just fine. I received no "device not found" messages and no skipped music.

    So, I updated to iOS 4.2.1 on the iPhone 3GS, Firmware 05.15.04. After I finished up I took it out to the car and plugged it in……it worked.

    I was able to navigate music using the head unit and by choosing iPod Mode and navigating from the iPhone. Also the Sony unit charges the device through the USB connection.

    I tested again today and I am able to plug the iPhone into the stereo USB connector and make and receive calls and the music mutes itself when the call is established. I also tried using my Bluetooth headset and it worked with that too to make or receive calls.

    Just thought I would share my experience.
    Macbook, Mac OS X (10.6.6)
  • cwerstak Calculating status...
    I am having the same problem with my 2009 Subaru Impreza Outback Sport. After bying the vehicle, I had to almost immediately by a new plug from Subaru ($35) to accomodate the new dock connector. Everything worked great! Now with updating to iOS4, it no longer charges my phone! Assuming this comes from the Apple side of things. Is there a fix yet???
    iPhone 3GS, iOS 4
  • freestyla Calculating status...
    Currently Being Moderated
    Jan 26, 2011 7:54 AM (in response to jminn)
    jminn,

    I have the exact same Alpine in my 06 Civic. I am using an iPhone 4 with IOS 4.2.1 and everything works except for the fact that I am getting a popping / static sound when I try to play music through the USB connection.

    Are you having the same issue?

    Is anyone else having this annoying static issue?

    Message was edited by: freestyla
    iPhone 4, iOS 4
  • jlfreund Calculating status...
    Surprised after 34 pages of posts, no official answer from Apple?

    I have a Kenwood KDC-MP342U and it seems to have stopped working with one of the iOS4 upgrades, but don't know if it was 4.0, 4.1, or 4.2. When I connect the device, the stereo says: "Reading" forever. It used to work with OS3.

    I couldn't find any firmware upgrades on Kenwood's site for this, and since it's been 8 months, I guess we shouldn't hold our breath.

    I wonder why Apple decided to change the interface for this thing? How could that possibly be good for their users?
    Mac Mini, Mac OS X (10.5.2)
  • Almar48 Calculating status...
    Hi guys, I own an alpine ida-x001 after using a used iphone 3g just for music i did the latest update and that was the end. Not knowing it was the latest updates fault I went and bought a itouch 4 64. Went to work very happy, I plugged the usb into myu radio and nothing, same message ipod error. After reading these pages I'm very upset because I'm ready to upgrade the x001 to an pioneer avh 5200bt to use the ipod video and now I'm wondering if I'm going to have the same problems with the ipod. I'm a truck driver and work long hours, and besides listing to Howard stern all day I need my music. Very sad and fustrated.
    xps 9100, Windows 7

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.