Skip navigation

Airport Express losing connection

7000 Views 13 Replies Latest reply: May 26, 2012 11:24 PM by Lars Hansen RSS
Steve L 060373 Calculating status...
Currently Being Moderated
Dec 19, 2010 7:33 PM
Every other day, my MacBook Pro shows a wireless signal, but I can't connect. I have to unplug the airport express and replug it in for it to work. Anyone else experiencing this? My Airport Express is about 2 years old.
MacBook Pro, Mac OS X (10.6.5)
  • Tesserax Level 8 Level 8 (47,545 points)
    Currently Being Moderated
    Dec 19, 2010 8:18 PM (in response to Steve L 060373)
    Hello Steve L 060373. Welcome to the Apple Discussions!

    It is very possible that you may have some form of Wi-Fi interference that has been introduced recently in the immediate area that is preventing your MacBook Pro from getting a good clean signal from the AirPort Express Base Station (AX).

    I suggest you perform a simple site survey, using utilities like iStumbler, or AirRadar to determine potential areas of interference, and then, try to either eliminate or significantly reduce them where possible. You may find that by simply changing radio channels may resolve the problem.
     Macmini3,1, Mac OS X (10.6.5),  Macmini1,1  MacBook4,1  PowerMac3,5
  • CJHill Calculating status...
    Currently Being Moderated
    Dec 21, 2010 2:08 AM (in response to Tesserax)
    Steve

    Similar problem here. Every couple of days all the devices connected to my Airport Extreme lose the ability to communicate with each other, and they lose access to the internet (provided by a Draytek Vigor 120 ADSL modem). This applies to wired devices as well as wireless devices, so I don''t think it is wireless interference.

    Like you, on my wireless devices (MacBook, iPhones, iPad) I see a strong signal strength indicator, but no connectivity. In this state I can use the Airport Utility wirelessly from my Macbook (and wired from my Mac Mini) to access the Airport Extreme, and if I do a Restart, the result is the same as pulling the power plug from the back of the Airport - everything comes back up and works fine for a couple of days.

    To me it seems as though just the router function of the Airport has crashed. I've updated the Airport to 7.5.2 as of yesterday morning, and am watching to see whether this cures it - should know by this time tomorrow!
    Mac Mini, 2 x MacBook, 4 x iPhone, iPad, n x iPods........
  • sdevan Level 2 Level 2 (465 points)
    Currently Being Moderated
    Dec 21, 2010 6:52 AM (in response to CJHill)
    The upgrade didn't fix it for me. It has made the system a little more robust, but I got a complete failure yesterday and had to restart both the express and the extreme.
    iMac, Mac OS X (10.5.7)
  • CJHill Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 21, 2010 11:19 PM (in response to sdevan)
    It hasn't fixed it for me either unfortunately - the router crashed overnight again. Looking over the Airport Extreme logs, I see no activity around that time apart from occasional 'Rotated CCMP group key' messages. I can see when the crash happened though, as the hourly clock synchronisation fails - one hour it is fine, then an hour later I get 'No Address for NTP server time.apple.com.' Once again the ADSL modem is still running and connected, because it just took a reboot of the Airport (from a wireless Macbook) to get everything going again.
    Mac Mini, 2 x MacBook
  • macintush Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2011 9:57 AM (in response to Steve L 060373)
    I'm having the same symptoms. Both wired AND wireless connections are affected. Even when connectivity returns, the browser I'm using often remains frozen until I quit/exit and restart the browser. Happens with Safari on my iMac (latest versions of OSX 10.6.x and Safari) and Firefox on my Win7 laptop, so it's something wrong with my Aiport Extreme Base Station (dual band; firmware 7.5.2).

    Any ideas?
    Intel iMac 20" (late 2006) & many more, Mac OS X (10.6.5)
  • DVX100Shooter Level 3 Level 3 (840 points)
    Currently Being Moderated
    Jan 9, 2011 9:18 AM (in response to macintush)
    I am getting this issue when I wake my computer up from sleep mode. I have a super strong signal but for whatever reason when its in sleep mode, it screws up the AE and then I have to go into the Network Diagnostics. After the first 2 or 3 questions it asks, it will then say its working properly and my connection will return on its own. On other occasions it will continue asking me questions then tell me to reset the AE and my cable modem as well. This is a constant chore though and I want to believe there is something with my computer being in sleep mode that is causing this to happen.
    1.8 G5 PowerMac & 2.33 Dual Core Macbook Pro, Mac OS X (10.5.8), 6gigs of RAM, 250g & 1TB HD's, Final Cut Pro Studio3, Fotomagico Pro
  • jdj74 Calculating status...
    Currently Being Moderated
    Jan 31, 2011 6:22 AM (in response to DVX100Shooter)
    Has anyone found a solution for this? I too lose my internet once a day. Restarting the Airport Express solves it temporarily. Running firmware 6.3 on an older unit (its current max firmware).
    Mac OS X (10.6.6)
  • sship21 Calculating status...
    Currently Being Moderated
    Feb 27, 2011 2:12 AM (in response to jdj74)
    I also have this problem on an Airport Express G. Downgrading the firmware to 6.1.1 works for me, but then you lose a lot of features like AirTunes, automatic port mapping and WPA2 security. Definitely not the ideal solution...
    Macbook 5,1 (Unibody), Mac OS X (10.6.4)
  • guuus Calculating status...
    Currently Being Moderated
    Jul 29, 2011 12:29 AM (in response to Steve L 060373)

    Same issue here. No solution whatsoever. Only trick is a complete reboot of AE which is starting to annoy me.

    Thought the AE was mechanically broken somehow but that wouldn't explain that the issue is temporary.

  • Dude! Calculating status...
    Currently Being Moderated
    Feb 19, 2012 8:44 AM (in response to DVX100Shooter)

    My issues are almost the same as DVX100Shooter's. I am working from an iMac hardwired to my Time Capsule serving as my wireless base station, and AirPort Expresses serving as AirPlay speakers. I also have a B&W Zeppelin Air, and an AppleTV connected to speakers. After I reboot my computer, iTunes seems to connect fine with all my AirPlay devices. After my computer wakes from sleep, however, it looses the connection to my AirPort Expresses alone. The B&W and the AppleTV can still connect. I don't get an error message, and when I try to reconnect through iTunes, the message "Connecting to '<speaker name>'..." pops up with a progress bar that never moves, and then disappears without connecting. I don't even receive an error message.

     

    Restarting iTunes doesn't cure the problem. Unplugging and plugging the AirPort Express back in doesn't cure the problem. Resetting the AirPort Expresses doesn't work. I have the latest firmware installed on the Time Capsule and AirPort Expresses. The only thing that seems to work most most times (but not always), is to reboot the computer.

     

    I'm at a loss. Has anyone solved this yet?

  • Duinweg78 Calculating status...
    Currently Being Moderated
    Feb 29, 2012 11:37 AM (in response to Dude!)

    I have the exact same problem. Whenever my iMac goes to sleep, I lose connectivity to AirPort Express connected to Bose sound dock. The only way to get it back is to reboot the iMac. All software / firmware is up to date. VERY ANNOYING.

    I hope they get this fixed.

  • kirktimpdx Calculating status...
    Currently Being Moderated
    Feb 29, 2012 8:05 PM (in response to DVX100Shooter)

    Same problem here.  My wired AEXP loses connection to my AE when my computer goes to sleep.  The only way to reconnect is to reboot the computer.  I hope Apple is aware of the problem we all seem to have and is fixing it.  In the interim, I switching the power saver to never put the computer to sleep (it's a mini).

  • Lars Hansen Calculating status...
    Currently Being Moderated
    May 26, 2012 11:24 PM (in response to Steve L 060373)

    I too have this problem. In order to get it to work again I have to do a restart.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.