Skip navigation

How to open CD/DVD tray if the MacPro won't boot

32258 Views 8 Replies Latest reply: Jun 19, 2013 10:28 AM by onetruth1989 RSS
wve Rich Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 31, 2011 1:46 PM
Just a few days ago I updated my version Safari on a MacPro. After the upgrade, my computer, I got a message on the reboot that said that it cannot read the disks I inserted. Since then, I can't get the machine to start at all. I'd like to boot it up from a CD/DVD (Drive Genius) but can't figure out how to get the tray to open to let me insert it. (1) Has anyone had such issues with updating Safari? (2) How can I get the tray to open if I can't get the machine to boot up to start with? (I've tried rebooting and holding down the "c" key. I've tried "target disk" mode but that doesn't get me anywhere.) (I think it may have 10.5.8 OSX and two internal drives.)
Mac Pro, Mac OS X (10.5.8), 2 x 2.66 GHz; 2 GB RAM
  • Kappy Level 10 Level 10 (221,095 points)
    Currently Being Moderated
    Jan 31, 2011 2:08 PM (in response to wve Rich)
    Five ways to eject a stuck CD or DVD from the optical drive

    Ejecting the stuck disc can usually be done in one of the following ways:

    1. Restart the computer and after the chime press and hold down the left mouse button until the disc ejects.

    2. Press the Eject button on your keyboard.

    3. Click on the Eject button in the menubar.

    4. Press COMMAND-E.

    5. If none of the above work try this:
    Open the Terminal application in your Utilities folder. At the prompt enter or paste the following:
    /usr/bin/drutil eject

    If this fails then try this:
    Boot the computer into single-user mode. At the prompt enter the same command as used above. To restart the computer enter "reboot" at the prompt without quotes.
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; 11" MBA, Mac OS X (10.6.5), iMac C2D 17"; MB 2.0 Ghz; iPad 32G; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Malcolm Rayfield Level 7 Level 7 (28,070 points)
    Currently Being Moderated
    Jan 31, 2011 4:44 PM (in response to wve Rich)
    Boot with Option pressed. You should then be able to use the Eject key or Command-Period.
    Mac Pro (Early 2008), Mac OS X (10.6.6), iPhone 3GS 4.2.1
  • Grant Bennet-Alder Level 8 Level 8 (48,145 points)
    Lastly, the true desperation move is to remove the DVD drive, apply straightened paper clip to little hole in face, pull open the tray, insert DVD, close tray, re-assemble, hold down Option at Startup.
    Beige G3, G4/867, G4/dual 1.25 MDD, MacPro'09 w cheap SSD, Mac OS 8.6 or Earlier, and 9.2, 10.5 and Server - LW IIg, LW 4/600, ATalk ImageWriter LQ
  • Dick Lund Level 2 Level 2 (185 points)
    Currently Being Moderated
    Mar 4, 2011 1:01 AM (in response to wve Rich)
    Hello

    I have the same problem I just need to get the door open to use my install disc to sect another drive to start. What did you do to solve the prblem?

    thank you

    Dick
    2.8Quad 8 core/2 23" Cinema/14 Gig Ram/4 Int 500 HD/4USB PCI-e 2port PCI-x eSATA, Mac OS X (10.5.8), imac 2.5 Gig Ram/6Ext sataHD/3 Ext firewire HD//Macbk Pro 4gig ram
  • atomant7 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 11, 2011 6:52 AM (in response to wve Rich)

    I was just having a problem getting a DiskWarrior CD to eject on restart. MacPro wouldn't start in single user mode, holding down the eject key on startup, option on startup, left mouse button... What did work was unplugging my keyboard from my Cinema Display and plugging it directly into the MacPro. Normal startup options were then available.

  • ButteredApples Level 1 Level 1 (0 points)

    Thanks Malcolm, this worked for me to get a DVD in even though my machine couldn't boot past the blue screen (that comes after the grey screen).

    Sadly putting in an OSX install disc didn't do anything when I then rebooted.

  • onetruth1989 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 19, 2013 10:28 AM (in response to wve Rich)

    Thank you kappy that totally worked =)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.