Skip navigation

How do I find a printer driver from a vendor's install?

7206 Views 13 Replies Latest reply: Jan 8, 2013 1:30 PM by cweirup RSS
harv47 Level 1 Level 1 (10 points)
Currently Being Moderated
Jan 20, 2011 4:09 PM
I have a Brother P-Touch 2700 label maker. I downloaded and installed the OS X 10.5.x printer driver from the Brother site. It came as a .dmg file. The P-Touch Editor installed separately. When started, it claims the driver is not installed. It's not in the list of installed printers either.

I'm guessing it's not where the Editor expects to find it. How do I find the driver? I've looked in Library>Printers>Brother. To confuse matters, I also have a Brother laser printer.

The Brother support folks have not yet responded to my question.

Any help appreciated.

Mac Pro (model 3,1), Mac OS X (10.5.8), 4 GB RAM, 2 500 GB WD RE3 HD, 20 in CinDisp, 1 TB TM, iPhone 3G, iPad 32GB 3G
  • Matt Broughton Level 5 Level 5 (4,905 points)
    I took a look at the driver package. It installs three items in the /Library/Printers/Brother directory:
    P-touch Utilities folder

    It appears that Brother really goofed on the ownership and permissions for the files. You should open the Terminal application (/Applications/Utilities). Copy and paste the following into a Terminal window and then hit the Return key:

    sudo chown -R root:admin /Library/Printers/Brother

    You will be prompted for your password. After you enter your password, hit the Return key again. Make sure the P-touch is connected to your computer and turned on. Then try using the Print & Fax preference pane to add the printer.
    Mac Mini G4 and Intel C2D; B&W G3, iPad
  • roam Level 6 Level 6 (13,545 points)
    Is the password to be entered for the admin user, or for user harv?

    If harv is not an Admin user, the error that occurred is expected.

    This procedure should be done from an Admin users account and of course with their password.
    iMac (Core 2 Duo, 2008) eMac (ATI) iBook (G4) 10.3, Mac OS X (10.5.8)
  • Matt Broughton Level 5 Level 5 (4,905 points)
    That seems to be a common error and seems to be mostly associated with HP printers.

    Try resetting the printing system. See

    Try adding the printer when logged in to an administrator's account rather than your standard account.
    Mac Mini G4 and Intel C2D; B&W G3, iPad
  • imatsig Calculating status...
    The internet is a wonderful place for very obscure information Matt's sudo chown command worked for me, and I can now print on my Brother P-Touch 2730.

    The Brother printer driver install software had finished by saying it was successful but it lied and there was no sign of the printer in System Prefs / Print & Fax and the P-Touch editor complained that there was no printer installed but Brother PT-2730 has now magically appeared, brilliant.
    many thanks
    Mick London UK
    imac, Mac OS X (10.6.6)
  • Matt Broughton Level 5 Level 5 (4,905 points)
    Thanks for the positive reply. I am glad we could get things working for you.
    Mac Mini G4 and Intel C2D; B&W G3, iPad
  • Mitoids Level 1 Level 1 (0 points)

    Has somebody solved this problem for Lion?  I have installed the Pt-2600 driver on my iMac.  The install script says that it installed successfully, but the driver does not appear in the list when I go to add the printer.  I tried the sudo command with no success.  I realize that Brother does not support this printer on Lion, but I can't believe that it is that complicated.


    I also downloaded the PT-2700 driver from the Brother site.  This installed sucessfully.  I tried setting up the 2600 with the 2700 driver.  However, when I try to print, the software tells me that I am printing to a device that is not a PT-2700 and the print file just sits in the queue. 


    Any suggestions?  Either to get the PT-2600 driver to show up, or to get the PT-2700 driver to work with my older device?

  • cweirup Calculating status...



    Did you ever find a solution to your problem with the PT-2600? I have the same model, and it is frustrating that I can't get it to work on Lion. I'd appreciate any help you might have.



    Chris W.

  • Mitoids Level 1 Level 1 (0 points)



    Unfortunately, I never got it to work.  I may even have tried installing the driver on a Windows VM.  In any case, I have resorted to typing my labels using the keyboard on the device itself.


    Would love to find a soution though!





  • cweirup Level 1 Level 1 (0 points)



    Thanks for letting me know. Unfortunately, I need to print barcodes, so using the keyboard doesn't work for me. I also tried the Windows WM with no luck. Looks I need to find a Windows PC to do this.





More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.