1 2 Previous Next 22 Replies Latest reply: Apr 27, 2012 5:50 AM by buckster
Joe Pyrdek Level 1 Level 1 (135 points)
Since updating to ARD 3.4 and OS 10.6.6 I have had nothing but PROBLEMS with ARD.

ARD will just, for no apparent reason, decide to drop all the connections to the remote systems. They sometimes show as the light blue with "Screen sharing available", sometimes they just show black (no connection) and, rarely, they will come back after several minutes. Quitting ARD and trying to restart it will wither come up with the ARD window showing all the the remotes still not connected or will give me a error window that there is a problem with the installation and it can not start. It suggests reinstalling ARD. Then again sometimes it will restart normally.

If I can not get a usable ARD by quitting and reopening it, I have to do a full shut down (not even a restart will bring it back sometimes) of the entire computer. Reinstalling ARD 3.4 Admin does nothing to solve the problem.

All remotes are now at ARD 3.4 Client. The server is a Mac Pro 2.66 Quad Core Intel Xeon with 8 Gigs of RAM Software build is Server 10J567

Sometimes when ARD is running it is lower than I have ever seen. It may take three or four minutes to do a scan of a 255 address network range. When it decides it wants to stop running, trying a scan of a network range shows the spinning wheel but absolutely no systems located. The scan comes up completely blank and the wheel will stop after a minute or so.

ARD 3.4 ran fine for two or three days after installation but since then the problems have just kept coming and coming.

My feeling is that Apple really "screwed the pooch" when they came up with this update!

Anyone else having these kinds of problems and if so, what did you do to quash them?

MacPro QuadCOre Intel Xeon 8 Gig RAM (Model ID MacPro 4,1), Mac OS X (10.6.6), Software build 10J567 Server
  • 1. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    Joe Pyrdek Level 1 Level 1 (135 points)
    One other thing I forgot to mention is that when this problem happens, ARD seems to send something, to all the systems that are connected, that will relight the screens of machines where the Energy Saver has taken the screens black but the system has not yet gone to sleep.
  • 2. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    BadBoy9999 Level 1 Level 1 (0 points)
    Also having major problems with ARD 3.4. I purchased ARD through the AppStore.

    I have updated a number of Macs with Remote Desktop Client 3.4. There are both server and non-server Macs involved and all are completely up-to-date and running OS X 10.6.6.

    The only computer ARD is able to see the version of ARD on, do reports on, etc. (i.e., anything but observe and control) is the computer on which ARD itself is running.

    Needless to say I have tried disabling firewalls to see if there were any issues. I have also tried completely removing ARD and reinstalling (as detailed in one of the Apple technical notes).

    Help please...

    Bill
  • 3. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    peacemaster Level 1 Level 1 (0 points)
    I have very often a similar problem. In my case it is always resolved by deleting the com.apple.RemoteDesktop.plist file located in <harddisk>/<user>/Library/Preferences

    On the other hand if you do not get computers in the scanner window when you scan by network range it seems to me that you might have network (different "location"?) issues or the client ARD is not active.
  • 4. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    Joe Pyrdek Level 1 Level 1 (135 points)
    I did a complete removal, including the hidden ARD files and then did a permissions repair, disk repair and a new installation from disk of ARD 3.1 and then upgraded to 3.4 (with no intermediate updates). The problem has been reduced but not eliminated.

    Since the reinstall, the ARD app has shut down, without any warning, twice and then it restarted normally when told to re-open. So far it has NOT frozen the computer. When I do scans, across many different sub-nets, ARD seems to find the "new" computers and will handle them normally. When the ARD shuts down without warning it does not seem to matter if any others apps are running or not. One shutdown occurred when ARD was the only open app, while the other quit occurred when a couple of others app were running.

    ARD 3.4 still has the problem that 3.3.2 had in that a computer found on a previous scan and entered into the All Computers group but which is then shut down and the DHCP lease expires, will not allow a new computer to be entered if it has the same IP address that DHCP assigned to the old computer. I have to delete the old computer from the All Computers list and then re-enter it when it shows up on a later scan with a different IP addr. Like I said this existed for the last couple updates of 3.3 so this problem is NOT 3.4 specific.
  • 5. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    Mark Moorcroft Level 1 Level 1 (10 points)
    I'm having way more trouble with this update as well. It's definitely a step backward.
  • 6. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    BadBoy9999 Level 1 Level 1 (0 points)
    I have installed Mac OS X Snow Leopard (not server) from scratch (brand new partition), applied all updates and installed only Apple Remote Desktop. I am still unable to use ARD in any way other than observe and control.

    I tried this with several different networks. Still no luck. I have tried this with just two systems (the ARD machine and an OS X Server) on a switch. Still no luck.

    However, if I do the same install of ARD on a Mac OS X server all works fine. So, there appears to be something about regular, non-server, Mac OS X as the ARD system that is problematic.
  • 7. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    BadBoy9999 Level 1 Level 1 (0 points)
    I meant to mention that I am using the AppStore 3.4 (465.14) version of ARD.
  • 8. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    FLYFI5H Level 1 Level 1 (5 points)
    I have over 500 MacBooks and MacBook Pros that I manage and I have seen some performance issues since updating to 3.4 of ARD. The program will fail and want to restart, something it never did before. I find it is taking longer to scan and authenticate. It seems to be slower when sending commands (I can't quantify this because I never did any testing of the time it took prior to updating and compare it to now).
    Anyway I am posting to support those that are having the issue and hopefully Apple will take heed.
  • 9. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    FLYFI5H Level 1 Level 1 (5 points)
    I do not want this to come across wrong, I am asking this to see what to offer for help. Are you new to ARD?
    If you are new to ARD one area to check on the machine you want to control is under System Preferences > Sharing there are two areas you want checked Remote Management and Remote Login. Add the user who will have the rights and under Remote Management check the option and select what (or All) rights you want to give.
    If I am being as clear as mud, let me know and I will try to explain better.
  • 10. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    BadBoy9999 Level 1 Level 1 (0 points)
    Not coming across wrong to me. Appreciate the suggestions.

    However, unfortunately I have checked those boxes, and added the user with the appropriate rights.

    What is strange to me is that the AppStore ARD is working when installed on OS X Server, but not working when installed on OS X desktop.
  • 11. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    BadBoy9999 Level 1 Level 1 (0 points)
    Peacemaster,

    I have tried deleting the com.apple.RemoteDesktop.plist file, but unfortunately that has not done the trick.
  • 12. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    Brian Nesse Level 4 Level 4 (2,780 points)
    You might look in /System/Library/LaunchAgents as well. You should find a com.apple.RemoteDesktop.plist file. If you also find a com.apple.RemoteDesktop-a.plist, and or a com.apple.RemoteDesktop-b.plist file delete them. They confuse launchd and keep ARD from functioning properly.
  • 13. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    rcmgk Level 1 Level 1 (0 points)
    I am running OS X Server 10.6.6 and ARD 3.4. Since updating I am not having any major problems with the operation of the program, but I have a minor one.

    I cannot control a computer and Command + Tab on the remote display.
  • 14. Re: aaard 3.4 & OS 10.6.6 BUGGY!!!!
    jeffy2be Level 1 Level 1 (0 points)
    Hi,

    Just want to let everyone know that I don't have any apparent problems after updating ARD and the clients to 3.4 via the Software Update… I did not do it via the App Store. Maybe there is an issue that process. But everything I normally did using ARD is working fine. And I upgraded to my computer running the ARD app 10.6.6 too! And no problems. Some of my clients are running OS 10.6.6 and some still running Tiger 10.4.11, and everything seems to be working fine. I think the new version works a lot better. For me, 3.4 allows working with the clients dock much easier. You no longer have problems dragging stuff into the the client's dock. Before I always had to go directly to the clients machine just to drag an icon into the dock.
1 2 Previous Next