Skip navigation

AirPlay dropping out

8946 Views 12 Replies Latest reply: Apr 14, 2011 6:23 AM by Boggled RSS
Tony Fletcher Level 1 Level 1 (5 points)
Currently Being Moderated
Jan 18, 2011 7:57 AM
the Airplay on my iPod touch keeps dropping the signal, even when placed right next to an Airport Express. Other desktop/laptop computers are not having this problem. Any logical explabation anyone can offer??

Thanks

Tony
iBook G4 60GB, Mac OS X (10.4.1)
  • rjpalumbo24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 29, 2011 5:08 AM (in response to Tony Fletcher)
    i am having the same problem. but it seems to occur when my network activity idles, i.e. if i just let the ipod sit, and the screen go blank, audio will cut out several seconds after that. if i keep the ipod 'awake' and doing things--even things that do not require an internet connection--the sound does not disconnect.

    i have also noticed that sometimes if im demanding a lot of the processor, audio may cut out (has happened maybe once) and/or 'music' will reset (i.e. my music library will be back up at the top, or genius--the first icon at the bottom on the left in my case, since i have genius activated--will be up as opposed to song information for the song i had just been listening to).

    definitely seems to be something to do with the ipod keeps a connection with the network. does anybody know how to keep the network connection from idling when using airplay? (like with the remote app, you can keep it connected [at least in an older release] to the internet and your music library so it doesnt have to keep searching for it every time you go to use another app). i have not had any of these problems with my macbook pro, either, so my guess is it must be the ipod (airport extreme extended by airport express). in the times ive tried it, my mac has been asleep and not using bandwidth. i am the only user of my wireless connection. small apartment. no interference to date. etc.

    anyone have a solution?
    ipod touch 2g, iOS 4
  • Joseph Kriz Level 5 Level 5 (5,045 points)
    Currently Being Moderated
    Jan 29, 2011 11:36 AM (in response to Tony Fletcher)
    Tony,

    Is the Express also your main base station or do you have a different base station?
    If you have another base station, how does the Express connect to it?
    "Join" or "Extend" the network?

    I have an Airport Extreme as the main base station and several Airport Express units connected to 3 different stereos and my setup seems to work fine.

    If you have your setup set to automatic channel, you might try using a different wireless channel and see if that helps.
    iMac 27 (11,3), iMac 21.5 (10,1), MacMini (3,1), iPod Touch, Mac OS X (10.6.6)
  • rjpalumbo24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2011 11:10 AM (in response to Joseph Kriz)
    i switched to extend network as opposed to join, and the ipod seems to be able to idle much longer than before, however, it will still cut out after about a minute, and start back up again as soon as i hit the home button.
    macbook pro 13" (mid 2009), Mac OS X (10.6.6)
  • Joseph Kriz Level 5 Level 5 (5,045 points)
    Currently Being Moderated
    Feb 1, 2011 12:25 PM (in response to rjpalumbo24)
    What is your Main base station then.
    Airport Extreme?
    Time Capsule?

    Where is the AX located in reference to the main base station? Distance?

    Are you sure you are connecting to the AX or are you connecting to the main base station.
    You would need to check this out in the Airport Utility application to find out which wireless device you are getting the connection from.
    The iPod or any device will connect to the closest base station or the one with the strongest signal.

    Let us know a little more.
    iMac 27 (11,3), iMac 21.5 (10,1), MacMini (3,1), iPod Touch, Mac OS X (10.6.6)
  • rjpalumbo24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2011 4:03 PM (in response to Joseph Kriz)
    my main base station is an airport extreme. my macbook pro is connected to the 5 ghz channel, and ipod touch (2g) is connected to just the regular network from airport extreme (i.e. it doesnt see that the airport extreme is broadcasting on a variable frequency channel, and a fixed 5 ghz channel, whereas my macbook pro can; not sure what the difference in channels is aside from interference from local wireless devices, but i didnt experience the macbook pro disconnecting from airplay back when i only had airport express joining my old linksys router [i.e. a non-5ghz channel]; i never used my ipod touch with airplay during this time). the airport express is set up to extend my wireless network, and obviously, this is how i connect to airplay. my macbook pro never disconnects from airplay, even after just sitting there and idling. the ipod touch will disconnect from airplay after the screen has turned off and the ipod has been idle for approximately a minute or two (when the airport express is set up to join the wireless network, the ipod typically disconnects just seconds after screen timeout. why this is, i do not know).

    my guess is that it isnt wireless interference because it would not cut out with such reproducibility--it would have a larger degree of variability.
    macbook pro 13" (mid 2009), Mac OS X (10.6.6)
  • rjpalumbo24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2011 5:20 PM (in response to Joseph Kriz)
    also. i do have the latest version of iOS4, and so, the ipod should be retaining wifi connectivity despite being in sleep mode. i have my extreme radio set to automatic, and my MBP connects to the 5 GHz channel (wide). the airport express is joined to the 2.4 GHz airport extreme channel, and that is also what my ipod touch is connected to (as a 11g device). fyi
    macbook pro 13" (mid 2009), Mac OS X (10.6.6)
  • Joseph Kriz Level 5 Level 5 (5,045 points)
    Currently Being Moderated
    Feb 1, 2011 6:12 PM (in response to rjpalumbo24)
    rjpalumbo24,

    Let me try and explain a little about my setup which sounds similar to what you want.

    I have an Airport Extreme base station.
    My Express is 60 feet away in a detached garage and connected to a stereo.
    I have the Express set to "Extend" the network... Not "Join"...

    Now, when I take my iPod Touch out to the garage, the sound will skip if the iPod Touch is connected to the Airport Extreme...
    I have to make sure that the iPod Touch is connected to the Airport Express which is giving on the "Extended" signal. Then, my iPod Touch does not skip....

    I have tested this through many trail and errors etc....
    The only way to check which unit you are connected to is by using the Airport Utility application.
    In the Airport Utility you can open both the Airport Extreme and Airport Express windows and see what is connected to these wireless devices....

    For me this isn't that easy to explain so I'm hoping you understand what I am saying here.
    Just because you are connected to your network doesn't tell us whether you are connected to the Airport Extreme for your connection or the Airport Express which is the extension of your network.

    Let us know if this is clear enough or not.
    Hope this helps.
    iMac 27 (11,3), iMac 21.5 (10,1), MacMini (3,1), iPod Touch, Mac OS X (10.6.6)
  • rjpalumbo24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2011 10:17 AM (in response to Joseph Kriz)
    right. the ipod is connected to the extreme. i tried a configuration in which the express was to extend the network, and allow clients, but the express itself didnt show up in the network list (not sure if its supposed to, or if this network would have the same name as the extreme).
    macbook pro 13" (mid 2009), Mac OS X (10.6.6)
  • rjpalumbo24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2011 10:35 AM (in response to Joseph Kriz)
    when i have the airport express set to extend the b/g compatible channel from the extreme, thats what i connect to with my ipod (and the name that shows up is the same as the b/g channel from the extreme; not sure if the express can possibly show a different name unless setup as its own individual network). i guess the problem is im extending a network with both the airport extreme and express within several feet of each other, and the ipod cant discern between the original network and the extended network. and it probably cuts out as it switches connectivity from one network to the other. or something like that.

    is there any way to have the ipod only connect to the extended signal? perhaps via mac filtering?
    macbook pro 13" (mid 2009), Mac OS X (10.6.6)
  • Joseph Kriz Level 5 Level 5 (5,045 points)
    Currently Being Moderated
    Feb 2, 2011 10:57 AM (in response to rjpalumbo24)
    If the Express is only a few feet away, you would be much better off just "Joining" the existing network.

    I have one setup this way in my office where I have my Computers and Airport Extreme base station along with a stereo and the Express.

    Give that a try.
    iMac 27 (11,3), iMac 21.5 (10,1), MacMini (3,1), iPod Touch, Mac OS X (10.6.6)
  • rjpalumbo24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 5, 2011 3:47 AM (in response to Joseph Kriz)
    i ave tried both joining and extending. neither configuration resolves the issue, though i have notice that extended seems to allow the ipod to idle for longer before cutting out.

    interestingly, isnt the newest version of iOS supposed to keep the ipod connected to the internet despite going into sleep mode? seems like that update would prevent the issue that i am having, though it does not.
    macbook pro 13" (mid 2009), ipod touch (2g), airport extreme, airport express, Mac OS X (10.6.6)
  • Boggled Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2011 6:23 AM (in response to rjpalumbo24)
    Hi, newbie here

    My setup is: iMac (connected via ethernet to router), Airport Extreme (connected via ethernet-over-power to router), 2 Airport Expresses, an iPhone4 and an iPod Touch (3). After having many problems with streaming music to the AExs I recently managed to get a secure, non-dropping out, connection by moving my Airport Extreme from the room with my iMac in to one of the rooms with an AEx, which is next to the room with the other AEx. Brilliant!

    However, whilst I can stream via Airplay without a problem (so far) from my iPhone4, the Airplay icon has disappeared from my iPod Touch. I followed a bizarre recommendation of changing my iPod's language to non-English (I chose French) and then reverting back to English, deleting the new keyboard at the same time. This fixed the problem at that time, but today the Airplay icon has gone again! iPhone4's Airplay facility still there. Does anyone have any thoughts?
    iMac, Mac OS X (10.6.7)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.