Skip navigation

Mac Mail Sent emails disappear and re-appear

29295 Views 44 Replies Latest reply: Feb 27, 2014 11:18 AM by slipman625 RSS
1 2 3 Previous Next
martini27 Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 3, 2011 4:49 PM
I have been having the same problem for several months: I hit "send" in Mac mail and the dialogue box would go away like normal and then nothing else would happen. No status bar on the bottom left or "whoosh" and then the sent mail does not appear in any of the sent mail folders (I have 3 email addresses and this happens on all 3). This does not happen 100% of the time but rather about 40%.

Since I can't tell if my email got sent, I then have to quit and re-start the program to try to make sure. SOmetimes it sends later out of nowhere (or the next day). SOmetimes it was sent but I can't really tell until I get a reply on it. Other times the sent emails magically re-appear out of nowhere in my sent mail box. Sometimes my inbox messages appear and disappear.

This is **** on wheels trying to work during the day when I can't ever tell if my emails have sent. And to top it off, when I hit the little "replied" arrow next to an inbox item, all I ever get is "Mail was unable to find your reply to the message “RE: credits”. You may have deleted the message."

Anybody seen anything like this? I have deleted my plist and mailboxes and re-created them several times to no avail. I have a godaddy account, a mobile me account and a gmail account. All 3 smae problem.

thanks
Macbook, Mac OS X (10.6.6)
  • amz1 Calculating status...
    Currently Being Moderated
    Feb 3, 2011 5:30 PM (in response to martini27)
    I have this problem too. C'mon Apple, get your act together. It's the 21st century and your Mail program is buggy like crazy!
    Apple MacBookPro, Mac OS X (10.5.8)
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Feb 3, 2011 5:33 PM (in response to martini27)
    Is your email account only configured on one computer or do you have it set up on multiple devices?

    Is the account IMAP or POP?

    Who is your ISP?

    Matt
    Intel Core i7 2.93 GHz iMac 4 GB RAM/MBP 2.26GHz 2GB RAM/iPod nano 4g/iPhone 4, Mac OS X (10.6.6), Time Capsule, AirPort Express
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Feb 3, 2011 7:03 PM (in response to martini27)
    And which account are you having the problem with? Or is it all of them.

    Matt
    Intel Core i7 2.93 GHz iMac 4 GB RAM/MBP 2.26GHz 2GB RAM/iPod nano 4g/iPhone 4, Mac OS X (10.6.6), Time Capsule, AirPort Express
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Feb 3, 2011 9:02 PM (in response to martini27)
    OK.

    Where do you store all your messages?

    Locally on your Mac or on the server of your ISP?

    If you're storing a lot of messages on your ISPs server, that could be your problem.

    Matt
    Intel Core i7 2.93 GHz iMac 4 GB RAM/MBP 2.26GHz 2GB RAM/iPod nano 4g/iPhone 4, Mac OS X (10.6.6), Time Capsule, AirPort Express
  • rgomez Calculating status...
    Currently Being Moderated
    Feb 4, 2011 10:41 AM (in response to martini27)
    I've been experiencing some similar problem (where the email is sent but not stored anywere)

    Just saw in the Console log that it stores an error that reads like:

    "Error (null) ocurred while trying to append messages to outgoing store"

    Do you have an error like that also?

    I've just enabled the debugging log on my IMAP Server (MailEnable 5) to see if it happens again, what's stored there (as I did not find any error in the activity log), but I have the feeling this has more to do with Mail.app than with the Mail Server itself (and if you have that also with gmail and/or your ISP would "confirm" it)
    Macbook Pro, Mac Pro, iPhone, Mac OS X (10.6.6)
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Feb 4, 2011 2:51 PM (in response to martini27)
    I store all messages on my Mac (they download from the server).


    Including messages you send?

    Matt
    Intel Core i7 2.93 GHz iMac 4 GB RAM/MBP 2.26GHz 2GB RAM/iPod nano 4g/iPhone 4, Mac OS X (10.6.6), Time Capsule, AirPort Express
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Feb 4, 2011 2:55 PM (in response to martini27)
    it sometimes creates a copy in draft folder that just sits there until I move it to some other folder or delete it. ????


    That indicates to me some sort of a network issue.

    Do you find you have problems when you are on any network or is it just limited to the network in one location.

    I'll occasionally get left over Draft when I'm on our lousy network at work, but it never happens when I'm on my network at home.

    Matt
    Intel Core i7 2.93 GHz iMac 4 GB RAM/MBP 2.26GHz 2GB RAM/iPod nano 4g/iPhone 4, Mac OS X (10.6.6), Time Capsule, AirPort Express
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.