Skip navigation

airport express shuts down after december update firmware

3265 Views 5 Replies Latest reply: Feb 7, 2011 7:31 AM by MaXaP RSS
pdoyle Calculating status...
Currently Being Moderated
Dec 27, 2010 7:25 PM
can anyone advise me on AEXpress which shuts down very soon after powering up, all since i upgraded firmware earlier in december? this is a replacement model which i got new in summer 2010...out of warranty now. it was fine on XP as client mode connecting wirelessly to Linksys WRT160N router; since upgrade, the airport express shows green light for 2 seconds; then amber for 1 minute; then no light at all. sometimes i plug it in and no lights appear at all. i doubt it's hardware as it followed the software update immediately. Should I somehow try to reinstall the previous software? but don't know how to do that since it won't stay powered on and doesn't show on airport utility. thanks, pdoyle
Compaq Presario SR1220 NX desktop, Windows XP, ethernet wired to Netgear router; not the 'home computer' on the network
  • Bob Timmons Level 9 Level 9 (75,575 points)
    Your best option is going to be to try to perform a Factory Default Reset on the AirPort Express to see if that will clear up the difficulties. If this is successful, you could rollback the firmware to an earlier version or reconfigure the device again with the current version of firmware.

    o Power down the Express for at least 20 minutes
    o Hold in the reset button and keep holding the reset button in as you plug the Express back in to power
    o Keep holding the reset button until you see the amber light blink more quickly. Hold another 3-4 seconds when you see this and release the reset button.

    With luck, the Express has now been returned to default settings so you can try to reconfigure it again.

    If you try the Factory Default Reset a few times and the Express is still having difficulties, I'm afraid there's been an internal failure within the device and it will need to be replaced.
    MacBook Pro, iMac, Mac OS X (10.6.5), Time Capsule, AirPort Extreme, AirPort Express, iPhone
  • Bob Timmons Level 9 Level 9 (75,575 points)
    It sounds like you have had an internal hardware component failure on the Express. It's hard to imagine that a software update could cause an electrical component to fail, but I suppose that anything is possible.
    MacBook Pro, iMac, Mac OS X (10.6.5), Time Capsule, AirPort Extreme, AirPort Express, iPhone
  • Tech Guy Dre Level 1 Level 1 (0 points)
    Thank you so much for this post. Mine went red in the last 3 minutes of the Superbowl Game. I tried everything to get it back to factory. I followed the steps, but I left it for the next morning and I got it to work. I was not looking forward to fighting with traffic and other drivers to get in the mall to get Apple to look at it!

    Again, thank you!
    MBP I5 2.4, 4G Ram, 320 HD Mac OS X (10.6.5) iPad 3G, iPad Wifi, iPhone 4 (I, Mac OS X (10.6.5), 3.0 GHz Core 2 Duo, 4GB Ram, 2 SATA DVD Brns, 2 SATA HD, 11 USB 2.0, 1gb VC
  • MaXaP Level 1 Level 1 (0 points)
    After December firmware update, my AirPort Express keep shutting down as well. Nothing helps.
    MBP 15 Alu '10, Mac OS X (10.5.7)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.