Skip navigation

links open in wrong browser

14444 Views 20 Replies Latest reply: Jan 31, 2014 10:01 AM by mmmond RSS
1 2 Previous Next
jaileer Calculating status...
Currently Being Moderated
Feb 8, 2011 6:22 AM
I have my default browser set as Chrome. When I click links in mail, or right click and select "search with google," they open in Safari.

I went to Safari to ensure that Chrome was selected as the default browser and it is. Any other ideas?

Thanks!
MacBook Pro, Mac OS X (10.6.6)
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Feb 8, 2011 6:41 AM (in response to jaileer)
    In Safari>Preferences>General do you have Chrome selected as the default browser.

    Matt
    Intel Core i7 2.93 GHz iMac 4 GB RAM/MBP 2.26GHz 2GB RAM/iPod nano 4g/iPhone 4, Mac OS X (10.6.6), Time Capsule, AirPort Express
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Feb 8, 2011 7:35 AM (in response to jaileer)
    What happens if you switch it back to Safari quit then open a link.

    Change back to Chrome quit and try the link again.

    Matt
    Intel Core i7 2.93 GHz iMac 4 GB RAM/MBP 2.26GHz 2GB RAM/iPod nano 4g/iPhone 4, Mac OS X (10.6.6), Time Capsule, AirPort Express
  • Matthew Morgan Level 7 Level 7 (22,420 points)
    Currently Being Moderated
    Feb 8, 2011 8:21 AM (in response to jaileer)
    Thanks for fixing the main issue, though! (i know better, i should have done that first...)


    You're welcome. I'm glad I could help.

    It seems that the prefererance you set in Safari can be overridden if you dismiss that dialogue warning when you first open something in Chrome.

    I'm not sure if there is any way around the Google thing.

    Matt
    Intel Core i7 2.93 GHz iMac 4 GB RAM/MBP 2.26GHz 2GB RAM/iPod nano 4g/iPhone 4, Mac OS X (10.6.6), Time Capsule, AirPort Express
  • mjuarez Calculating status...
    Currently Being Moderated
    Feb 11, 2011 5:28 AM (in response to jaileer)
    jaileer wrote:
    I have my default browser set as Chrome. When I click links in mail, or right click and select "search with google," they open in Safari.

    Thanks!


    I'm running into this same issue. Seems like Mac Mail's "Search with Google" option is somehow hard-wired to Safari. Any ideas on how to fix this?
    MacPro 1,1, Mac OS X (10.6.6)
  • Neal Bridgens Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 2, 2011 4:02 PM (in response to mjuarez)
    I'm having this problem too. And it transferred to my new laptop with migration assistant somehow.
    Not a problem on my promac, it opens with chrome just fine.
    Pro Mac 8x2.8 - G4 733 - MacBook Pro 2x2.4 - And a classic in the closet!, Mac OS X (10.6.3), Started with a 6100/60 av OS 7.1…
  • notetoself.net Calculating status...
    Currently Being Moderated
    Mar 2, 2011 7:32 PM (in response to jaileer)
    I found this and several similar threads while looking for an answer to my issue. When selecting text and clicking "Search in Google" within Preview, Safari opens even though Chrome is my default browser.

    From the other threads, I see that several other Apple applications override the user's browser preference and force them to use Safari. This seems familiar. Didn't Microsoft get into trouble a few years back when they manipulated the OS to prefer Internet Explorer over other browsers?
    11" Macbook Air, Mac OS X (10.6.6), 1.6 Ghz, 4GB DDR3, 120GB SSD
  • Krag Level 2 Level 2 (215 points)
    Currently Being Moderated
    Mar 3, 2011 9:19 AM (in response to notetoself.net)
    It may be they coded Mail to use Safari rather than the Default Browser. My Safari issues stopped when I switched to "open in 32 bit mode".
    Macbook Pro, 2 Mini's, Mac OS X (10.6.6)
  • andyBall_uk Level 6 Level 6 (17,440 points)
    Currently Being Moderated
    Mar 3, 2011 9:44 AM (in response to notetoself.net)
    The 'search with google' option is a 'service' offered by the Safari application, like 'look up in dictionary' or 'new textedit window'...

    I suppose that it should be named differently, since plenty of people expect it to use the default browser.

    see the macworld hint at http://hintsforums.macworld.com/showthread.php?t=111762 post #9
  • silby102 Calculating status...
    Currently Being Moderated
    Jul 26, 2011 3:43 PM (in response to jaileer)

    Similar problem I've found but fixed. I have a broken arm and it's difficult to hold down cmd and click or do the shortcut (which doesn't work anymore), so I found a workaround based on http://rentzsch.tumblr.com/post/5794765921/search-with-google-using-chrome

     

    It will take less than a minute to implement.

     

    Open Automater -> Choose Service -> Find 'Run Shell Script' action and drag to workflow window -> Choose '/usr/bin/ruby' from Shell drop down menu -> type the following

    require 'cgi'

    `open 'http://www.google.com/search?q=#{CGI.escape(STDIN.read.chomp)}'`

     

    Then save it with a title like "Search With Google (New Window)" and you are done. Then rather than using the shortcut, just right click the highlighted text you want to search and you can use this new service. It should work with whatever you have your default browser to be set to in Safari preferences. Just make sure you choose the new service and not the original.

  • Ferro Level 2 Level 2 (455 points)
    Currently Being Moderated
    Oct 26, 2011 7:04 AM (in response to silby102)

    Hi Silby102 when I open Automator (2.1.1) I don't see Service but Services  than what about run Shell Script, sorry but never tried such things before so I want to make sure I am not messing up soemthing.

     

    Thanks

  • bozo_z_clown Calculating status...
    Currently Being Moderated
    Mar 10, 2012 11:55 AM (in response to Matthew Morgan)

    Resetting the default browser to Chrome in Safari (even though that is what it showed it was already set to) fixed the issue for me (the Pandora app was opening links in an old copy of Firefox).

     

    1. Open Safari
    2. Open "Preferences..."
    3. On the "General" tab set the "Default Web Browser" to "Safari"
    4. Close Safari
    5. Open Safari
    6. Open "Preferences..."
    7. On the "General" tab set the "Default Web Browser" to "Chrome" (or your choice)
    8. Close Safari
    9. Try your link again
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.