Skip navigation

iMovie not recognizing camera

5045 Views 4 Replies Latest reply: Jul 30, 2013 3:45 PM by brand1130 RSS
pinballwizard Calculating status...
Currently Being Moderated
Feb 8, 2011 12:18 PM
Hey everyone.

So on Sunday I started uploading my footage from my camera through imovie with no problems. I got through five tapes and had no issues. Well, when I wanted to finish the rest of my tapes, I plugged my camera back in through the firewire and connected my external hard drive, but when I try to "Import from Camera" through iMovie, it wont read the camera anymore-- it just shows the built in camera. I've tried just about everything-- restarting my computer, unplugging, turning the camera off/on, letting my camera power off for a while. And it's still not recognizing my camera after it worked perfectly on sunday. The Firewire port just says: "Maximum Speed: Up to 800 Mb/sec"

Is there anything more I can do? Is this a problem within iMovie or my firewire?

Thanks!
13" MacBook Pro, Mac OS X (10.5.8)
  • Mac on Andy Level 3 Level 3 (825 points)
    Currently Being Moderated
    Feb 8, 2011 12:46 PM (in response to pinballwizard)
    Welcome to Apple Discussions.

    The following support article would be a good place to start

    http://support.apple.com/kb/TS1059
    imac 27" i3, Mac OS X (10.6.6), iphone4, ipad, apple tv
  • ocean8 Calculating status...
    Currently Being Moderated
    Feb 11, 2011 3:56 PM (in response to pinballwizard)
    I have the same story as pinballwizard. I am at a school in the middle of big video projects. I was able to connect to my camera(s) on Friday, February 4. On Monday, none of my computer lab computers recognize the cameras. The only changes I have made between downloads was software updates. Could there be something wrong in the update?

    I, too have tried all the usual trouble shooting tricks... power, restarts, new cables, different cameras, etc.
    iMac, Mac OS X (10.5.8), multiple computers
  • brand1130 Calculating status...
    Currently Being Moderated
    Jul 30, 2013 3:45 PM (in response to pinballwizard)

    Well, I had this issue and found a fix. It may be a fix for myself only, but it worked. I tried everything and no matter what I did, iMovie would not recognize the camera, only the iSight. However, even though iMovie would not recognize the camera, the computer still recognized the SD Cards and mounted them on the desktop. I opened one up and browsed to the movie clips. Then I simply dragged one of them over to the Event Library in iMovie. Only THEN did iMovie finally recognize my camera. It said "This file cannot be copied, it must be imported with iMovie Importer." I clicked yes and poof, problem solved.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.