Skip navigation

Question about battery connector voltage

1909 Views 2 Replies Latest reply: Oct 6, 2012 7:06 PM by dokidaveapple RSS
Llessur999 Level 4 Level 4 (1,155 points)
Currently Being Moderated
Feb 10, 2011 9:01 AM
I have a MacBook 2 GHz (2,1 Late 2006) with the frequently reported problem where the battery is not recognized (black X in battery status icon). The MacBook works fine on the AC adapter (green LED, never changes to orange). A new battery operated the laptop on battery power but would not charge. The battery was sold to a friend because it charged fine in their MacBook, so presumably the new battery was not defective. So the problem is my MacBook will not charge the battery. Based on numerous posts to this forum, the problem must be one of the following parts is defective:
1. Battery/sleep switch cable.
2. DC-in module.
3. Logic board.

I measured the voltage at the battery connector (pin numbers left-to-right when looking into the battery bay):
1: 0 (ground)
2: 3.26
3: 3.41
4: 3.41
5: 0
6: 12.58 for 1st few seconds after plugged in, then floats around 0

The initial 12.58V on pin 6 seems promising because that is sufficient charging voltage for the 10.8V battery. The fact that it drops to zero might be a problem, or might be normal when no load is detected (I can only measure this when the battery is removed). Surprisingly I can't find specs that show what the voltage at each pin should be.

The first two are very cheap parts and easy to replace. The 3rd is definitely not worth replacing on such an old MacBook. I am seeking advice on troubleshooting to determine whether either of the first two parts is defective.

Note: I have already followed the commonly recommended resolutions including resetting the SMC. No difference. Because the battery is not recognized, system profiler reports the battery is not installed, and does not show any information about the battery.
MacBook 2 GHz (2,1 Late 2006), Mac OS X (10.4.11)
  • dokidaveapple Calculating status...
    Currently Being Moderated
    Oct 6, 2012 7:06 PM (in response to Llessur999)

    i will just copy paste your post and change the data: your post

    I measured the voltage at the battery connector (pin numbers left-to-right when looking into the battery bay):

     

    1: 0 (ground)

    2: 2.4

    3: 3.56

    4: 3.56

    5: 0

    6: no charge at all

     

    on my macbook 4,1 OS X 10.5.8 2.1 GHz Intel Core 2 Duo 1GB 667 MHz DDR2 SDRAM

     

    any help is appreciated!

     

    Message was edited by: dokidaveapple

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.