Skip navigation

Time Machine Gets Stuck In "Calculating Changes"

2860 Views 10 Replies Latest reply: Apr 8, 2012 6:17 AM by MudShark RSS
Cerebro Level 1 Level 1 (90 points)
Currently Being Moderated
Jan 18, 2011 8:08 AM
Three times in the past three days, I have been having problems with Time Machine. Occasionally, when it was starting to do a backup it would get stuck on "calculating changes" and would not proceed beyond that stage.

I have a 2010 15" 2.53 GHz i5 MacBook Pro, running 10.6.5. My time machine back-up volume is a 1TB Fantom GreenDrive Quad (http://fantomdrives.com/products/greendrive-quad.htm) connected via FireWire 800. My drive is formatted and partitioned correctly (Mac OS Journaled, GUID Partition Table).

The first time it happened, my troubleshooting research led me to determine that the safest way to "unstick" TM was to open Activity Monitor and force quit the "backupd" process. This ended the TM process, but I was still unable to unmount the TM volume or restart my MacBook without having to do a hard shutdown. I would, then, boot up, reconnect and mount the TM volume, and the backups would resume as normal. I verified, both, my internal drive and the TM volume with disk utility and found no issues.

The second time it happened, I decided to do a hard reset of TM which, essentially, entails trashing the TM preference file and setting up TM again from scratch. At this point, I thought I was in the clear.

The third time it happened, I researched the issue a bit further. It started a back up and then it hang on "calculating changes". I payed attention to the console logs at the time this occurred and saw the following:

1/17/11 11:01:58 PM kernel IOSCSIPeripheralDeviceType00::setPowerState(0x13e9db00, 1 -> 4) timed out after 100171 ms
1/17/11 11:06:05 PM kernel IOSCSIPeripheralDeviceType00::setPowerState(0x13e9db00, 4 -> 3) timed out after 100116 ms
1/17/11 11:11:05 PM kernel IOSCSIPeripheralDeviceType00::setPowerState(0x13e9db00, 3 -> 2) timed out after 100120 ms
1/17/11 11:13:05 PM kernel IOSCSIPeripheralDeviceType00::setPowerState(0x13e9db00, 2 -> 4) timed out after 100119 ms
1/17/11 11:16:25 PM kernel IOSCSIPeripheralDeviceType00::setPowerState(0x13e9db00, 4 -> 3) timed out after 100117 ms

I'm not an expert at reading these things, but more online digging led me to believe that my issue has something to do with the Fantom Drive's own power saver mode. It seems that, periodically, TM may start a back-up and have difficulty waking the drive from it's sleep state (can anyone verify if I'm off the mark, here?).

From my research, it seems like the fix to this issue is to deselect the "Put Hard Disk(s) To Sleep When Possible" option in the Energy Saver preferences (this is also the suggestion offered in the manual for the drive itself). I haven't yet concluded whether or not this has resolved the issue. I can only wait and see.

Can anyone else tell me if they've had this sort of issue and how they have, ultimately, solved it?

Is deselecting "Put Hard Disk(s) To Sleep When Possible" detrimental to performance in any way? It's not as if the drive never sleeps. As per my routine, I, manually, put my computer to sleep twice a day (before I go to bed, and before I leave for work in the morning). When I do, both the computer and the drive spin down.

Sorry for being long winded. I'm annoyed that this problem keeps occurring and want to put a stop to it.

Thanks.
MacBook Pro 15.4 inch 2.53 GHz Intel Core i5, Mac OS X (10.6.5)
  • scot Calculating status...
    Currently Being Moderated
    Jan 20, 2011 12:33 PM (in response to Cerebro)
    Id like to piggyback on this. I have very similar setup and condition, 15" Macbook Pro 2.4Ghz Core2 Duo, coupled to a LaCie Quadra D2 320 Gb drive connected with a FW800 cable. I'm running OS 10.6.6.


    I have tried erasing, verifying, and repartitioning, the drive (now it only has one drive partition). I have verified the drives on the Mac and LaCie, rebuilt the permissions, zapped the PRAM, and even did a reinstall of the OS (not clean). The setup has worked for a year or so until recently. I can get the drive to operate normally for the first backup only (58Gb)which I suspect is not complete. Then subsequent backups get as far as "calculating changes" with a spinning beachball. This can last for at least a day but on the most recent 2nd time through backup, it had a time out after about a minute. The dialog box that popped up said it could not create a backup folder. In the recent past it has caused the finder to hang and the only way out was to use the power button on the MacBook.
    17" iMac, Mac OS X (10.4.3)
  • scot Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 20, 2011 8:17 PM (in response to scot)
    Solution- Apparently the LaCie Drive was damaged. It would not mount a different laptop at all. I have gone back to the wireless Time Capsule and all is well with the world. I think this fell victim to being unplugged without being ejected from the computer first. I caught the wife doing this a couple of times. Points out though the value of Apples no worries wireless backup system being combined with a laptop.
    17" iMac, Mac OS X (10.4.3)
  • jtupnsmoke Calculating status...
    Currently Being Moderated
    Feb 11, 2011 11:46 AM (in response to Cerebro)
    I am getting the same thing, but mine seem to be a little different. About 60-70% of my backups work fine, but a couple of times a day I will go to my computer and see time machine "Calculating Changes" with no end. @Cerebro-I have my "no sleep" option unchecked and also have the update to my Seagate external so it never goes to sleep installed, so I don't think it is the sleeping causing the problem. This is very annoying. What I have been doing is killing time machine with "sudo killall backupd" , then unplugging the harddrive, then running "sudo service com.apple.metadata.mds stop" and finally "sudo service com.apple.metadata.mds start". This is the only solution I have found that doesn't involve doing a hard restart.
    iMac, Mac OS X (10.6.6), 8 gigs of ram
  • michael groff Calculating status...
    Currently Being Moderated
    Jan 24, 2012 2:17 PM (in response to Cerebro)

    I too am getting a never ending write to my USB external drive for TM. And this is only a recent matter as of this January. I have been using this drive - also a 1 TB Fantom Drive - for more than a year for manual TM backups. I am using the drive for additional storage and the TM backup files. I preferred to do my own back up timing manually, so every couple days I tell it to back up when I go to lunch. Been working GREAT! Loved it... till now. Now I can't get a completed back up. TM continues to run. I am not a tech user so can't tell you anything about the logs you have posted. Are you reporting this from the Console Messages?

     

    My set up is 27" iMac late 2009, Core 2 Duo, USB direct connected Fantom 1TB ext drive. OSX 10.6.8 3.06 GHz, with 4 G RAM. Also running a second monitor. Nothing all that special. Will try the "Put to Sleep" setting off, mine was on...  i have tried the PRAM, Disk Utility to reset permissions, have run cocktail to do all scripts, clear caches and scripts... made sure I had all firmware and OS updated... all software updated...  Still same problems... However, been looking at other posts dating back to 2009 and found this interesting link perhaps Spotlight is our newest - revisited problem... http://www.thexlab.com/faqs/stopspotlightindex.html#Anchor-Preventing-49575.

     

    I just forced the indexing to stop on my ext. volume and the the silence is great! I am still reading... but is it possible in the Sys Pref to have spotlight not index a folder such as the backup file/folder that TM creates, yet let it index my additional storage files? Or do I have to choose a complete volume? Each time I try to tell spotlight to not index Backups.backupdb I get a "Privacy List Error - Item cannot be added or removed because of an unknown error."

     

    Lastly, I don't see a solution according to the link... it seems that no matter what, if the appropriate index file is backed up to the ext volume, no matter what indexing will start.

     

    Any comments or thoughts? Does this help anyone here?

  • MudShark Calculating status...

    Toss me into this group.  But I'll add its going to a up to date Time Capsule.

     

    This problem leaves me with the feeling that TC/TM is unreliable and should NOT be used for true back ups.

    I used to like it, but I guess glitz trumps function once again.

  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Feb 5, 2012 5:21 PM (in response to Cerebro)

    Cerebro wrote:

     

    First of all, why am I not allowed to edit my own postings? (the forum isn't letting me for some reason).

    There's a 15-minute time limit.

     

    Anywho, I would still like to solicit people's opinion on the "no sleep" option. From what I gather, the cyclic spin-down/spin-up puts greater wear and tear on the drive. Since the drive needs to be written to every hour (per TM's automated scheduling), that's a lot of constant cycling. My feeling is that deselecting this option is better all around.

    There's little hard evidence.  Modern drives are built to run 24/7 if necessary.  Most have a built-in sleep or spin-down mode after 10, 15, or 20 minutes of inactivity, so they're designed to do that, too.

  • Pondini Level 8 Level 8 (38,710 points)

    michael groff wrote:

    . . .

    I just forced the indexing to stop on my ext. volume and the the silence is great! I am still reading... but is it possible in the Sys Pref to have spotlight not index a folder such as the backup file/folder that TM creates, yet let it index my additional storage files?

    You have other data in the same partition as your backups?  That's not a good idea. See Time Machine - Frequently Asked Question #3.

     

    You can exclude the drive from Spotlight indexing (System Prefs > Spotlight > Privacy), but you cannot keep Time Machine from indexing them.  See the Note: in section 2 here: http://docs.info.apple.com/article.html?path=Mac/10.6/en/8991.html

     

     

    EDIT:  See #D1 in Time Machine - Troubleshooting for more.

     

    Message was edited by: Pondini

  • MudShark Level 1 Level 1 (50 points)
    Currently Being Moderated
    Apr 8, 2012 6:17 AM (in response to MudShark)

    As an update.  I had trashed the TimeCapsule and started fresh.  Was great until the TC got full.  Now stuck on calc changes again.  I'm DONE with TM & TC for back ups.  It just pure junk and too unreliable.  back ups are the one thing that needs to be perfect (or as close to as possible).  CCC and Super Duper for me.  (or heck, just dd will work)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.