Skip navigation

Xcode 4 code sens (code completion) disappeared

12100 Views 23 Replies Latest reply: Nov 21, 2013 12:51 PM by teofiloisrael RSS
1 2 Previous Next
AcidStuff Calculating status...
Currently Being Moderated
Feb 7, 2011 4:39 AM
I want to share with you a problem I encountered using Xcode 4 GM seed build 4A278. It was shocking to get no convenient code sense (code completion) in one of my classes inherited from NSObject. My .h file had no problem whatsoever, but the .m file didn't react to any of my gestures including the control command key combination.

All other files in the project the code sensing feature worked fine. This was my first couple of hours with Xcode 4 and the project was converted from Xcode 3. In the end, the solution was to copy the code into memory, delete the .m file, add a new .m file and finally pasting the code in to the .m file. Voila, there was the code sensing. You never know, you may experience a similar problem in the future.

I think I really going to like the new Xcode 4, good job Xcode team!
MacBook Pro 17, Mac OS X (10.6.6)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.