Skip navigation

error 29 iphone locked in recovery mode

302550 Views 195 Replies Latest reply: Jan 21, 2012 9:04 AM by ArdianWilasti RSS
  • Jimwinny Calculating status...
    Currently Being Moderated
    Dec 1, 2010 10:31 AM (in response to aussi)
    Hello,

    After 2 weeks of reading all over the web, I confirm that changing my battery solved my error 29. Even when managing to get out of recovery mode, my 3GS would restart every 3 minutes.
    When IOS 4 installed, it failed on installing the battery software -> error 29.
    I order a new battery APN 616-0435 original and OS4 installed normally after that and no more reboot.
  • rmoody Calculating status...
    Currently Being Moderated
    Dec 7, 2010 6:34 PM (in response to aussi)
    yep i can confirm that a battery change fixed my error 29 problem along, also before doing that i tried using limerain on 4.0.1 while in recovery mode and it kicked it right out, after limerain, i tried restoring again and got error 29 so i replaced the new aftermarket battery with the older original battery and tried restoring again and it worked just fine. I would assume that if the battery don't do the trick try changing the dock assembly at the bottom, i have seen the charge port go bad and cause various errors too.
  • ATRAC3 Calculating status...
    Currently Being Moderated
    Dec 9, 2010 8:13 PM (in response to aussi)
    The problem with "Error 29" is 99,9% battery issue, i had over 10 cases of this error, all solved with original replacement battery.
    Custom Built, Windows 7, 3.2 DualCore, 2Gb RAM
  • vanity64 Calculating status...
    Currently Being Moderated
    Feb 12, 2011 10:42 PM (in response to mrangelo)
    The only way I could get out of the recovery loop was to use my other laptop to restore my 3GS.
    iOS 4
  • marcuslbt Calculating status...
    Currently Being Moderated
    Feb 15, 2011 10:44 PM (in response to ATRAC3)
    how do i know if i should get APN:616-0435 or APN:616-0431 battery for my iphone 3gs? is there anyway to know without opening the iphone?
    Windows XP
  • DiGitalChaos Calculating status...
    Currently Being Moderated
    Feb 17, 2011 11:10 AM (in response to iFixrepairs.net)
    worked here too, thanks.

    Got my 3GS out of Error29-Loop after replacing (swaping) not-original APN 616-0431 with APN 616-0433 from another, never opened 3GS.

    Now, this (other) 3GS have the same trouble while updating iOS from 4.0.1 to 4.2.1.

    Already ordered a new 100% Apple 0435, will report later.
    HP, Windows XP Pro
  • TaraRSP Calculating status...
    Currently Being Moderated
    Feb 18, 2011 1:53 PM (in response to aussi)
    I had the same issue, same error code.

    I kept clicking Restore, and on the 4th time it actually restored my phone.
    It's working on re-syncing it with my saved iPhone, and it's working so far.

    I hope it turns out functional.
    Good luck to everyone.
    3GS iPhone
  • Shaddow41 Calculating status...
    Currently Being Moderated
    Feb 18, 2011 1:57 PM (in response to TaraRSP)
    Do not use the 3rd party software iRecovery. It might void your warrenty.

    For the Mac Users try this
    In the Finder, locate iTunes in the Applications folder and drag it to the Trash.
    Go to
    /System/Library/Extensions
    and locate the file called
    AppleMobileDevice.kext and drag it to the Trash.

    Go to
    /Library/Receipts/
    Locate the filecalled
    AppleMobileDeviceSupport.pkg and drag it to the Trash.

    Go to
    /System/Library/LaunchDaemons/
    Locate the file called
    com.apple.usbmuxd.plist and drag it to the trash

    Go to
    /System/Library/PrivateFrameworks
    and locate the file called
    MobileDevice.framework and drag it to the Trash.
    Empty Trash and restart the computer. Empty the trash again if needed

    Download and install the current version of iTunes.

    Now try your restore again.

    You can also try mrangelos suggetions “Ok this is what I did. I used a windows xp machine (not vista, not windows 7) and these were the steps that worked for me:

    1. download libusb win32 and install this.
    2. download and unzip iRecover into a simple folder for example: c:\ir
    3. open the command prompt: Start menu -> Run -> type cmd -> press enter -> you see a black box with a blinkin cursor
    4. goto the folder by doing this: type c: -> press enter -> cd\ir -> you’re in the folder
    5. now you’re going to do the instructions
    6. start the program: type iRecovery -s -> press enter
    7. the program starts (if you get a message that it sees usb but no device, turn on your iphone, make sure it’s connected with the usb cable and go to step 6.
    8. program shows some information (never mind that) and it gives the oppurtunity to type command that it will send to the iphone, so type this and end every line with an enter:

    setenv auto-boot true
    saveenv
    /exit”
    iOS 4
  • iDcirco Calculating status...
    Currently Being Moderated
    Feb 22, 2011 7:27 PM (in response to aussi)
    For the record, we need to take issue with this. This should be illegal.

    I am currently in the PROCESS of replacing my battery. I brought it to a repair shop because I was afraid to open my 3GS myself and it's already out of warranty. I watched him carefully remove each piece and replace the battery, just like in those clever YouTube videos. I was content. I left and went home with the phone and new battery.

    I attempted to restore the device because it kept resetting as I tried to charge it while turned on. I thought a hard-press factory reset would be fine.

    ERROR 29 - Restore Looping now.

    I took it back to the shop and the tech had me come back the next day. After some advice from another tech, he moved my phone into the housing of another device, restored the device without ERROR 29, returned it into MY housing and had me pick it up immediately.

    I took my 3GS home and during backup restore it started resetting again. I was able to run the SOFTWARE restore by erasing all settings and giving a brief plug into iTunes, but it continued to reset at random, with considerable frequency when plugged in.

    This entire problem started with ERROR 29 and I remain confident the solutions provided in THIS forum topic and also here > http://www.ifixit.com/Answers/View/28809/Tryto+restore+get+a+error29
    will be his final decision.

    Currently the tech has my phone to swap out the housing again and double check for the resetting issue in that housing. He may even let me keep that housing if it my housing continues to reset. I have doubts it will continue to operate correctly unless the housing he uses has a proper battery OR the housing directly correlates with how the battery is read by the board. (see iFIXIT post for backup details) Can anyone say that using a different housing (an older one) has resolved this "restore with wrong battery model" issue?

    It may have merely been my techs luck that a different housing didn't give him ERROR 29 during restore.

    I also wonder if the guy at iFIXIIT is even partly correct. I'm led to believe he may be, because my current 3GS is from an in-warrant-exchange back a year ago.

    As noted here and in other forums, ERROR 29 is CURRENTLY diagnosed as an issue with different model numbers of the battery. I find it interesting also that this issue arose for people after upgrading to iOS4.

    To me this reeks of several things: 1) Apple ensuring themselves business by putting people like my tech out of business if they don't obtain OEM battery model numbers. 2) Forcing customers who restore an "old issued" phone to run into potential problems once 4.0 was released. This all leads to more money for Apple in my opinion. It's clever and all, but there should be a law against software modification of a device to disallow after-market hardware. Especially in the context where battery replacement can already be monopolized with warranty tags.

    Obviously if you insert a new battery into an Apple phone you are voiding any warranty, and for someone who no longer HAS a warranty, battery replacement without Apples mighty help has a MUCH cheaper turn around.

    Total crap - and if my tech returns the device to me with a different housing just to solve the issue or I have to buy a potentially "correct" battery for my device, I'm writing more than an informational forum post about this.

    First - I'm willing to bet most of the people claiming to have gotten their device brand new or have never made any hardware changes are liars.

    Through sheer trial and error and user reports, ERROR 29 starts as a battery replacement issue.

    Second - Diagnosing the problem has had people report using different model number batteries, lower iOS versions and (starting now) older housings. There is even a character on the iFIXIT forum who claims to swap out the logic chip on the battery. WHATEVER THAT MEANS. I'm not interested in opening up my device to find out... God help Apple if I have to.

    Third - This should't be a problem in the first place. I mean, a mobile device battery should be synonymous with the term "battery door". Do you smell what I'm cooking here? Aside from that, software changes to stunt the after-market market around your product is as despicable as Google claiming not to be evil while stuffing wallets in Washington.

    Thanks for reading this. I hope more information can be obtained and anyone with a problem finds the solution to getting your awesome iPhone back and running. I hope in the next few days my issues will be resolved as well. I also hope not to be completely deterred from ever buying Apple again.

    Cross your fingers y'all.
    AthlonXP, Windows XP Pro
  • kukulhey Calculating status...
    Currently Being Moderated
    Mar 14, 2011 6:42 AM (in response to aussi)
    hi,
    i could not restore my iphone 3Gs..its showing error 29..i tried by changing battery..but could not fix the problem.. can anyone help me???
    iphone 3Gs, iOS 4
  • gizmobug Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2011 8:02 AM (in response to kukulhey)
    I too had this issue with the Error 29, my iPhone 3GS being stuck in Recovery Mode. BUT, I have fixed the issue by replacing the battery on my iPhone 3GS. Note, I had previously replaced my battery on the same phone and it had been fine until I tried the iOS 4.3 update.

    I documented what I tried to do to resolve in this blog post: http://bit.ly/dP9ZmX

    And this is the blog post where I talk about how replacing the replacement battery fixed my issue: http://bit.ly/g7W4He

    I'm back up and running! Please let me know if you have any questions!
    iPhone 4, iPhone 3GS, iPod Touch, iPhone (original), iOS 4
  • casper1414 Calculating status...
    Currently Being Moderated
    Jul 14, 2011 4:39 PM (in response to gizmobug)

    Gizmobug, I did the same thing, replaced the battery last week, and then did the update on itunes a couple of days ago, and the phone has been stuck in recovery mode, and I tried to do a restore and it failed (error 29).

    replacing the battery was a pain in the butt, I dont really want to do it again.I think this caused the problem in the first place, because I have transferred files over to the iphone before the battery replacement, but it is not isolated to this, as many people on here have the same issue stuck in recovery on brand new phones. I wish I had never updated the software or updated itunes, ironically doing everything that apple instructs got us into this mess!

     

    I downloaded irecovery, right click, run in compatibility mode xp.

    This application failed to start because libusb0.dll was not found. I will try to reinstall it, and search this here thread for instructions again.

  • casper1414 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2011 7:24 PM (in response to casper1414)

    Well....****! Took me 2 hours to get back online. After extracting and installing the  libusb0.dll file on my toshiba pc running vista, it froze. and I went into task manager and it would not terminate. I rebooted, and all my usb's failed and network, and fingerprint login.

    I restarted in safe mode and thank God, at midnight there was a restore point, from automatic windows update.

    Windows help popped up because I was in safe mode, and I scrolled down to restore point option.

    What was just an iphone issue became a pc issue, so now I am at step 1 again...I am a bit scared to try irestore again, and my iphone is still in recovery mode.

    PEOPLE PLEASE MAKE A RESTORE POINT BEFORE PROCEEDING!!!!!

  • casper1414 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2011 7:46 PM (in response to casper1414)

    the battery i removed is a 616-0433, so I will be ordering a replacement battery from apple.

    No more crap off ebay. I bought a replacement screen for sony ericcson c905 which was 5 months old and now the phone does not work, should have learnt from that.

  • TwistedGecko Calculating status...
    Currently Being Moderated
    Jan 14, 2012 5:28 PM (in response to ron ingman)

    I had the same Error 29 issue after an upgrade from OS3 to OS5 on an iPhone 3GS. I tried iRecovery with libusb but that failed. I had replaced the battery about 2 weeks earlier. After reading that the battery could be the issue I begrudgingly changed the battery back to the original and voila, the phone is working again! However, I changed the original battery because it doesn't hold a charge for very long. Now I have a working iPhone with poor battery performance.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.