1 2 3 4 Previous Next 55 Replies Latest reply: Mar 20, 2011 9:53 PM by Paul_A
Fonzo Level 1 Level 1 (0 points)
Hey. Just started to use Safari 5. When I go to Youtube, the "recommended for you" box doesn't show up when I log onto my Youtube account, but it does when I use another browser e.g. Firefox. Is this a bug, and how do I fix it? Cheers. Oh and one more thing, in the "top sites" window, how do you scroll through your top sites when you format the icons to large? It only displays six at a time but I have around ten sites but there isn't an arrow or whatever to move through the sites!

13.3 " MacBook Pro 2010 2.4GHz Intel Core 2 Duo 4GB DDR3 RAM, Mac OS X (10.6.4)
  • 1. Re: Youtube not working properly on Safari 5?
    Carolyn Samit Level 10 Level 10 (89,765 points)
    HI,

    From your Safari Menu Bar click Safari / Reset Safari. Select the top 5 boxes. Relaunch Safari.







    Carolyn
  • 2. Re: Youtube not working properly on Safari 5?
    C.Jason Level 1 Level 1 (0 points)
    Hi Carolyn,

    I have a different problem with youtube. The player simply doesn't load on my Safari anymore. I tried updating the flash player from 10.1 to 10.2, reset the safari, repaired disk permissions 2 times but i still can't get it to work. I can still watch the same videos embedded on sites like tumblr and facebook but when i go to youtube.com, nothing happens, just a black box.

    Any advice?

    Jason
  • 3. Re: Youtube not working properly on Safari 5?
    El_Nastro Level 1 Level 1 (0 points)
    Same problem.

    Running:

    OS X 10.6.6 on an Intel Macbook 2.4 Core 2 Duo.
    Safari 5.0.3
    Adobe Flash 10,2,152,26 (the latest version).


    The page loads fine, but video won't start. I get a black box where the video should be.

    Only youtube doesn't work. Other Flash video sites work fine..Hulu, Cnet, Comedy Central..etc.

    Youtube was working fine yesterday, but today the videos simply won't load.

    I've tried:

    -a different computer (a mac, running Safari 5.0.3 & Flash 10,1,102,64) & youtube works, so it's not youtube.

    -a different browser on this computer. Youtube works in Firefox.

    -"Reset Safari" (with all the boxes checked)

    -"Empty Cache"

    -re-installing Adobe Flash (after running Adobe's Flash uninstaller)

    -going to Safari->Preferences->Security & making sure "Enable plug-ins", "Enable Java", & "Enable Javascript" were all checked.

    -uninstalling & downloading & re-installing Safari

    -going to the Finder->Applications, right-clicking on Safari->Get Info, & checking the "Open in 32-bit mode". ("Open using Rosetta" is not checked)

    -restarting Safari

    -restarting the computer

    Nothing has worked.

    Any ideas?
  • 4. Re: Youtube not working properly on Safari 5?
    El_Nastro Level 1 Level 1 (0 points)
    Update:

    Immediately after typing up my post on this subject, I re-downloaded & re-installed Flash (10.2.152.26) yet again & restarted Safari. It was like the 3rd time I've done that tonight.

    I don't know if it's coincidence or what, but now youtube seems to be working fine.
  • 5. Re: Youtube not working properly on Safari 5?
    bimoo Level 1 Level 1 (0 points)
    i have the same problem and i did all u did but still not working
    works in firefox and it works also in Facebook
    but the main page no
  • 6. Re: Youtube not working properly on Safari 5?
    C.Jason Level 1 Level 1 (0 points)
    Speaking of coincidence, how weird is it that this problem popped up right at the time facebook updated their photo viewer?
  • 7. Re: Youtube not working properly on Safari 5?
    bimoo Level 1 Level 1 (0 points)
    i checked safari to open 32bit and now its working
    but what is the diff. between 32 and 64 bit in safari?
  • 8. Re: Youtube not working properly on Safari 5?
    anthreas Level 1 Level 1 (0 points)
    Hey guys, same problem here too

    As I remeber well, last nigth some time there was a software update & if I remember well it was a web update. Maybe that has caused the problem. I've done all the above myself as well e.g. installing reinstalling flash and plenty more, but still no lack.

    It will though play normally when using HTML 5 the youtube extension available for safari that uses HTML 5 instead of flash (Youtube5 2.2.1 name of extension).

    Still trying to figure out why it doesn't play!! Really annoying.
  • 9. Re: Youtube not working properly on Safari 5?
    Huaa Level 1 Level 1 (0 points)
    dude
    The same to u.
    it makes freaking out...
  • 10. Re: Youtube not working properly on Safari 5?
    sateach Level 1 Level 1 (10 points)
    Ditto!
    I too did the software upgrade and no youtube!
    Reset Safari > downloaded latest Flash > uninstalled Click to Flash > restarted computer. Did all these things and still no youtube on Safari. Works fine on Firefox! Videos on other sites run fine on Safari.

    Any other suggestions?
  • 11. Re: Youtube not working properly on Safari 5?
    timibr Level 1 Level 1 (0 points)
    i'm not sure if some of you already found out that if you click on the user that uploaded the video, as usual you're getting directed to his channel.. ironically.... once there, everything seems working as it should.. but that's not a real solution.. just sayin'
  • 12. Re: Youtube not working properly on Safari 5?
    sateach Level 1 Level 1 (10 points)
    timibr,

    You're correct. It works but it is definitely an inelegant solution. And most of us own Macs because of their inherent elegance.

    There's got to be reason for this and subsequently, a proper solution.

    If it's caused by the latest upgrade, then it must be a rampant problem.
  • 13. Re: Youtube not working properly on Safari 5?
    skywalkermatt Level 1 Level 1 (0 points)
    Same Problem here, the screen is just black. anyone has any idea of how to fix it?
  • 14. Re: Youtube not working properly on Safari 5?
    Maurovas Level 1 Level 1 (0 points)
    Lo mismo me paso al actualizar la versión de iweb el día de ayer 16-2-2011.

    Dejo de funcionar el video de youtube, desde su pagina inicial (solo aparece cuadro en negro)

    La solución fue habilitar Safari en modo 32 bits.

    Lo dejo así, hasta la próxima actualización de apple.

    Suerte.
1 2 3 4 Previous Next