Skip navigation

So Windows 7 can't run on 2007 iMacs?

4935 Views 10 Replies Latest reply: Feb 25, 2011 2:18 PM by Stokestack RSS
Stokestack Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 14, 2011 3:42 AM
Hi all.

I thought I was having problems because I was trying to create a total of three partitions, but that's not it. Starting with one partition and Boot Camp Assistant, Windows 7 (Pro, 32-bit) installation fails because "A required CD/DVD drive device driver is missing". I have the drivers from the SnowLeopard installation DVD on a thumbdrive and could navigate to them in the Windows installer, but none was the mystery driver.

This is on a 2007 iMac, freshly set up with SnowLeopard and all updates. Anybody get this to work?

Thanks.
iMac, Mac OS X (10.6.6), other computers
  • The hatter Level 9 Level 9 (58,560 points)
    Currently Being Moderated
    Feb 14, 2011 6:44 AM (in response to Stokestack)
    I always start with search of my bookmarks and Bing

    http://www.bing.com/search?q=Arequired+CD%2FDVD+drive+device+driver+ismissing

    http://www.bing.com/search?q=MacBoot+Camp+A+required+CD%2FDVD+drive+device+driver+ismissing

    My take, and I thought I'd seen it listed here once, is you have a faulty DVD drive. Or the DVD was burned with Disk Utility, and not at 2x (reduced burn speed), and you have electronic version that you burned with Disk Utility, not physical media (retail, OEM, etc)

    *ONLY use "Use 2x Reduced Burn Speed" which is a well known problem if using Apple Disk Utility to burn ISO to DVD.*

    Re: setting up windows 7 in boot camp
    Posted: Jul 6, 2009 5:11 PM
    Ok, thanks. I downloaded the 32bit and it solved that problem. Now I have run into another. I click the "Install Now" button and it comes up with a screen that says a driver needs to be installed. Here is exactly what it says.

    *A required CD/DVD drive device driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now.*

    The interesting thing about this is that I have made two copies of the 32bit and the first one did not do this. It went all the way to the actually installation screen, but I had to throw that one away because of scratches.
    .....
    I burned a new copy and the problem is not reoccurring. I do have one other question though. How long does it take to Expand Windows Files? It seems to take forever.

    http://discussions.apple.com/thread.jspa?threadID=1842538&start=60

    http://macosx.com/forums/boot-camp-os-virtualization-mac/307942-windows-7-cd-dvd -driver.html

    http://windowsfixup.com/2009/08/windows-7-wont-install-a-required-cddvd-drive-de vice-driver-is-missing/
    -----

    *General Help for other problems, tips:*

    Even if your mac is not on the list of those that support 64-bit Windows it can still be installed.
    http://support.apple.com/kb/HT1846

    System requirements for Microsoft Windows
    http://support.apple.com/kb/HT1899

    BC 3.0 FAQ, What's New
    http://support.apple.com/kb/HT3777
    http://www.apple.com/support/bootcamp/

    Boot Camp: Windows 7 installation frequently asked questions
    http://support.apple.com/kb/HT3986

    Boot Camp Software Update 3.1 for 64-bit requires 3.0
    http://support.apple.com/kb/DL979

    http://www.macintouch.com/readerreports/bootcamp/index.html

    Installing Windows 7 on IMAC 27 256G SSD 2 TB HD Core I7 8G Ram
    http://discussions.apple.com/thread.jspa?messageID=12171578

    Blue Screen issue with iMac
    http://geekswithblogs.net/ajames/archive/2009/08/12/take-an-imac-and-windows-7-r tm-ndash-and-have.aspx

    Ubuntu and Windows 7
    http://lifehacker.com/#!5403100/dual+boot-windows-7-and-ubuntu-in-perfect-harmon y

    Windows 7 Walk-Thru
    http://www.simplehelp.net/2009/01/15/using-boot-camp-to-install-windows-7-on-you r-mac-the-complete-walkthrough/

    Vista x64
    http://blog.andersonshatch.com/2008/04/13/macbook-pro-and-vista-64-bit/

    iMac 27" and Windos 7 64bit: Can't scale resolutions to full screen

    http://www.pcpro.co.uk/blogs/2009/10/26/how-to-install-windows-7-onto-the-new-27 in-imac/comment-page-1/

    http://discussions.apple.com/messageview.jspa?messageID=12085612&stqc=true

    Triple Boot Wiki:
    http://wiki.onmac.net/index.php/TripleBoot_viaBootCamp
    Mac Pro 8800GTX Corsair SSDs, Mac OS X (10.6.5), 3.2GHz 10K VelociRaptors Win7 GTX 460
  • The hatter Level 9 Level 9 (58,560 points)
    Currently Being Moderated
    Feb 21, 2011 2:56 AM (in response to Stokestack)
    You aren't changing the fact that Apple Disk Utility can't burn from ISO to DVD, only that you have more problems than just that.
    Mac Pro 8800GTX Corsair SSDs, Mac OS X (10.6.5), 3.2GHz 10K VelociRaptors Win7 GTX 460
  • NA Smith Level 2 Level 2 (345 points)
    Currently Being Moderated
    Feb 21, 2011 10:28 PM (in response to Stokestack)
    I'm having a slow night and decided to Google this interesting issue. It is not a BC issue specifically so much as it is a huge Windows (& Nvidea) issue. While most online discussions involve BIOS changes:

    +In the end, I simply turn off IDE emulation for SATA drives on my motherboard and the problem was solved.I guess it depends on each manufacturer and BIOS, but I guess this can be the problem for some people. In my Nvidia730i based Gigabyte GA-E7-AUM DS2H I can choose to use Nvidia's SATA chip in IDE, RAID, or AHCI. I was getting the "driver problem" when using "IDE" mode, but it disapeared when I put it back in AHCI. I guess that using the SATA chipset on IDE was interferring with the IDE channel for the DVD drive (my unit is IDE and rather old).+

    One person was aware of the BIOS techniques but fashioned a different way -

    +...try slipstreaming the SATA/RAID driver into the installation media and burning a new disk with it included. nLite is my tool of choice for handling this. You need to download and install nLite (http://www.nliteos.com/) on a working computer with a CD/DVD burner. Then, gather your original installation media, the SATA/RAID driver for your particular system, and a blank CD/DVD. Step thru the wizard in nLite and when finished, you should have a fresh installation media WITH your SATA/RAID driver already installed. Just fire up the installation and Windows will do the rest. HTH+

    I am not saying this works. It takes skills (that I don't have) and a LOT of work with no guaranteed results, but it doesn't involve a BIOS. Just sayin'.

    http://www.vistax64.com/vista-installation-setup/126054-during-install-required- cd-dvd-drive-device-driver-missing-2.html

    PART 2 of this post:

    Someone has solved their issue with this and THEY CLAIM the phrase offered is misleading because it is poorly written. See corrected phrase below:

    +...it occured to me that it probably meant the IDE controller driver was needed, not some "drive device driver". Sure enough, I put the XP 64-bit driver for my ITE IT8211 ATA/ATAPI Controller on the root of a floppy, install finds it, I choose it and click next; all was well. *IMHO the message should have been something more like:*+

    +Windows Install could not load the CD/DVD drive that contains the installation media. Please provide the necessary drive or controller device drivers provided by your manufacturer.+

    +Next, it suddenly prompted me with another unhelpful message:+

    +No new devices could be found. Make sure the driver files are correct and located on the driver installation media.+

    +So, did my driver fail? Did the driver for my controller not take? *No, actually it had loaded the ATAPI controller correctly and was now interested in the SATA drivers for the HDD. It only took me a minute to figure that out, but a more novice user would find this confusing.* It should say something like:+

    +Windows Install could not locate a storage device to install Windows Vista on. Please provide the necessary drive or controller device drivers provided by your manufacturer.+

    +It is a small thing... but helpful prompts go a long way!+

    Devon

    http://social.technet.microsoft.com/Forums/en/itprovistasetup/thread/4d906f85-76 50-4eff-8bd2-13ec2b0bd2ae

    Message was edited by: NA Smith
    Macbook Pro 13", Mac OS X (10.6.6), BootCamp Vista Home Premium
  • NA Smith Level 2 Level 2 (345 points)
    Currently Being Moderated
    Feb 24, 2011 10:40 PM (in response to Stokestack)
    Hi again - I'm not trying to by annoying to what must be a miserable situation...

    BUT - coming at this from an entirely different corner is this:

    +You have a bad burn of the ISO file. The same thing has happened to me countless times, and it's only ever with Microsoft provided ISO files. Thankfully, there is a workaround:+

    +Use the Windows 7 USB/DVD Download Tool to burn any Microsoft ISO files:+

    +http://store.microsoft.com/Help/ISO-Tool+

    +On the same computers I've had bad burns with I was then successfully able to burn the same ISO using the USB/DVD Download Tool.+

    http://discussions.apple.com/message.jspa?messageID=11458792

    A few people on the thread were claiming success.
    Macbook Pro 13", Mac OS X (10.6.6), BootCamp Vista Home Premium

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.