Skip navigation

Ethernet DHCP not getting IP address, but DHCP with manual address works

26665 Views 17 Replies Latest reply: Dec 5, 2012 5:04 PM by paulfromburwood RSS
1 2 Previous Next
spaceman79 Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 16, 2010 8:27 PM
So I've spent hours looking through forums and trying to find an answer for this. I'll try and be as specific as possible.

My wife's new (2months) 13" White MacBook has recently lost the ability to get an IP via DHCP from our university network. It gives the self assigned IP

My own MacBook Pro 13" can connect fine and all the network settings are identical on both machines. As are Firewall settings.

The weirdest thing and probably most interesting for ruling out all kinds of things is: if I use the DHCP IP address assigned to my MacBook Pro in the original MacBook(DHCP with Manual setting, after disconnecting the former of course) it connects instantly so there is no hardware issue here or other internet issues. (both machines can connect wirelessly to the internet with no issues.)

I have repaired permissions and zapped the PRAM to no effect.
I have deleted and recreated the *.alf.plist in /Library/Preferences, to no effect.

Basically what could prevent DHCP assigning an IP to one computer but having no problem with all other computers. I cannot get access to the router as this is a university network, but since other computers work fine it isn't a router issue.

I throw myself at the mercy of you mac gods.

Message was edited by: spaceman79

Message was edited by: spaceman79
MacBook 13" 2010, Mac OS X (10.4.6)
  • dbsneddon Level 4 Level 4 (1,525 points)
    I cannot get access to the router as this is a university network,

    You should really talk to the University network people...
    but since other computers work fine it isn't a router issue.

    Not true. I would hazard that it is most likely a router issue since
    it is the router that is handing out IP addresses and for some reason
    doesn't like one of your machines.

    You say the machine "recently lost the ability..."
    How long ago?
    Was anything done just before it stopped working? Upgrade? Installation?

    You also say that both can connect via wireless. Is this at the uni or
    some other location?

    iMac 27", Mac OS X (10.6.4), , MacBook (10.6.4), iBook G3 (10.4.11)
  • caojianhu Level 1 Level 1 (0 points)
    I have met similar problems before. And I tried to enlarge My DHCP Address Range, Like before it was, try to enlarge this to a bigger range,
    My Understanding was when the DHCP ip pool was all assigned out to clients and not up to the least time. The DHCP Server can not assign ip address to client any more.

    Hope this helps.

    Macbook Pro 4GRAM 500G Hard Drive, Mac OS X (10.6.4)
  • Jai23155 Level 1 Level 1 (0 points)
    hi, i have the same problem. I am an IT admin, not too familiar with mac. We have two macs which don't which get self assigned IP address while all the windows computers are getting DHCP addresses from RVS400 router. is there any solution for this ?
  • peter.holm Level 1 Level 1 (0 points)
    Hi all

    I have the same issue, although mine is on a mac mini. It's very hard to search for this problem on the internet because it is so specific. To restate the problem:

    The wireless ethernet connects to the same router and acquires it's IP address, DNS, and router information through DHCP without a problem.

    The wired ethernet connection is unable to communicate with the DHCP server. The router detects it, and sees it as having it's self-assigned ip address ( The subnet mask is wrong ( vs. as well. Both are greyed out. I've tried all of the obvious steps (restarting networking, rebooting everything, disabling airport, etc.) to get it to work and like the guy above, I can get it to connect with a manually assigned IP.

    I have had this issue with multiple routers. Currently I'm using a gigabit-e router - netgear WNDR3700. Other machines connect to the router just fine through wired ethernet (xbox360 and linkstation mini).

    I'll also post this in the mac mini section, but I doubt it is hardware related.
    Mac Mini 4.1, Mac OS X (10.6.5)
  • bipo Level 1 Level 1 (0 points)
    I encountered this problem as well. Has it been solved yet?
    I operate a LAN with powerbooks (4) imac (1) macmini (2) and several switches. The DHCP does not provide an IP address to one computer (macmini) others work fine!
    mac mini, Mac OS X (10.5.4)
  • torndownunit Level 1 Level 1 (0 points)
    I just started having the exact same problem. The PC works fine, my Macbook won't.
    MacBook 2.4 ghz, Mac OS X (10.5.5), i like cheese
  • bipo Level 1 Level 1 (0 points)
    DHCP issues IP = 192.168.2.xx? I just found that that may be causing the problem
    powerbook, Mac OS X (10.5.4)
  • aksamit Level 1 Level 1 (0 points)



    I have noticed the exact same issue.


    At my office both wired and wireless network works flawlessy, I just plug in the ethernet cable and I instantly get an IP address from our DHCP network.


    At home however I have noticed the same issue many other have reported. I use D-Link DIR-635 as a router with DHCP enabled for both the wired and the wireless network. If I connect to the wireless network, I will receive an IP and everything works. When using the wired network, the MacBook seems to refuse to use IP address assigned by the DHCP server, it uses a self-assigned IP instead (which of course does not work).


    Is there any sollution to this? I highly doubt it is a router issue, in this thread I have seen various routers from different manufacturers, yet the same problem is reported. I have also never experienced this problem on any of my other computers, running different versions of Windows/Ubuntu.

  • gconcepcion Level 1 Level 1 (0 points)

    Add another one to the list.

    I have a MacBookPro3,1 that connects to WIFI no problem. It used to connect to ethernet when I originally bought it, however I've been using WIFI exclusively for the past 2 years.


    Recently I had a need to connect via ethernet and it wouldn't work at home (apple airport router). I next tried connecting via ethernet at a friends house using a linksys WRT54G, no dice either. I have the computer in the lab today (University Network) and I get the same error. 3 different locations, 3 different routers, all same problem. It used to connect to home and university networks ethernet right away.


    IP address assigned is - subnet -

    no other info. It's showing up as connecting to the network, but unable to communicate with DHCP. It does work if I enter all of the information in manually.


    At first I thought I had messed something up in networking preferences as I tend to play around with things alot. However I did a complete system format, and fresh install of OSX Lion and I still have the same problem, without any of my meddling around to confuse things.


    What gives?

  • ju4nj3 Level 1 Level 1 (0 points)

    Same issue, add me to this thread.


    DHCP on wifi works, on ethernet not, same router, dhcp server, etc.

  • ju4nj3 Level 1 Level 1 (0 points)

    In my case I solved it.


    I discovered that I had two DHCP servers running on the local network, (one on the wifi DSL router and another on the server machine),  I disabled on the router, rebooted everything to refresh and force it to dissapear, and now it works perfect.



  • throttle1 Level 1 Level 1 (0 points)

    Add me to the list. I'm a sysadmin at my work. I can get my MacBook air to connect via Wi-Fi just fine. Try using ethernet and I get the notorious self assigned IP.

  • Johann Beda Level 1 Level 1 (0 points)

    This thread suggests removing the network services and plists, then rebooting and readding them:


1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.