Skip navigation

Robotic Static Sounds USB Headset

65211 Views 160 Replies Latest reply: Apr 9, 2014 11:14 AM by morph21 RSS
  • Wingman2112 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 21, 2010 9:19 AM (in response to CristianTM)
    Please let us know how your Apple Care discussion goes. Apple needs to fix this ASAP - been a known issue for far too long and too many of their products rely on USB for comms since their mic input is either non-existent or not amplified.

    FYI - I installed one of these thinking the OS would provide better priority to something with a know driver as opposed to my Plantronic 510 headset which comes up as an Unknown USB Device. Used an old 3.5mm headset and this combo put off the static for about 30-40 mins at a time. To fix I simply unplugged it and plugged it back in. Both the Mac and Vent would auto-find it and I was good to go after 15s or so. Note to Apple - this is NOT a fix and simply unacceptable for something that operates flawlessly on PCs. I expect more from you folks.

    http://www.amazon.com/Syba-SD-CM-UAUD-Adapter-C-Media-Chipset/dp/B001MSS6CS/ref= sr11?ie=UTF8&qid=1290359943&sr=8-1
    MacBook Pro, Mac OS X (10.6.5)
  • variuse Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 29, 2010 5:43 AM (in response to Wingman2112)
    I have submitted a bug using Apple's official bugtracking website (http://bugreport.apple.com/) and wrote some detailed feedback at http://www.apple.com/feedback/macosx.html

    Hope that helps...
    iMac 27" Core i7, Mac OS X (10.6.5)
  • variuse Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2010 11:47 PM (in response to variuse)
    Hello again,

    I've got a very detailed response from Apple Developer Team:

    Engineering has determined that this issue originates with a 3rd party.

    Why it is not a common issue before Mac OS X 10.5.7
    On Mac OS X 10.5.6 & prior, the USB audio driver publishes 2 audio engines, one for input stream and another for output stream. Applications could change sample rate on one audio stream without affecting the other stream. On 10.5.7 & onwards, a change in the USB audio driver publishes only 1 audio engine for both input & output streams. Changing sample rate on one stream will affect another stream (technically, the sample rate resides on the audio engine, so changing the sample rate naturally affects both streams). So in this case, changing the sample rate causes the input stream to run at a different rate that originally when Ventrilo launched. Ventrilo doesn't handle the sample rate change properly, resulting in the audio corruption (robotic/garbled, etc).

    (a) This problem actually could occur on Mac OS X 10.5.6, depending on the USB audio device used. If the device can only support one sample rate, then this problem will also occur after the USB audio driver switches the sample rate on both streams when it detected one stream is falling behind.
    (b) This problem is not specific to USB audio driver. Using Ventrilo for example with Firewire audio device also exhibits similar issue. The Firewire audio driver also puts input & output audio stream on the same audio engine.

    In conclusion, this is a 3rd party application developer issue. Ventrilo (& other programs such as Mumble) need to listen to and handle sample rate change properly.

    *Please feel free to contact the 3rd party vendor (Ventrilo, Teamspeak or Skype as appropriate for your case) regarding this issue to help alert them of its importance.*

    So that would mean, that the problem does not occur in Apple applications like iChat, as I presume they know how to handle a sample rate change correctly. So the only way of getting rid of this issue is to contact developers of Skype, Teamspeak, Ventrillo, etc. ... despite the fact it seems a little odd that all of those did the same mistake

    So in conclusion I will try to communicate this issue to Skype, Teamspeak and Ventrillo developers.
    iMac 27" Core i7, Mac OS X (10.6.5)
  • Wingman2112 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 17, 2011 6:34 PM (in response to variuse)
    Variuse: I see your follow-up in the Vent forums and they say it's not their problem - it's Apple's. Hoo-ray for a catch-22!

    Had anyone found this static problem using iChat?

    So Apple won't address this issue in forums, and then points to "3rd party apps" as the problem. Kind of a bankrupt answer really since something they did affected these other apps that were working prior to their "upgrade." The correct customer-oriented answer is: "We have determined the problem lies with 3rd party apps and have provided in an open forum the fix for this problem (insert link to fix here). Please check with your 3rd party app and have them upgrade their app."

    Until then I guess we suffer being caught between businesses not willing to provide us support?!
    MacBook Pro, Mac OS X (10.6.5)
  • Esquire Sandwich Calculating status...
    Currently Being Moderated
    Jan 30, 2011 5:22 PM (in response to Wingman2112)
    just want to keep this thread alive, I am having the same problem with a dynex usb mic, every 20-30 min. i have to unplug the mic or I need to close and reopen mumble.

    using 10.6.6

    anyone come up with anything?
  • morph21 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 5, 2011 11:54 AM (in response to variuse)
    variuse,

    Sorry to say, but they LIED.

    I have those issues with Quicktime 7, Quicktime Player, iChat, FaceTime.

    Basically I'm using FaceTime to talk to someone and suddenly they tell me my mic is screwed up. I just open Quicktime Player, File -> New Audio Recording, make sure the right mic is selected then pull the volume up a bit and talk.

    There we go... I can hear myself talking like a freak robot. I use that to see when the problem is gone and then I get back to talk into FaceTime.

    Where is the 3rd party here? Everything is Apple.
    iMac 27" i7 4x2.8GHz 8GB, Mac OS X (10.6.4)
  • Ginsei Calculating status...
    Currently Being Moderated
    Feb 8, 2011 6:37 PM (in response to morph21)
    I am having the same issues going on, how can Apple deny this when so many people are complaining about it? I use Ventrilo for gaming and my friends keep mentioning my mic sounds screwed up, and today they came out and said I sounded just like a robot. I don't want to have to be self-conscious while I'm trying to have fun.
    iMac early 2008, Mac OS X (10.6.6)
  • morph21 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 8, 2011 10:26 PM (in response to Ginsei)
    Although Offtopic, but this is also some interesting information you can use.

    You could use non USB headsets/phones, but there is a catch.

    I don't know if all the late (past 2 years) models are like this, but recent iMacs you can NOT use a headset with a microphone on it since there is NO mic port on them anymore. What happens is that if you plug an iPhone headphone, with 4 contacts in the plug, that headphone's microphone will work.

    I don't know if that also affects Macbooks.

    That opens a whole new world of "ways" to workaround this issue. Just look for iPhone headphones or headsets with microphone and that will do the trick.

    Although not elegant, might help you keep going while Apple keeps denying it.
    iMac 27" i7 4x2.8GHz 8GB, Mac OS X (10.6.4)
  • xtremect Calculating status...
    Currently Being Moderated
    Feb 17, 2011 9:26 AM (in response to morph21)
    Have the same problem .... with my new iMac 27 ...

    It's ridiculous that Apple neglect this problem ... they state it is third party applications causing the problems. But how come Apple apps like garageband is giving the same issues ? The hardware works fine, booting windows vista in bootcamp ... so definitely this is an OS/Driver issue. Wake up Apple - at least tell us that you are working on it ....

    Give us hope - the least you can do is to provide a list with working USB sound cards so wee can have headset support on our macs .... beware you are living from us - YOUR CUSTOMERS

    Regards,
    Bjarne
    Imac 27" 3.2 GHz I3, Mac OS X (10.6.6)
  • Thomas Tibbitts Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 25, 2011 9:00 PM (in response to xtremect)
    10.6.6 problem still persists for me. Definitely NOT a third-party-only problem.
  • Spacecadetcraig Calculating status...
    Currently Being Moderated
    Mar 8, 2011 1:58 PM (in response to Thomas Tibbitts)
    Agreed. Same here. Brand new install of Snow Leopard and updated to 10.6.6 cleanly and ROBOT noise every 20-30min even with garageband.. ANY audio app using a USB Mic device.

    Apple needs to fix.
    2010 12 Core MacPro 2.93Ghz. 32 GB RAM - ATi 5870 (PoS) 1x SSD 240GB : 3x WD 2TB, Mac OS X (10.6.6)
  • Einherji Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2011 3:10 PM (in response to Jason Wooten)
    Still no mention of a fix with system update 10.6.7

    http://support.apple.com/kb/HT4472
    MacBook Pro 2.4 GHz 4Gb, Mac OS X (10.6.5), G4 AGP 1.6 GHz 2Gb Mac OS X (10.4.11) • AirPort Extreme
  • Christy Rudziensky Calculating status...
    Currently Being Moderated
    Mar 22, 2011 10:38 AM (in response to Jason Wooten)
    A few pieces of data I have to share:
    I had this robo issue but for a long while was able to revert back to the older usbaudiokext. Unfortunately, I bought a new video card for my MacPro and it required I update to 10.6 which reintroduced the robo-sound. Around this time, I bought the Creative Soundblaster WoW headset (the wired USB version) and the OSX software it comes with, downloaded updates from Creative and the headset does NOT robo.

    I recently bought a Sennheiser headset with 3.5mm input and output plugs. I bought the Griffin iMic to use as an external soundcard/adapter/usb power source and I can use Ventrilo and Skype for HOURS with no robo effect.

    Next up: I recently got a new Macbook Air for work. It's running 10.6 and does not robo with ANY headset which robo'd on my older MacPro tower. A co-worker also got the same exact MacBook Air but rather than start with a fresh system, imported all his old data from a Macbook G4. His robo'd with the exact same headsets I'd tested on mine. He then wiped the new Air and did a fresh install of the OS and experienced NO Robo.
    MacBook Air 3.2, Mac OS X (10.6.6)
  • morph21 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 22, 2011 9:37 PM (in response to Christy Rudziensky)
    Christy, thank you for sharing that information. I read your post and got excited as I JUST reinstalled my mac due to a very very bad filesystem corruption.

    Anyway, full install of a 10.6.2 snow leopard that came with the machine then 10.6.7. This installation has "hours" of life.

    No applications, system settings or anything else despite the machine name and network settings where brought from the backup. My USER files were also restored from the time machine backup.

    I just started a chat with iChat and after 30 minutes or so there it was, the robotic sound all over again.

    What is next to me now is to try the same with a different user. I'll do so probably tomorrow and post my findings.
    iMac 27" i7 4x2.8GHz 8GB, Mac OS X (10.6.4)
  • fakeh Calculating status...
    Currently Being Moderated
    Apr 4, 2011 2:24 AM (in response to Jason Wooten)
    Someone seems to have had some success here: http://www.insanelymac.com/forum/index.php?showtopic=249627
    Mac Pro (2008), Mac OS X (10.6.7)
1 2 3 4 5 6 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.