Skip navigation

8GB won't install

11751 Views 25 Replies Latest reply: Nov 20, 2012 5:21 AM by Gigdan RSS Branched to a new discussion.
1 2 Previous Next
Jeaux Level 2 Level 2 (160 points)
Currently Being Moderated
Feb 16, 2011 2:23 PM
I have a fast 2010 Mini. The lower memory upgrade slot won't accept 4GB... when I try to install two 4GB SO-DIMMs, the mini won't boot. The lower memory slot will only accept 2GB. No matter how I try to mix and match the best I can do is 6GB (2GB in the bottom slot and 4GB in the top). What's up?
MINI, Mac OS X (10.6.4)
  • DaddyPaycheck Level 6 Level 6 (16,035 points)
    Currently Being Moderated
    Feb 17, 2011 3:11 AM (in response to Jeaux)
    Any chance one of the DIMMs is bad?
    A collection of clinking, clanking, clattering caliginous junk., Mac OS 8.6 or Earlier, PDP11
  • jonty1512 Calculating status...
    Currently Being Moderated
    Feb 17, 2011 3:28 AM (in response to Jeaux)
    Hi there

    To expand on Daddypaycheck's post I would try using just one of the DIMMS and put it in the first slot. If it boots up ok then power down and try it in the 2nd slot. If that is ok then repeat the process with the other DIMM. That way you can test both DIMMS in both slots and get an accurate result. If you find that you get this problem with both DIMMs in the lower slot then it's the slot that is faulty and I guess the mini will have to go back to Apple for service.

    Just be thankful that Apple have redesigned the Mini as to make this kind of testing easy. Would've been a nightmare in the old style Mini!

    Jonty
    Mac Mini (MA608B/A) Intel Core Duo 1.83 GHz 2 GB RAM, Mac OS X (10.6.6)
  • Jitanjafora Level 2 Level 2 (245 points)
    Currently Being Moderated
    Feb 17, 2011 10:45 PM (in response to Jeaux)
    Jeaux,

    The 2010 Mac minis shipped with a crippled firmware version that does not allow them to accept over 4GB/6GB of RAM. Check the firmware in your mini. Here's the Apple article:

    http://support.apple.com/kb/ht1237

    If the firmware is not up-to-date, it will simply not accept the RAM update.

    HTH,

    Felix
    iMacs (Intel and G3), iPod Touch, 17" PB, eMac, Pismo, et al., Mac OS X (10.6.6), Also Leopard, Tiger, Panther, OS 9.2.2, Windows XP, and some Linux flavors
  • Jitanjafora Level 2 Level 2 (245 points)
    Currently Being Moderated
    Feb 18, 2011 8:47 PM (in response to Jeaux)
    Hmm. You have been sorting this out in a very thorough and well-informed fashion, so I guess the only possibility left at this point is some sort of malfunction in your lower memory slot, since it can recognize a 2GB stick but not a 4GB stick. I would just take it to the Genius Bar and have Apple deal with it. The mini should still be under warranty.
    iMacs (Intel and G3), iPod Touch, 17" PB, eMac, Pismo, et al., Mac OS X (10.6.6), Also Leopard, Tiger, Panther, OS 9.2.2, Windows XP, and some Linux flavors
  • VinodB Calculating status...
    Currently Being Moderated
    Feb 19, 2011 10:08 AM (in response to Jeaux)
    I have the same problem. I installed a *GB kit and its just recognizing 4GB.
    I tried both 4GB individually and it works. Together the mac mini just recognizes 4GB. Anyone can help?

    Hardware Overview:

    Model Name: Mac mini aluminum
    Model Identifier: Macmini4,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 4 GB
    Bus Speed: 1.07 GHz
    Boot ROM Version: MM41.0042.B00
    SMC Version (system): 1.65f2
    Mac mini 2010, Mac OS X (10.6.6)
  • robert777nj Calculating status...
    Currently Being Moderated
    Mar 6, 2011 2:53 PM (in response to VinodB)
    I have the exact same problem as the original poster. 8GB wont take but chips work in the back slot. Seems to be an issue with the lower slot. That page doesn't show anything for the 2010 model mac mini.

    Looking forward to hearing the solution.
    mac mini, mac pro
  • robert777nj Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2011 4:21 PM (in response to robert777nj)
    So I believe I have figured out what is causing my problem. Thought I should share the results of my findings.

    So the Mac Mini comes stock with DDR3-8500 (1066MHz) and the RAM I purchased was DDR3-10600 (1333MHz).

    My theory is that the MAC cannot adjust the speed down without a 1066MHz speed chip.

    I also have a MacBook Pro with 8GB from Apple so I mixed 1 4gb from each and now both machines register 8GB.

    So I have in the Mini now 1 x 4GB DDR3-8500 (1066MHz) in the lower slot and 1 x 4GB x DDR3-10600 (1333MHz) in the upper slot.

    Watch the type of RAM you buy... Good Luck All!
    mac mini, mac pro
  • beischel Calculating status...
    Currently Being Moderated
    Mar 11, 2011 5:30 AM (in response to Jeaux)
    This is why I always go to a vendor like Crucial and use the specific memory they recommend for the system. When I have done that I have never had a memory issue. Only problems I have had, and they have been few, is trying to use memory that "should be compatible."

    BTW, I highly recommend the specific Crucial memory for the Mac Mini. I have 8GBs of their memory for both 2010 Mac Minis and it works perfectly without issue.
    Mini Mac
  • macconvert11 Calculating status...
    Currently Being Moderated
    Mar 11, 2011 6:11 PM (in response to Jeaux)
    Exact same issue here ... however I have TWO identical 2010 Mac Mini's, purchased at the same time.
    Same OS version, same firmware version.

    One will accept 8GB (2 x 4GB modules), the other fails (endless beeping) when the SAME EXACT 4GB modules are installed in it. Works ok if only one 4GB module is installed in the upper slot, but not both 4GB modules.

    This is obviously a hardware defect.
    Mac Mini 2010, Mac OS X (10.6.6)
  • bbellina Calculating status...
    Currently Being Moderated
    Jul 9, 2011 3:21 PM (in response to macconvert11)

    I just upgraded my 2009 (Model 3,1) and 2010 (Model 4,1) Mac Minis to 8 GB. I purchased the 4 4GB DDR3-1066 RAM cards I needed from RamJet.

     

    I had an enormous amount of trouble upgrading the 2010 Mac Mini's memory because I kept getting the endless beeping anytime I had anything installed in slot 0. I thought initially it was bad chips, but every one of the 4 that I purchased worked fine in slot 1 alone. Eventually what I determined is that it was a hardware problem with slot 0 easily fixed with a small flat-blade screwdriver.  What was happening is that the memory card inserted into slot 0 was being unseated slightly when the card was pressed down. The unseating was not enough to see and there was no way to avoid it. What I did to correct it finally was this: after the card was inserted and pressed down, I inserted a small flat blade screwdriver blade between the top of the card and the Mini and then turned the screwdriver blade so that it exerted some additional pressure on the card, pushing it further into the slot. I didn't see any difference or hear any difference, but after doing so the Mac booted up fine and all 8 GB was recognized.

     

    Ironically I had no trouble at all upgrading my older Mac Mini.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.