Skip navigation

New MacBook Pro early 2011 doesn't play nice with Home Sharing

80360 Views 348 Replies Latest reply: Nov 6, 2011 6:28 AM by MAW01 RSS
  • adr1974 Calculating status...
    Same problem here with my 2011 15" MBP. I've found that logging out of and back into homesharing works, but only until I quit iTunes. Upon reopening, I need to log out/in to homesharing to re-enable streaming of video.
    Mac Pro, Mac OS X (10.5.1)
  • flur Level 1 Level 1 (0 points)
    FYI - just installed 10.2.1 and it did nothing to solve the problem. I still see all my files on the MacPro and get a spinning wheel on the new MBP.
    2011 MBP, 2007 MacBook, 2008 MacPro, Mac OS X (10.6.6), iPhone 4x2 (4.0, iTunes 10.2.1)
  • earlgreyson Calculating status...
    The latest iTunes, 10.2.1, does not resolve this issue for me.
    Macbook Pro Early 2011, Mac OS X (10.6.6), iTunes 10.2.1(1)
  • jklick Calculating status...
    I'm having the exact same problems with a new MBP, ATV(G1) sync error(3689) and NO FIREWALL, and iPod Touch Remote App. iTunes 10.2 update is breaking everything. Getting ready to return the new MBP and putting the iPad2 on hold.
    MacBookPro i7, Mac OS X (10.6.6)
  • SnQ1420 Calculating status...
    same issue with me. I have another MBP 13 i5 and it works fine, but not from my i7.
    Macbook Pro 2.7ghz i7, Mac OS X (10.6.6)
  • sftobos Level 1 Level 1 (10 points)
    Same issue here. This worked fine no issues on my 2010 MBP. Am I doing something wrong here. Darn it, this is frustrating.
    Macbook Pro 2.2 2011 17', Mac OS X (10.6.6)
  • MacNewbie82 Level 2 Level 2 (195 points)
    Well glad to see it's not just me. Since it appears to be some sort of bug, hopefully Apple will fix it. Maybe the iOS 4.3 update? (at least for the remote app portion).
    MacBook Pro 13" 2.7GHz dual-core Intel Core i7, Mac OS X (10.6.6), iPhone 4 - 32GB
  • JSwerdy Calculating status...
    remote app wont connect and wireless printer connection won't keep. prints test page if i reset the connection and set it up, but after that stalls when trying to locate the printer. same behavior as the problem w/ remote app.
    '11 13inch mbp, Mac OS X (10.6.6)
  • NickMac77 Calculating status...
    I have exactly the same problem as MacNewbie82 on my new MBP. I've tried 3 different routers now, so I have ruled out my network, besides my remote app still connects to my old PC running iTunes just fine.

    I'm new to Macs and everything else in the transfer experience from a PC has been amazing, hopefully this is just a software glitch that will be patched soon.
    15" 2.2Ghz 2011 Macbook Pro, Mac OS X (10.6.6), iPhone 4
  • jklick Level 1 Level 1 (0 points)
    Spent an hour online with Apple Tech Support last night. Tried connecting the MBP directly to the ATV via an network cable in order to by-pass the router and wireless connection, also verified the firewall was set to off. Sync still failed with a message that port 3689 needs to be open. Could also send music to the ATV via air-tunes from the MBP to the ATV speakers.

    iPod Touch Remote App is still failing to the new MPB iTunes software. Verified for Tech Support that Remote App could still connect/control other iTunes devices including the ATV.

    Problem got escalated to Apple software engineering.
    MacBookPro i7, Mac OS X (10.6.6)
  • sftobos Level 1 Level 1 (10 points)
    Speaking to Apple as I type. My case is moving up to software engineering as well. Apple doesn't seem to be aware of this issue. We all need to call our cases in to get this fixed quicker. Steve my Apple contact on the phone stated the more people that call in the better to help troubleshoot the issue. I am going crazy over this one.
    Macbook Pro 2.2 2011 17', Mac OS X (10.6.6)
  • sftobos Level 1 Level 1 (10 points)
    See above comment plus, " sent 13 mb data capture image to Apple. Steve stated in could be up to 3 to 5 days before I could possibly hear anything back. Please call your cases is so the more info they get the quicker this will be resolved. I think with the IPAD 2 coming out Friday this could be pushed back to a lesser priority and be weeks if not months before it could be resolved.
    Macbook Pro 2.2 2011 17', Mac OS X (10.6.6)
  • jklick Level 1 Level 1 (0 points)
    Glad to hear Apple software engineering is working on the problem. I'll schedule an appointment for when I return from work tonight. I'll give them some time to fix. If it gets into a couple of weeks I'll probably return the new MBP while it's still under the 90 day return guarantee. I hate going back to my old window-7 PC but it works and there is no point in keeping a new MPB that is non-functional for sync to my ATV and iOS Remote App.
    MacBookPro i7, Mac OS X (10.6.6)
  • sftobos Level 1 Level 1 (10 points)

    Not to derail this thread but just to give you a heads up. Typically on Apple products the return policy is 14 days. This is merely an FYI to you.

    No back to the thread. I am curious why we have not seen more activity on this issue. There is this thread but I would think there would be many more with the same issue we are having.
    Macbook Pro 2.2 2011 17', Mac OS X (10.6.6)
  • sftobos Level 1 Level 1 (10 points)
    Well guess what I may have fixed it.
    Quit Itunes
    Delete this file:
    Restart Itunes
    Connect as before with ATV or Apple App Remote

    Mine is now working.

    Tell me if it worked for you. If this works Apple owes me back my sanity.


    User, library, preferences, byhost,
    Macbook Pro 2.2 2011 17', Mac OS X (10.6.6)
1 2 3 4 ... 24 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.