Skip navigation

Not Enough Space to Sync My Photos After Updating to 4.3

5834 Views 6 Replies Latest reply: Apr 15, 2011 1:53 PM by McHausman RSS
Louis Trapani Level 1 Level 1 (20 points)
Currently Being Moderated
Mar 9, 2011 3:30 PM
With iOS 4.2, I was able to sync my entire Aperture photo library to my iPad and still had about 3GB to spare on it. It's a 32GB iPad. If I recall correctly, the photos took up about 6GB on it. After updating to 4.3 today, iTunes is telling me that it can not sync my photos to it because there is not enough space.

How can this be? I had been syncing the entire library before with 4.2. OK, maybe Apple is optimizing the photos differently for 4.3 and they need more space, I don't know. I went ahead and cleared out all my video I had synced there along with some other stuff and freed up over 20GB of space which is available. Yet iTunes is still saying there's not enough space. How can this be? There was space with iOS 4.2, but not with 4.3. With 4.2 I had a few GB to spare even with my entire photo library synced. Now I freed up over 20GB and it's telling me it can not sync my photos.

So now I am going to try to selectively sync photos to my iPad instead of choosing the option to sync them all. I still don't understand why I was able to sync them all under 4.2, but not 4.3.
Mac Pro 8-Core, 17" MacBook Pro, iPhone 4, iPad, iOS 4
  • Carolyn Samit Level 10 Level 10 (84,500 points)
    Hi,

    Try deleting the photo cache, instructions at this link.



    http://reviews.cnet.com/8301-13727_7-20012542-263.html







    Carolyn
    27" iMac 3.2GHz i3 MBAir iPad iPhone 4 iLife iWork / AirPlay ATV2 AiportExtr, Mac OS X (10.6.6), QTPro Intuos Epson Olympus Airport JBL
  • Mr. Luigi Level 1 Level 1 (5 points)
    Hi Louis (nice name),

    I had the same experience. Luckily for me I have a 64GB iPad. So despite being told by iTunes during the optimization process that I had about 18 GB of pictures (I too thought at the time that perhaps iOS 4.3 was creating much larger picture files during the optimization process for some reason because this was about twice the size of my picture file before updating to iOS 4.3), I didn't have to remove anything and do things piecemeal as you were forced to do. All my pictures successfully optimized and downloaded in one swoop because I had the space. Then, BOOM, the size of my picture file in my iPad went down from 18GB to around 9GB once the sync was complete. So, I'd say this is a little bug in 4.3 that probably deserves reporting to Apple via their Feedback process. In the meantime, for those experiencing this same behavior, your solution seems quite clever and effective. Of course, for those of us with big, honkin' 64 GB iPad memories we might be able to get by without your clever strategy.

    Cheers, Mr. Luigi
    MacBook Pro 2.53 GHz Intel Core 2 Duo, Mac OS X (10.6.6), iPod Touch, iPod Nano, iPod, Airport Extreme, Apple TV
  • dmason84 Level 1 Level 1 (0 points)
    I had the same issue when I first got my iPad, which was on iOS 3.x (can't remember the exact version). I don't think the issue is do with 4.3, just an old issue which appears to have resurfaced as 4.3 seems to force a resync of all photos.
    iMac 24" 2.8 GHz Intel Core 2 Duo, Mac OS X (10.6.4)
  • McHausman Calculating status...
    I have had the same problem early on with iPad and then recently with the system upgrade and having to resynch the whole photo library. I took my cue from other posters who suggested synching a few albums/events at a time. That worked and allowed me to stumble upon what had been causing the problem - at least for me, and maybe for others. It turns out I had a single album containing a single huge file (128MB) that had been created by merging two very high res scans in Photoshop . Whenever I included this album as one of several to be synched, I got the "not enough memory" message. By unselecting this album I could then select as many others as I liked (containing "regular" photo files) and synch many hundreds of photos at once. The inference is that if you are selecting your entire library to synch and there is one giant file lurking in amongst all the normal photos, perhaps this is causing the problem you have been having. Do you have some panorama photomerges of multiple high res images, for example? If so, de-select those and then see if synching the rest of the library goes any better.
    MacBook5,1, Mac OS X (10.6.7), iPad

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.