1 2 Previous Next 18 Replies Latest reply: Nov 4, 2011 11:35 PM by jdcowboy
erikfsn Level 1 Level 1 (80 points)
In another thread on home sharing someone noted that they have a "Shared" icon which appears under "More" in the iPod app.

Nothing like that on my phone. What's up with that?

I've updated my phone and computer with the most recent software, and they are both working on the same wireless network.

imac, Mac OS X (10.6.4)
  • 1. Re: no "shared" icon on my phone
    erikfsn Level 1 Level 1 (80 points)
    A thought occurred to me, do I need to get the Apple TV for the following functionality?

    "Now you can play your entire iTunes library from anywhere in the house. If it’s on your Mac or PC, you can play it on your iPhone, iPad, or iPod touch over a shared Wi-Fi network.3 And not just music. Watch a movie or TV show. Play a podcast. Or listen to an audiobook. On whichever device you want — without having to download or sync."
  • 2. Re: no "shared" icon on my phone
    Adam McMaster Level 1 Level 1 (0 points)
    Make sure you've selected "Advanced -> Enable Home Sharing" in iTunes. It's not enough to just enable Sharing in Preferences.
  • 3. Re: no "shared" icon on my phone
    Ian Parkinson Level 6 Level 6 (10,400 points)
    Have you gone into the Settings > iPod on the phone and entered your Apple ID (as used in your iTunes)?
  • 4. Re: no "shared" icon on my phone
    blark Level 1 Level 1 (50 points)
    on the iPhone 3Gs and iPhone 4 after you get the home sharing setup on you phone and in itunes on your computer, you have to go to the iPod app on you phone then tap on more then you should see shared on you iPhone
  • 5. Re: no "shared" icon on my phone
    erikfsn Level 1 Level 1 (80 points)
    Thanks for the suggestions. I had already done all but enabling sharing under "advanced." Unfortunately, that did not solve the problem.

    Any other ideas?
  • 6. Re: no "shared" icon on my phone
    luvluvapplelongtime Level 1 Level 1 (10 points)
    Same problem. Did everything everyone suggested.
  • 7. Re: no "shared" icon on my phone
    Keith Lines Level 1 Level 1 (85 points)
    Same problem here on both my iPad and iPhone. I have home sharing enabled on a Mac Mini and a MacPro (both upgraded to latest iTunes). I have no problem sharing between the Macs. I have entered my username and password on both iOS devices, rebooted both, turned home sharing on/off on the Macs, but still I can't see 'shared' under the more tab, nor can I see my shared library in the side panel on my iPad.

    (Ah well, I have GarageBand to play with for now!) Lets hope for a prompt bug update from Apple as this seems to be a fairly frequent problem.
  • 8. Re: no "shared" icon on my phone
    Nathanial Ziarek Level 1 Level 1 (5 points)
    I had the exact same problem. Erasing the password under "Settings>iPod" and then re-entering it fixed it for me. I previously had set up home sharing on my iPad, but never on my phone. Not sure where iTunes got that username and password in the first place.
  • 9. Re: no "shared" icon on my phone
    newagemac Level 2 Level 2 (240 points)
    erikfsn wrote:
    Thanks for the suggestions. I had already done all but enabling sharing under "advanced." Unfortunately, that did not solve the problem.

    Any other ideas?


    After enabling it in iTunes under "Advanced" and enabling it on your iPod under Settings > iPod, you should reboot your computer and the mobile device and it should work.
  • 10. Re: no "shared" icon on my phone
    Trash II Treasure Level 1 Level 1 (65 points)
    iMac
    sharing is enabled in iTunes (latest)

    iPhone
    username and password in 'settings/iPod'

    restarted both devices, still no shared icon under "more"

    Hmmm
  • 11. Re: no "shared" icon on my phone
    Trash II Treasure Level 1 Level 1 (65 points)
    Screengrab of iMac itunes showing (centre) home sharing enabled
    also
    iPhone with home sharing details added

    http://farm6.static.flickr.com/5138/55196408140e1266a8ccb.jpg

    tried rebooting both - still no shared libraries option (right)...

    the right screen says "Status: On, no users connected" - so this suggests the iphone isn't talking to the iMac.
    Tried reentering the username and password, but still nowt, Any ideas?
  • 12. Re: no "shared" icon on my phone
    Trash II Treasure Level 1 Level 1 (65 points)
    Turned home sharing on the iMac off, turned it back on again and bingo - shared turned up!
  • 13. Re: no "shared" icon on my phone
    Keith Lines Level 1 Level 1 (85 points)
    After discovering that one machine which has a wired connection to my router worked, I figured it might be something to do wifi connections. As my last resort, I did a cold restart of my Macmini (which is the machine I really want to access via home sharing) and also of my wifi router. Happily, for whatever reason, this did the trick and I can now access any machine on my network via home sharing from my iPhone and from my iPad.
  • 14. Re: no "shared" icon on my phone
    Kibi Level 1 Level 1 (0 points)
    No, this does not work. No matter what, the "shared" option is not available on my iPhone.
    I have even gone to the extent of ensuring that my Mac and my iPhone are on the same subnet. I have restarted my iPhone and Mac numerous times, enabling and disabling home sharing on the Mac has absolutely no effect.
1 2 Previous Next