Skip navigation

PPTP Won't work after 4.3 Upgrade

73235 Views 123 Replies Latest reply: Aug 4, 2012 10:02 AM by sguilliard RSS
1 2 3 ... 9 Previous Next
JC_MacD Calculating status...
Currently Being Moderated
Mar 10, 2011 2:03 PM
We had a PPTP VPN connection on our department iPad. I upgraded to 4.3 and now it won't connect to the vpn. Has any one else had this problem? We know the vpn works, we connected an 4.2 iPhone. VPN device is a Nortel 1700.
iPad 16gb WiFi 1st Gen, iOS 4, iOS 4.3
  • Asatoran Level 4 Level 4 (2,535 points)
    Currently Being Moderated
    Mar 10, 2011 2:49 PM (in response to JC_MacD)
    Mine is still working after the update. I have PPtP to a Cisco Linksys RV042. (And L2TP & IPSec VPNs are also working for me.) Sorry I can't help more than that.
    MBP 15" Penryn, Mini 2009, iPad 3G (4.2.1), Mac OS X (10.6.6)
  • livinginamoment Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2011 4:55 PM (in response to JC_MacD)
    I'm in the same position. My husband's iphone which has not been upgraded still works but my iphone and my ipad, both upgraded to 4.3 no longer work. I have had trouble with the ipad since the previous upgrade too but at least I could still access the VPN then. Now it won't even connect no matter what I do.
    Macbook Pro, Mac OS X (10.6.6)
  • Steveclv Calculating status...
    Currently Being Moderated
    Mar 10, 2011 4:58 PM (in response to JC_MacD)
    Yes, I have exactly the same problem. iOS 4.3 on an iPad and an iPhone will not connect to the VPN using PPTP or L2TP

    We have tried using WiFi (through a Linksys WRT100N) and 3G and neither connects.

    If I try using another iPhone with iOS4 through the same router it works fine.

    Also using a Windows 7 laptop and an OSX Mac all work fine too.

    So it is something to do with iOS 4.3

    We have deleted the old VPN settings and recreated them, rebooted the device, reset the WiFi connections, rebooted the router and tried on both 3G and WiFi and nothing makes any difference.
    iPad, iOS 4, iOS 4.3
  • Steveclv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2011 7:19 AM (in response to JC_MacD)
    I have run side by side tests now with one iPad and 2 iphones.

    iPad with iOS 4.3 connects maybe 1 time in 10
    iPhone with iOS 4.3 will never connect - get a message saying unable to connect to PPP server although the settings are identical with the other 2 devices.
    iPhone with iOS 4.2.1 connects first time, every time

    We have tested this with our WiFi network (Linksys WRT100N) and 3G (ATT) with the same result.
    iPad, iOS 4, iOS 4.3
  • TheMacKid Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 11, 2011 7:22 AM (in response to JC_MacD)
    If I had an iOS device, I would avoid this update like the plague until they can get it right!
    iBook G4 1.07ghz 12 inch, Mac OS X (10.5.8), 768mb RAM, PowerPC G4, Leopard 10.5.8
  • Steveclv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2011 7:25 AM (in response to TheMacKid)
    Just found this on another thread...
    "Our corporate proxy is a Microsoft ISA server and checking the logs on there after repeated failed efforts to get to either http or https sites revealed that the *proxy was not getting presented with the user credentials* from the iPad. The proxy was getting no username / password and as a result dropping the requests. Very occasionally, it would present the credentials and pass the traffic but it's intermittent to say the least."

    This is relevant to a proxy server but that is not a million miles away from a VPN - so it may be the same issue - that iOS 4.3 is not always sending the username and password to the VPN server and that ties in with my experience of 1 in 10 connection attempts succeeding

    iPad, iOS 4, iOS 4.3
  • livinginamoment Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2011 9:10 AM (in response to Steveclv)
    I think you may be right about the authentication. My ipad seems like it is connecting but then drops the connection after a few seconds. Suggests to me that it is not getting the information for some reason. I had it connect twice last night but dropped the connection after about one minute. Haven't been able to connect since. My iphone 4 does not even connect at all. I have tried it on 3G and wireless in all variations. Please can somebody help. I was going to upgrade to a new ipad but I don't think I will bother now unless this is fixed soon.
    Macbook Pro, Mac OS X (10.6.6)
  • p0p0 Calculating status...
    Currently Being Moderated
    Mar 11, 2011 10:47 AM (in response to JC_MacD)
    It's working fine for me on 4.3 :S
    MacBook, Mac OS X (10.6.6)
  • Steveclv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2011 10:59 AM (in response to p0p0)
    If it's working for you, can you give us more information about your setup rather that just a 'its working'?

    What type of VPN are you accessing, what settings are you using etc etc

    At least we can start to see why it's not working for some and is for others.


    iPad, iOS 4, iOS 4.3
  • BritViewer Calculating status...
    Currently Being Moderated
    Mar 11, 2011 11:05 AM (in response to Steveclv)
    For me it's hit and miss: some VPNs still work, other have stopped. On the one that stopped, I switched from PPTP to L2TP (by selecting the L2TP tab at the top and then entering the "shared secret"). That now works, but still investigating what the PPTP change is that causes it only to work with some VPNs.
    iOS 4.3, iOS 4
  • livinginamoment Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2011 12:54 PM (in response to BritViewer)
    Tried changing to to L2TP, won't work on iphone at all and connected one time on ipad and only worked for about a minute again. Don't think it's a fault with the VPN as it is still working on the PC laptop (and on the mac except it's really slow) and the old iphone which has still not been updated. I have to make an extra comment that the iPad became very hit and miss after the previous update and hasn't really worked well since so I am thinking that there was something wrong then and 4.3 has made it worse and completely unusable now. I am hoping someone will post when they have the new ipad to see if it is doing the same thing.
    Macbook Pro, Mac OS X (10.6.6), iPhone 4, iPad
  • on2003 Calculating status...
    Currently Being Moderated
    Mar 12, 2011 3:54 AM (in response to JC_MacD)
    First, it is not DNS issue, as I tried with corresponding IP Address, same result.

    2nd, I first notice this issue in iOS 4.3 beta3.

    The device is: iphone 4 with iOS 4.3

    The same VPN configuration works perfectly before iOS 4.3

    So I believe iOS 4.3 brought the issue.
    mac air, iOS 4
  • BritViewer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2011 3:30 PM (in response to on2003)
    For sure the problem came with OS4.3, as I have the exact same config and VPN provider that used to work in previous versions. If it was in 4.3 beta, I wonder why didn't they address it? And if you were beta testing it, why didn't you SHOUT LOUDER at the time ;o)
    Definitely worth trying the switch to L2TP as I've now confirmed that this has fixed it for a couple of people. You might get lucky. You'll need to switch the tab at the top to L2TP and get the "shared secret" for L2TP from your VPN provider / network admin.
    Also hearing that it sometimes works with PPTP - which tends to make me think it's a timing issue of some sort; though I haven't managed to get through on PPTP ever. Per my VPN provider, they don't even see the connection request for PPTP.
    Have also tried using the direct IP address, in case it was DNS related. Same result, so pretty sure it has nothing to do with DNS.
    VPN seems a bit of a weak point for Apple in general. From the crappy Cisco client VPN stack they use on Macs (which doesn't auto-negotiate MTU settings with some routers, even after several releases) to this. Still, fairly confident they'll sort this by 4.3.1 - since they could simply roll back to the previous version.
    C'mon Jobsy, throw us a bone.
    Mac OS X (10.6.4)
1 2 3 ... 9 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.