Skip navigation

Daylight Savings Time not changing

54552 Views 92 Replies Latest reply: Mar 12, 2012 3:23 PM by glenw1 RSS
1 2 3 ... 7 Previous Next
ekcwmi Calculating status...
Currently Being Moderated
Mar 13, 2011 3:55 AM
I have a Verizon Wireless iPhone 4 and the time didn't change for daylight savings time today. It is set to do it automaticly and I also tried to sync it to see if it would change but it didn't. Any advice?
Dell, iOS 4
  • M4NiC5 Calculating status...
    Currently Being Moderated
    Mar 13, 2011 4:57 AM (in response to ekcwmi)
    same problem. I have a 3gs and my wife has the 3g model. A phone reboot resolved the issue.
    iphone 3gs, iOS 4
  • code3vp Calculating status...
    Currently Being Moderated
    Mar 13, 2011 5:23 AM (in response to ekcwmi)
    I have iphone 3g and it also did not change. My alarm went off at 6:10 and again at 6:30 and it was an hour behind. Needless to say I was late to work for 2nd time thanks to the iphone. When I left the house to place a call and ended the call the phone updated the time, the time the call was placed and a text message at 6:30 to the new time. Seems like the problem is in the phone with the phone being in a standby or sleep mode.
    Macbook Pro, iOS 4, Iphone and Macbook pro
  • oneworld95 Calculating status...
    Currently Being Moderated
    Mar 13, 2011 6:47 AM (in response to ekcwmi)
    Same issue here. Woke up and my iPhone 4 (Verizon) had not changed to the correct time. If I changed the Date & Time > Set Automatically > to Off, the time was correct. If set this to On, the time was back by one hour. What's causing this?
    Lenovo ThinkCentre, Windows 7, x64
  • Lawrence Finch Level 7 Level 7 (24,500 points)
    Currently Being Moderated
    Mar 13, 2011 6:43 AM (in response to ekcwmi)
    If you have time set to "Automatic" it's the carrier who sets the clock. And if the phone was off or in Airplane mode it would not receive the DST update. My AT&T phone DID receive it, so this is likely a Verizon issue or your phone was off or off net.
    MacBook Air, Intel iMac , Dell/Ubuntu 8, iPhone 3GS iOS 4.3, Mac OS X (10.6.6), Leopard 10.5.4 on iMac, XP via Fusion on MBA
  • Screwball216 Calculating status...
    Currently Being Moderated
    Mar 13, 2011 6:52 AM (in response to Lawrence Finch)
    Lawrence Finch wrote:
    My AT&T phone DID receive it, so this is likely a Verizon issue or your phone was off or off net.


    Going with the latter... my iPhone was on over the night, and the time is correct.
    Verizon iPhone 4, iOS 4
  • Redwards1517 Calculating status...
    Currently Being Moderated
    Mar 13, 2011 6:53 AM (in response to Lawrence Finch)
    Wrong. I have AT&T and mine fell back an hour. This is ridiculous. The clock when you hit the button says the correct time, but the little clock (the internal clock) at the top has the incorrect time. Didn't Apple fix this back in November???
    iPhone 3G (AT&T), iPhone OS 3.1.3
  • Lawrence Finch Level 7 Level 7 (24,500 points)
    Currently Being Moderated
    Mar 13, 2011 7:04 AM (in response to Redwards1517)
    The clock at the top of mine has the correct time. If you are truly on 3.1.3 as your profile says even if Apple fixed it your phone would not be fixed.
    MacBook Air, Intel iMac , Dell/Ubuntu 8, iPhone 3GS iOS 4.3, Mac OS X (10.6.6), Leopard 10.5.4 on iMac, XP via Fusion on MBA
  • Redwards1517 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 13, 2011 7:08 AM (in response to Lawrence Finch)
    I'm on iOS 4.2.1, my bad. However, my phone is the old 3G version. I wonder if that has something to do with it. My wife has the same phone, and hers is working fine.
    iPhone 3G (AT&T), iOS 4
  • Zarg404 Calculating status...
    Currently Being Moderated
    Mar 13, 2011 7:13 AM (in response to Redwards1517)
    I am on a worktrip in Chile. Yesterday (03/12/11) both my iphone (4.2.1) and my mac book pro (10.6.6) changed their time at around midnight(local time). This morning they are both late of one hour !
    Any way to fix that ?
    Thank you

    Message was edited by: Zarg404
    Macbook Pro, Mac OS X (10.6.6)
  • samstone10 Calculating status...
    Currently Being Moderated
    Mar 13, 2011 7:36 AM (in response to ekcwmi)
    When I first woke up the time had changed. 10 minutes later it reverted back to standard time. When I turn off the auto time change it displays the correct time. ??
    iphone 4, 4.3 has been installed
  • Pitchy Calculating status...
    Currently Being Moderated
    Mar 13, 2011 7:37 AM (in response to ekcwmi)
    I am having the same problem with my iPhone 4 (ATT) - iOS 4.3. My time is set to automatic and it is an hour behind. My fiancé who is right beside me with a 3GS has the correct time as well as my iPad 2.

    One would think that if this was a tower issue that her and I would be on the same tower. Rebooting does not fix the time. If I disable Set Automatically, the time jumps ahead an hour and all is well.

    I am puzzled by this.
    custom, Windows XP Pro, iPod 60gb Video [5g]
  • Top_Shelf Calculating status...
    Currently Being Moderated
    Mar 13, 2011 7:38 AM (in response to M4NiC5)
    I have an iPhone 4 that has the correct time this morning. My wife's iPhone 3G didn't change the time, but turning it off and on again solved the issue. thanks M4NiC5!
    iOS 4
  • j0hnw3bb Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 13, 2011 8:32 AM (in response to ekcwmi)
    +1. My AT&T iPhone 3GS running iOS 4.2.1 had the same problem. It did NOT automatically "Spring Forward" for Daylight Savings time. I had to restart the phone to get the correct time. I though Apple had addresses this issue back in November with the "Alarm Clock DT" bug. Sigh.

    Interestingly, my WiFi iPad (v1) running iOS 4.2.1 updated the time just fine.

    John
    Mac Pro, Macbook Pro, Mac Mini, Mac OS X (10.6.6)
  • tbandl Calculating status...
    Currently Being Moderated
    Mar 13, 2011 9:13 AM (in response to ekcwmi)
    I, too, suffered the same problem with my iphone 4, os 4.3. My phone did not spring forward an hour, unless I turned it off to do so automatically in the settings. However, my son has a 3gs and his phone DID spring forward. Same house, same AT&T, same os, same everything except for the type of phone. Very strange. I restarted my phone two times, but the only thing that would make it spring forward was to turn off "Set Automatically," then it moved, but if I turned it back on it would go back an hour. Erg.
    macbook pro 13", Mac OS X (10.6.6), iPhone 4, os 4.3
1 2 3 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.