12 Replies Latest reply: Oct 3, 2013 11:24 AM by OisinDSNT
topping Level 1 Level 1 (0 points)
Hi all,

I saw someone with this issue, but his solution doesn't seem related to mine. Like most users, I open Finder windows and they stay open when I launch a foreground app. Problem is, sometimes Finder goes to 100% CPU after a while until the windows are closed.

It's very strange. My first instinct was it was Spotlight, but now it happens relatively frequently (once a day or so). MenuMeters shows high CPU usage, Activity Monitor confirms it is Finder at 100%, switch to Finder, hit "command option w", problem stops.

Is there a way to stop this altogether?

Cheers, Brian Topping

MBP 15" i7 hi-res 8GB/256GB SSD, iMac 27" Quad i7, Mac OS X (10.6.5)
  • 1. Re: Finder to 100% CPU
    Kappy Level 10 Level 10 (226,845 points)
    Yes, find out what is causing the Finder to malfunction. Killing a window only covers the symptoms, but it does not fix the problem.

    A first guess is: bad com.apple.finder.plist file in /Home/Library/Preferences/. Delete the file.
  • 2. Re: Finder to 100% CPU
    Martin Bell Level 1 Level 1 (120 points)
    Thanks Kappy, I had similar problem, deleting the file resolved the issue. For the time being anyway. May the Force be with you.
  • 3. Re: Finder to 100% CPU
    ichaddy Level 1 Level 1 (0 points)
    Brilliant thanks so much. Works fine now even after a restart.

    I deleted the file "com.apple.finder.plist"

    in /Home/Library/Preferences/

    Goto Terminal and input
    killall Finder
    (this restarts the finder)

    Thats will bring the Finder back to 1%CPU usage !
  • 4. Re: Finder to 100% CPU
    woondidu Level 1 Level 1 (0 points)
    hi all

    I have the same problem. As soon as a finder window is open my cpu usage goes up to 100% - when I close all finder windows - problem gone.

    deleting the com.apple.finder.plist file and restarting the finder didn't change anything however...

    does anyone have another idea?
  • 5. Re: Finder to 100% CPU
    rstoner Level 1 Level 1 (0 points)
    I had the same problem this morning. Removing the plist file seems to have done the trick. Thanks.

    woondidu - If you have a lot of files, especially jpegs on your desktop, clean your desktop up this has also been known to cause finder to chew up CPU.
  • 6. Re: Finder to 100% CPU
    rstoner Level 1 Level 1 (0 points)
    AH this problem showed up again this morning and based on my playing around, I think Finder was choking on my external USB drive. I ran disk repair and there were several errors reported and repaired. Been running nice and quite for several hours now.
  • 7. Re: Finder to 100% CPU
    bytemonkey Level 1 Level 1 (0 points)
    This did the trick for me just now. Moved the com.apple.finder.plist file to the trash, relaunched the Finder and everything immediately starting winding down.
  • 8. Re: Finder to 100% CPU
    snowyogi Level 1 Level 1 (0 points)
    Deleting all the screen captures on the desktop worked for me. CPU was about 85% and disk read was about 5MB/sec. Deleting about 30 png files immediately resolved the problem without reboot.
  • 9. Re: Finder to 100% CPU
    Phil.H Level 1 Level 1 (0 points)
    As of 10.6.6 I have a version of this problem, completely reproducible,
    tied to checking the "calculate all sizes" in the "Show View options"
    Closing the Finder window thus checked, or unchecking the box restores
    the conventional Finder usage (0-0.4%) on an Intel Core i7 2.2 GHz 4-core.

    Previously reported around 10.6.2. in Sept. 2009
    http://discussions.info.apple.com/thread.jspa?threadID=2135562&start=0&tstart=0

    I have a SSD disk that quickly calculates the sizes, but the Finder remains
    at 100% for one processor core, no matter how long the Finder window
    so checked (calculate all sizes). The window calculations are clearly done.

    In my case removing the preference file (com.apple.finder.plist) had no effect.

    It is hard to imagine this bug lingering until 10.6.6, unless the "tickle"
    is rather subtle.

    Quite reproducible. No time today to progressively delete preference files.
  • 10. Re: Finder to 100% CPU
    KTransue Level 1 Level 1 (0 points)
    Thanks Phil.H. I like having "calculate all sizes" set, especially since my MacBook Pro is using just about all available space. But, unchecking "calculate all sizes" restored typical cpu usage instantly.
  • 11. Re: Finder to 100% CPU
    mjc Level 3 Level 3 (635 points)

    I solved this issue by setting my finder preferences for "New Finder window show:"  to my home folder... My issue was that it was defaulting to "All My Files"--- that caused finder to scan everything, images, thumbnails, etc and get up over 100% of cpu usage.

  • 12. Re: Finder to 100% CPU
    OisinDSNT Level 1 Level 1 (0 points)

    This worked for me! Cheers