Skip navigation

xcode 3.2.6 stops looking in /Library/Frameworks

3662 Views 3 Replies Latest reply: Mar 30, 2011 8:23 PM by psksvprv2 RSS
psksvprv2 Calculating status...
Currently Being Moderated
Mar 13, 2011 6:51 PM

I have just upgraded to xcode 3.2.6 from 3.2.3. When I try to build my project, there were lot of compiler error, because It can't find header file. The project was built fine in the previous version of xcode(3.2.3).

My project liked with some frameworks in /Library/Frameworks and they are all still there. so I delete all the xcode preference file, and try building my project again, still xcode3.2.6 would not look in /Library/Frameworks.

I tried delete the references of the frameworks from my project and tried to reinsert them into my project again, somehow when I did "right-click on the target" -> "Get info" -> "General" Tab -> click on the '+" button at the bottom of "Linked Libraries" List Box, all the framework files in /Library/Frameworks does not list like it used to with the previous version of xcode. I had to click on the button "Add Another" to navigate to /Library/Frameworks to select the frameworks and add to my project again.

I have to manually put a flags -F/Library/Frameworks to get my project to build corretly again.

has anyone experienced this?? and know why?

Intel Core 2 duo 1St gen Mac Mini


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.