Skip navigation

4.3 HomeSharing

30876 Views 68 Replies Latest reply: Apr 17, 2011 2:55 PM by danel k RSS
  • franza83 Calculating status...
    Currently Being Moderated
    Mar 12, 2011 2:44 AM (in response to a Mac user)
    iPhone 4 and iTunes 10.2.1 on a 11.6" MacBook Air (2010)

    I had same problem ('Cannot connect to media library') *until yesterday* (I have tried to re-enter ID and password many times, reboot, hard reboot, ..., with no results).

    Today, doing nothing, it works
    Very strange...
    MacBook Air, Mac OS X (10.6.6)
  • circlhill Calculating status...
    Currently Being Moderated
    Mar 12, 2011 5:33 AM (in response to canitrustmac)
    Okay I had the same problem-iphone 4 could not connect to shared library. I restarted my iphone, because it had not been restarted since the 4.3 update, and it now works perfectly. Give it a shot!
    macbook pro i7 2 Ghz, Mac OS X (10.6.6)
  • PhantomApple Calculating status...
    Currently Being Moderated
    Mar 12, 2011 8:44 AM (in response to circlhill)
    Doesn't work on my new iPad 2 either.
    Windows 7, iOS 4
  • Philly_Phan Level 6 Level 6 (11,010 points)
    Currently Being Moderated
    Mar 12, 2011 8:47 AM (in response to maury)
    maury wrote:
    Go to security settings in system preferences and make sure firewall is turned off. That is what fixed my issue!

    Actually, you can keep the firewall turned on if you allow for an exception - iTunes.
    iMac, Mac OS X (10.6.6), iPad-1 IOS 4.3
  • Philly_Phan Level 6 Level 6 (11,010 points)
    Currently Being Moderated
    Mar 12, 2011 8:51 AM (in response to a Mac user)
    a Mac user wrote:
    Doing that actually made my problem worse.

    ?
    iMac, Mac OS X (10.6.6), iPad-1 IOS 4.3
  • thebx61 Calculating status...
    Currently Being Moderated
    Mar 12, 2011 8:38 PM (in response to a Mac user)
    Any word? I've tried everything from restarts to restores. Totally not the iPad tho bc I am able to connect to a windows machine running xp no problem.

    Primary laptop: mb pro 13'" early 2011, i7 (no more than a week old for me). will not allow homeshare with iPad

    Secondary: Dell mini xp- easy peasy homeshare set up and go, no issue with iPad and sharing.

    Both have iTunes 10.2.1.

    iPad is first gen 64 gb.
    Macbook, Mac OS X (10.6.6)
  • Philly_Phan Level 6 Level 6 (11,010 points)
    Currently Being Moderated
    Mar 12, 2011 8:57 PM (in response to thebx61)
    thebx61 wrote:
    Primary laptop: mb pro 13'" early 2011, i7 (no more than a week old for me). will not allow homeshare with iPad

    Is your internal firewall on?
    iMac, Mac OS X (10.6.6), iPad-1 IOS 4.3
  • thebx61 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 13, 2011 4:24 AM (in response to Philly_Phan)
    Turned on but have turned off, done all soft resets on all devices and still nothing.
    Macbook, Mac OS X (10.5.2)
  • canitrustmac Calculating status...
    Currently Being Moderated
    Mar 13, 2011 6:47 AM (in response to franza83)
    DeAuthorized all machines from iTunes
    Turned off Home Sharing iMac / PC / iPad
    Deleted Library files from iMac / PC (exported playlists first!)
    Rebooted / Turned off firewall
    Re-Authorized all machines
    Opened iTunes on iPad
    Result:

    Bubkiss.

    Please, good folks @ Appl...we need a one-shot utility to clear the path to make this work.
    iMac 20" 2.4ghz 1gb / 4gb RAM /iPad 16g wifi / iOS 4.3 /, Mac OS X (10.6.6)
  • jtbnz Calculating status...
    Currently Being Moderated
    Mar 13, 2011 10:03 PM (in response to canitrustmac)
    Same problem for me with and Iphone and an Ipod. running Itunes on Windows 7

    Started a virtual XP machine installed itunes, turned on sharing and it worked first time.

    went back to the windows 7 itunes and still doesn't work........
    Toshiba, Windows 7
  • sanramon_94582 Calculating status...
    Currently Being Moderated
    Mar 13, 2011 11:37 PM (in response to jtbnz)
    Same problem here. (I'm using Windows 7)

    I have the latest iTune 10.2. Home Sharing turned on.

    I have the latest iOS 4.3 on my iPad. I entered id and password. I'm sure they are corrent.

    When I go to iPad's ipod app, it does not show other Library

    When I go to iPad's Video app, on the top there's only Movies, does not show other tabs

    On computer's iTunes app under Sharing, it says On, no users connected.

    I tried everything I've seen in these posts so far. Restart. Reboot. Turn on apps in iPad and iTunes in different sequence. Tun off firewalls...

    What else can I try? Thanks!
    Windows 7
  • canitrustmac Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 14, 2011 5:05 AM (in response to canitrustmac)
    I must be clear by saying that the library tab shows up on the iPad, I just cannot connect to it.
    iMac 20" 2.4ghz 1gb / 4gb RAM /iPad 16g wifi / iOS 4.3 /, Mac OS X (10.6.6)
  • sk0rp10 Calculating status...
    Currently Being Moderated
    Mar 14, 2011 7:38 AM (in response to canitrustmac)
    iPhone 3GS, iOS 4
  • sk0rp10 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Mar 14, 2011 5:49 PM (in response to sk0rp10)
    iPhone 4, iOS 4
  • sheardiv Calculating status...
    Currently Being Moderated
    Mar 14, 2011 8:08 PM (in response to zwei)
    Awesome! Worked great for my ipad but not my iphone. Not to concerned about that but thanks for this tip.
    Mac OS X (10.6.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.