Skip navigation

ATV2.2 Updated Now No Audio

9722 Views 50 Replies Latest reply: Jun 17, 2011 8:34 AM by danfromparksville RSS
  • vazandrew Level 6 Level 6 (12,990 points)
    Currently Being Moderated
    Mar 11, 2011 8:02 PM (in response to SuperTroye)
    I finally got a chance to try home-sharing and it also worked.

    @ Supertroye. If you want a response from Apple you won't get it here, I would suggest calling support.
    iMac 2.8GHz 2GB RAM ATI Radeon HD 2600 Pro, Mac OS X (10.5.8), Apple TV 2G
  • arcusii Calculating status...
    Currently Being Moderated
    Mar 11, 2011 8:49 PM (in response to FRH3)
    same here, and on the IPad the 'Remote' app that access the same library is acting the same.

    Geez.
    MacBookPro, Mac OS X (10.6.6)
  • TheDuck1971 Calculating status...
    Currently Being Moderated
    Mar 12, 2011 10:41 AM (in response to FRH3)
    Ok, I am not sure this is only related to HDMI. I have media files that I have setup on my Home Share. I get the same issue on my iPad/iPhone as I get with my Apple TV2. I have restored and rest, everything the same. I have also tried to go through the opti-out, but getting the same issue. Again, I do not think this is tied to HDMI.... This is the suxor. I use this device daily
    PC
  • TheDuck1971 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2011 11:12 AM (in response to FRH3)
    **UPdate, after some sleuthing around with this issue, it looks like ATV2/iPhone/iPad have lost their abilities to to play back audio from mp4 files, from the Home Share. It plays m4v files just fine, which is the native file format from iTunes store purchases. Us who have ripped out DVD collection, and used the mp4 file format are having this issue.
    PC
  • rmaustin Calculating status...
    Currently Being Moderated
    Mar 14, 2011 5:50 AM (in response to TheDuck1971)
    Completely agreed with the MP4 being the issue... but it isn't that simple. It depends also on the encoding because I have many MP4s that will still play - while others will not. I haven't checked if it is higher bit rate files that have the issue or what. But the files play back fine on my un-updated AppleTVs and on my Macs... it is only the updated AppleTV that is having the issue.

    Apple support has been completely unhelpful on this.
    AppleTV, iOS 4
  • sdgoss Calculating status...
    Currently Being Moderated
    Mar 14, 2011 9:48 AM (in response to VodkaPundit)
    This is happening to me as well. But it is limited to ATV HD encoding. I have some HD iPad prest encoded and the audio plays fine even in 5.1
    iMac, Mac OS X (10.6.2)
  • sdgoss Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 14, 2011 10:14 AM (in response to TheDuck1971)
    I disagree, I have mp4 files that are playing fine. I use iMeda Converter from Pavtube to convert my movies. They have presets. The iPad presets will play on the ATV2. The AppleTV preset (1280x720) will not. Both files are mp4.
    iMac, Mac OS X (10.6.2)
  • TheDuck1971 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 14, 2011 10:21 AM (in response to sdgoss)
    What it comes down too, is that all of my files played perfectly well before the update. Now they do not. I use DVD Fab, I choose to rip my movies to .mp4. I would like the higher quality (not 720p, just higher quality.) when I am watching them on my TV.
    PC
  • Thomas Moy1 Calculating status...
    Currently Being Moderated
    Mar 14, 2011 12:39 PM (in response to SuperTroye)
    Ever since the update, I'm not getting sound. Tried rebooting. Turning off Dolby decoding (it was already). No sound. Not even the ping sounds confirming remote button pressing. hmph. Tonight I'll try unplugging cables and doing a full reset.
  • Jonathan Pabalate Calculating status...
    Currently Being Moderated
    Mar 15, 2011 6:08 PM (in response to FRH3)
    I am having the same problem. Tried restore several times.. .files that worked perfectly before the update won't work now. I tried reecoding to a lower bit rate to no avail... HELP!
    MacPro Quad 3.0 4GB RAM ATI x1900 500 GB HD, Mac OS X (10.5), Logic 7.2, Final Cut studio, Adobe CS3
  • acommonjoe Calculating status...
    Currently Being Moderated
    Mar 16, 2011 9:02 PM (in response to vazandrew)
    I am having the same issue. Has anyone had any luck with correcting this?
  • Jonathan Pabalate Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 17, 2011 8:46 AM (in response to acommonjoe)
    I just finished spending a fair amount of time with an Apple TV senior support engineer.

    Basically, while they understand that the content we have all encoded should work, the product is working as designed if all the purchased iTunes content, content created on a mac and or an iPhone (video) plays back correctly when shared via home share in iTunes.

    That being said, he understood that it should work and would pass along the information to the support engineering team. It definitely is not fixed by a restore so don't waste your time.

    What DID work was taking content ripped from BluRay using PavTube, and then using Handbrake to re Encode using the New AppleTV2 preset.

    I was never able to get any of the presets for PavTube to work on my ATV2 after the latest update. I did find a 4.2.1 update, but have no MicroUSB at the moment so I cannot downgrade.

    Results after reencoding ripped format worked ok, but the sound quality is degraded (3 gens of compression).

    It was felt that the problem lies in the AC3 surround functionality that enables Netflix to have 5.1 streaming surround, has broken previously encoded material.

    The options at this point, are to reencode using HandBrake, or wait for another ATV2 update that MAY fix the problem. Currently the efforts are focused on fixing the flickering problem users are experiencing when they connect to their HDTV from HDMI out of the ATV2 to DVI.

    I was told I would be contacted in a few business days to give me a sense on what they will do about this.

    Hope that helps all of you.
    MacPro Quad 3.0 4GB RAM ATI x1900 500 GB HD, Mac OS X (10.5), Logic 7.2, Final Cut studio, Adobe CS3
  • VodkaPundit Calculating status...
    Currently Being Moderated
    Mar 17, 2011 8:59 AM (in response to Jonathan Pabalate)
    My fix was to take my ATV2 to the Apple Store and exchange it for an un-broken model. Needless to say, I won't be installing any updates.

    It might not sound like much to re-encode movies via Handbrake, but I'm a collector with about 1,400 movies, nearly a third of them now from Blu-Ray.

    Mostly I'm just offended that Apple will not allow a true factory restore. Apple broke my ATV and won't allow me to set it right? And what happens if my wife forgets, and tells the ATV to go ahead and update, next time the message pops up?

    You need to tell your people to seriously rethink this policy of having my unit "phone home" to get your latest firmware when I'm trying to do a restore. If I'm trying to restore the old firmware, it's because Apple screwed something up, not because I'm thrilled with the new firmware.

    And your solution to your screwup is to have me re-encode months worths of rips?

    Honestly, I'm getting angry all over again just thinking about it.

    It will be nice when or if Apple ever unscrews its ATV screwup. But it's absolutely mandatory that you give users back the power to do a real factory restore.
    Mac Pro (Nehalem), Mac OS X (10.5.7)
  • VodkaPundit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 17, 2011 9:00 AM (in response to Jonathan Pabalate)
    Sorry -- meant to mention that my previous reply to you, was the email I just sent off to Apple. Sorry for any confusion.
    Mac Pro (Nehalem), Mac OS X (10.5.7)
  • BringerOD Calculating status...
    Currently Being Moderated
    Mar 17, 2011 10:49 PM (in response to FRH3)
    Does anyone know of a Apple TV competitor that these files will work in?

    I like my Apple TV, but I have 600 movies, that I do not want to rip over again.
    Windows 7

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.