Skip navigation

AirPlay issues

12253 Views 15 Replies Latest reply: Nov 23, 2011 5:11 AM by Jman1313 RSS
1 2 Previous Next
harrykellerman Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 18, 2011 8:23 AM
I have an iPad, an iPod Touch and a new 2nd gen Apple TV. (Apple fan here).

Have upgraded everything to latest OS. Trying to use AirPlay and here is a list of problems encountered ...
1) Streaming music -- worked fine for @ 10 minutes then quit (no apparent reason?)
2) Streaming apps (Discover channel HD) ... when I click little Airplay icon it pops up a choice of my Apple TV 3 times (why when i only have 1 ATV?) two have a TV icon and one has a satelliet dish icon. None of them seem to work even when checked off.
3) Herk-jerky playback -- I actually got it up and running for about 5 seconds and then lost everything. Didn't play back on TV and caused sound to be mute on iPad. No graceful way out, had to reboot iPad.

Wonder why i'm having so many problems with it. It's a cool feature but not necessarily a must-have. Would be nice for it to work better for me. Maybe it's "operator error" as a friend has suggested.
iPad 1, iOS 4
  • vazandrew Level 6 Level 6 (13,045 points)
    Currently Being Moderated
    Mar 18, 2011 8:41 AM (in response to harrykellerman)
    Don't have an iPad (yet) but have an iPhone and iPod Touch and airplay works fine. I would look into your local network, maybe there is something amiss there.
    iMac 2.8GHz 2GB RAM ATI Radeon HD 2600 Pro, Mac OS X (10.5.8), Apple TV 2G
  • vazandrew Level 6 Level 6 (13,045 points)
    Currently Being Moderated
    Mar 18, 2011 8:53 AM (in response to harrykellerman)
    That would be your internet connection and count towards things like Netflix, Youtube, iTunes Rentals etc. Airplay is using your local network and is separate. But it could also be slow or have an issue which is causing this
    iMac 2.8GHz 2GB RAM ATI Radeon HD 2600 Pro, Mac OS X (10.5.8), Apple TV 2G
  • James A. Weston Level 5 Level 5 (5,830 points)
    Currently Being Moderated
    Mar 18, 2011 10:07 AM (in response to harrykellerman)
    Your Internet connection shouldn't matter, but your wireless network could be the problem.

    Good things: A router that handles 5GHz wireless connections as well as 2.4GHz, no signal strength issues due to interference or excessive distance to router from connected wireless devices.

    Bad things: To much wireless traffic due to too many active wireless devices, outdated router, too many 2.4GHz wireless connections (be sure to connect your Apple TV 2 by 5GHz wireless connection or by Ethernet, if possible).
    Mac OS X (10.6.6), Windows 7
  • Yannou69 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2011 10:43 AM (in response to James A. Weston)
    Before the upgrade to iOS 4.3, all my devices were OK through Airplay to stream my music via my Airport.
    Now, Airplay seems to crash after a moment.
    I don't think that my network is in cause as I have changed nothing except this stupid upgrade on my iPhone 3GS and iPad. My other iPhone on iOS 4.2.1 works fine with Airplay....

    So Apple fix it please as we can't downgrade to the previous iOS without a lot of manipulations....
    MacBook Air,iPad V1,iPhone 3GS, iOS 4, iOS 4.3; Airport Express 7.5.2
  • tomsig Calculating status...
    Currently Being Moderated
    Mar 19, 2011 2:38 AM (in response to harrykellerman)
    Hi
    I also upgraded to 4.3 and got the same problem.
    I use Airport Extreme and airport express as network, and when i got the problem i upgradede the network firmware, but i did not help, so i went back to my ipad, and i seems to me that ipod are having a problem staying connected to the network after upgrading to ios 4.3. so i tryed it with the sound from YouTube, - and so fare the disconnection problem does not appear with other media.
    I think Apple have to do something with the ios 4.3
    Looking forward to a solution
    Ipad, iOS 4
  • sfarley724 Calculating status...
    Currently Being Moderated
    Mar 23, 2011 7:30 AM (in response to harrykellerman)
    I was having the same issues after downloading the new software. No communication between iTunes account, AppleTV, iPhone or iPad with home sharing turned on. Only solution that worked for me was to unplug and reboot my router. After router was rebooted, all devices recognized each other and airplay icon was displayed on both iPad and iPhone. Also, iTunes was obviously recognized by Apple TV as well. Now Airplay functioning again. Hope this helps.
    MacBook Pro
  • HaPi76 Calculating status...
    Currently Being Moderated
    Mar 30, 2011 11:11 AM (in response to Yannou69)
    I'm also experiencing major issues with AirPlay (which I love), going from "bad" to "better" to "badder" through the last 3 iOS updates (4.2.1 to 4.3 to 4.3.1).
    Both my iDevices (iPhone4 and AppleTV 2010) are up to date OS-wise, yet my iPod app refuse to "see" and/or "wake-up" my ATV. This issue, at first occasional, is now systematic and has spread to my other apps, going so far as to remove my ability to even AirPlay audio content. The airplay icon will show up on occasions (with menu and all) but the ATV will still not play the content. Only the Remote app remains able to link to it (most of the time: there has been some connectivity issues there too).
    Is this situation familiar/common to many?
    Will there be a bug fix before june?
    Thanks for listening.
    iPhone 4, Apple TV G2 (2wire b/g modem/router), iOS 4
  • FTBoomer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2011 12:44 PM (in response to harrykellerman)
    Add me to this list. My ATV2 keeps losing the AirPlay connection. I leave the ATV2 Airplay menu open and turn the option off then on and it works again for 10 minutes. This just started yesterday. Had the ATV2 since Christmas, iPad 2 and iPhone 4 having same issues.

    40MB pipe with Windows 7. All software at the latest release on all devices. All devices on same router G\N
    IPad2, iOS 4
  • HaPi76 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2011 7:03 AM (in response to HaPi76)
    Hi,
    I went into Settings/ iPod/ then activated the Home Sharing feature.
    It did not work immediatly, but my ability to push content from my iPod app to my AppleTV (including audio feeds from other apps) seems to have been restored. Since I didn't do anything else beyond the usual syncing/charging, it might be a possible solution.
    Thanks
    iPhone4, AppleTV 2010, iOS 4
  • grantfromred hill Calculating status...
    Currently Being Moderated
    Sep 28, 2011 5:07 PM (in response to harrykellerman)

    im having a similar issue running ipad 2 to apple tv2 i can stream music via airplay however im having issue with mirroring when i select apple tv and then mirroring it instantly turns off and goes back to just the ipad. then to switch mirroring off you need to be quick and sometimes will take 10 times before it stays off so that you can stream music.

     

    the ipad is running ios 5 beta 7 and apple tv is on the advised version to work with it. one issue im having that seems like it might have something to do with this however im unsure is that the apple tv is registered with apple dev account however in the menu on the unit it says it has been refused authorisation...

    any suggestions?

  • grantfromred hill Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2011 5:10 PM (in response to grantfromred hill)

    i have also tried to return the apple tv to last version of ios but pop up says it cant contact apple or something similar (net connection and all other parts or network in full working order and not causing the issue)

  • Dragos Maciuca Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 9, 2011 8:25 PM (in response to grantfromred hill)

    Similar problems here.  Here is my setup:

    The music library is on an iMac, wired ethernet wired to router.

    Apple TV, v.4.4.2, wired ethernet to router.

    "Remote" App on iPod Touch, iPad 2 and iPhone 4S (they all behave the same, so I assume is not the app).

     

    After Apple TV wakes up from sleep, I can't get music to stream.  On a good day, I can go to AirPlay within the Remote app, turn off Apple TV, turn on Apple TV and then it works.  On a bad day I have to reboot Apple TV (unplug, plug the cord since the **** thing doesn't have a switch).

     

    All these problems seem to have appeared after the latest upgrade allowing iPad mirroring.  Welcome to Microsoft!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.