Skip navigation

NO AIRPLAY after update to 4.3 on iPhone 4, 3GS and iPad

24073 Views 48 Replies Latest reply: Mar 26, 2012 8:21 AM by Lau185 RSS
  • joshmorison Calculating status...
    Well, that explains that then.

    Time to upgrade!!
    iphone, iPhone OS 3.1.3
  • jimmerz Level 1 Level 1 (10 points)
    i have the latest software updates on my imac, apple tv, and iphone3gs as well as my iphone4. i have no air play anything. the setting on the apple tv unit is turned on its always been on.. everything is on the same network. everything has been rebooted including the router, ive reset all my devices and started over from scratch and i still have no air play. in fact i also can not get the apple remote app to pick up on my itunes library OR my apple tv.. all user names and passwords have been checked and double checked.. no clue whats going on but im a bit more than annoyed. sounds like some of you guys are having similar issues.
    imac i7, Mac OS X (10.6.6), iphone4
  • Tonka889 Calculating status...
    This problem is not limited to apple TV, I was using this on my iPad, MacBook and iPhone4 to play via an Airport Express to my stereo prior to 4.3 update, now Airplay icon is AWOL.

    update- I have restarted the iPhone and the icon has re-appeared and after several failed starts is working again.

    glad other people have noticed this, must be a bug/glitch
    MacBook, Mac OS X (10.6.6), ipad 1 iphone 4.
  • toriqo Calculating status...
    i have a problem too. i've recently updated my atv2 to ios4.3 but NOT my iphone 4, which is still running on ios4.2.1. though i still have the airplay icons on my iphone, i can't stream video or images to the atv2. only music. any idea if this is happening because i didn't update the iphone too?
    mbp5,5, iOS 4
  • James A. Weston Level 5 Level 5 (5,830 points)
    I believe the latest software for Apple TV 2 is version 4.2, not 4.3.

    I can't test your situation since I've updated my iPhone 4 to IOS version 4.3, but my guess is that you will need to upgrade, too.
    Mac OS X (10.6.6), Windows 7
  • toriqo Level 1 Level 1 (5 points)
    yeah, sorry, my bad. i have ios4.2 on my atv.
    mbp5,5, Mac OS X (10.6.3)
  • Abraster Calculating status...
    I have the similiar problem. I have 1 ipad (4.3) 2 iphone 3gs (4.3 & 4.2.1) with airport express. I can stream the music via 4.2.1 but not with any other device with version 4.3.
    iOS 4
  • Smithfff Calculating status...
    Same issue worked great before update to 4.3. updated and no more airplay goodness for me
    iOS 4
  • toriqo Level 1 Level 1 (5 points)
    ok, is anyone here who updated atv2 to ios4.2 AND iphone4 to ios4.3 and STILL has full airplay functionality?
    i'm asking this because maybe they've changed something in airplay and both devices need to have the latest firmwares in order for the airplay protocol to work correctly.
    mbp5,5, Mac OS X (10.6.3)
  • Yannou69 Calculating status...
    Exactly the same situation for me as
    I have the similiar problem. I have 1 ipad (4.3) 2 iphone 3gs (4.3 & 4.2.1) with airport express. I can stream the music via 4.2.1 but not with any other device with version 4.3.

    Message was edited by: Yannou69
    MacBook Air,iPad V1,iPhone 3GS
  • peterdoney Calculating status...
    Just upgraded to 4.3.1 and same thing - no airplay buttons.
    iMac, MacBook, iPhone, Mac OS X (10.4.10)
  • cwags64 Calculating status...

    I had to update my computer and my router and reboot.   Then I checked the turn AirPlay on or off button under the network setting on my Mac.  All devices have been upgraded. Ipad2 iPhone 4, atv and atv2.  Now the AirPlay button has reappeared. 

  • Handicap18 Calculating status...

    Here's my issue.  We have 2 iPads and 2 iPhone 3GS and ATV2.  Airplay works for everything except for the video on 1 of the iPads.  Both iPads are updated to 4.3.3.  One iPad the airplay works fine for all apps.  On the other iPad I can get the airplay to work for the camera roll and the iPod, but when showing video's from the video app where we have our tv shows and movies, the airplay does not show up.

     

    I'm baffled.

  • DrewV Calculating status...

    I've been struggling with this for a few weeks and I'm still stumped. Our house has an iPad 1, 3GS, and iPhone 4. The iPad and 3GS can connect quite reliably to AirPlay using an AirPort Express (G model). However, both the AirPlay icon AND iTunes Home Sharing appear less than 50% of the time on the iPhone 4. Rebooting the phone always brings AirPlay back, but it can disappear as soon as the phone sleeps and then awakes again.

     

    I've tried:

    - Setting up as a new phone

    - Changing security on the wireless network. Also removed security.

    - Reconfiguring my network with a different wireless router. Have tried 802.11G and N

     

    I LOVE this feature when it works, but its been so unreliable and frustrating on my iPhone 4. Really hope this is fixed soon.

  • Maxwellimus Calculating status...

    Just solved this problem on my iPhone 4, which is only connected to my AirPort -- not an Apple TV.  It definitely sounds strange, but I switched the language to French and then back to English, and the icon was suddenly there in the iPod app!  I imagine this would probably work for any language you would choose to change it to.

     

    If you are using an iPhone 4 to connect to ONLY AirPort, definitely try this!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.