Skip navigation

"Reply All" re-sends to me! So annoying!

63345 Views 42 Replies Latest reply: Nov 18, 2013 10:50 AM by Nick Johnson7 RSS
1 2 3 Previous Next
pieceolease Calculating status...
Currently Being Moderated
Mar 17, 2011 4:21 PM
When there is a convo between a group, or an email sent directly to me (with others CC'd), when I "reply all", it puts my email in the cc spot.

I do NOT have the "cc me on everything" checked in preferences. I have checked my address book and made sure there is only 1 entry for my email. It doesnt matter if i was a cc or it was sent directly to me, I am always included and when I send I get an email in my inbox from myself. I have to physically delete my contact from the reply all email to not receive it.

some technical info. the email address i use is gmail. that in turn forwards to my mobile me account. Mobile me pushes to all my devices. its mobile me that is set up on my mac mail NOT GMAIL. The outgoing server is setup to send through gmail, though, so that people see emails as coming through my gmail, not mobile me. hope that makes sense and you can help! thanks!
iMac, Mac OS X (10.5.8)
  • Beavis2084 Level 4 Level 4 (2,850 points)
    Currently Being Moderated
    Mar 18, 2011 7:35 AM (in response to pieceolease)
    I don't see that as strange behavior. When I click "reply to all" I expect I am included... as I am a part of "all".

    This is even true when I use my Outlook at work. Regardless where my email is on the original (CC or TO), if I hit REPLY TO ALL, I get a message.

    A work-around: Setup a rule that auto-deletes any emails sent TO you FROM you. Then at least you wont have to do it yourself.
    Dual 1.8GHz G5 | iMac 2.8GHz Intel Core 2 Duo 20 | iMac G4 17 |, Mac OS X (10.6.6), 5G iPod 80GB | (2) AirPort Extreme | (2) AEX
  • Zlig Level 4 Level 4 (1,340 points)
    Currently Being Moderated
    Mar 18, 2011 8:19 AM (in response to pieceolease)
    Do you have more than one email address? If so it could be that the sender is sending to both your addresses, and so when you reply to "All" from one it automatically sends to the other...
    MacBook 2.4 White, iMac Intel 2.16 20", PowerMac G4 MDD, Macintosh Plus, Mac OS X (10.6.6)
  • Klaus1 Level 8 Level 8 (43,425 points)
    Currently Being Moderated
    Mar 18, 2011 11:24 AM (in response to Beavis2084)
    I don't see that as strange behavior. When I click "reply to all" I expect I am included... as I am a part of "all".

    I am struggling to see how a sender can be classed as a recipient.

    I have never received a copy of any email I have sent, even on a 'reply to all'.
    20" 2.1GHz iSight iMac G5,, Mac OS X (10.5.8), iLife 9 but iMovie 6, QTPro 7.6.9, Safari 5.0.4
  • fa1con Calculating status...
    Currently Being Moderated
    Mar 23, 2011 2:17 PM (in response to pieceolease)
    Bugs me too on the iPhone. I guess I'm used to gmail where when you hit 'reply all' it replied to everyone but yourself. Seems smarter, but I guess it is what people are used to.
    2.4 Ghz Intel Core 2 Duo, Mac OS X (10.6.6), 4 GB Ram
  • relativitydrive Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 8, 2011 8:04 AM (in response to fa1con)

    I have a solution to this. It is not as simple or as obvious as taking yourself off the CC to list.  I've posted this elsewhere but thought best to put it up here as it's an issue seen with gmail accounts and a lot of Mac and iPhone users...

     

    The answer to this is...

     

    Make sure your email address that is registered in Mac's Mail program under Preferences, Accounts, is exactly the same as the account's version of the address.

     

    Here's my example:

     

    xxx.xxx@gmail.com was the name used in Mac's Mail program and on my iPhone.  This works fine and is acceptable because @gmail.com is a replacement for @googlemail.com

     

    The account when I set it up was @googlemail.com.

     

    I changed the xxx.xxx@gmail.com to xxx.xxx@googlmail.com and both the iPhone and the Mac's Mail program now exclude me when replying to all.

     

    You must ALSO change the outgoing mail server information to smtp.googlemail.com to make this function.  It still works with gmail on the incoming mail server but changing that to googlemail is recommended.

     

    This is due to the mail programs not recognising the alias automatically and therefore not pruning the address when required.  This is an issue that Apple needs to solve if it can be done without breaking other rules that are obviously there for a reason.

     

    If you don't use googlemail and your mail account doesn't have the replacement option like gmail, you'll still have to find a solution.

  • mmmax Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 30, 2011 6:23 PM (in response to relativitydrive)

    This was very helpful - I suddenly started having this problem when I got a new machine (Lion), did migration assistant from a Snow Leopard machine, and had to set up my mail accounts.

     

    When I implemented the solution as stated by relativitydrive, I stopped getting myself copied when I did reply all. However, there was a predictable bad side effect: my email now seems to others like it comes from my gmail account, rather than the account I was formerly using in Preferences (which is also setup in Gmail imap settings to be the "reply from" email address).

     

    Here's the strange thing: when I switched the account email address listed in Mail Preferences back from the gmail address to the original address  (the very address I started off with in Mail Preferences), the problem did not occur again - when I hit reply-all, Mail does not copy me!

     

    Why this happened I don't know, but perhaps this will be useful to somewhere out there in googleland.

  • CarltonBanks Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 18, 2011 1:57 AM (in response to pieceolease)

    this also started happening for me out of nowhere today. and is driving me nuts. any ideas how to fix yet?

  • CarltonBanks Level 1 Level 1 (15 points)
    Currently Being Moderated
    Nov 18, 2011 2:01 AM (in response to CarltonBanks)

    Ahh i figured it out...

     

    goto outlook 2011 preferences

     

    then goto accounts

     

    and make sure your email address matches what people are emailing you.

     

    i recently changed it to a different alias email that still comes to the same email address but everyone still emails me to my old alias.

  • jarrob Calculating status...
    Currently Being Moderated
    Dec 2, 2011 6:00 AM (in response to CarltonBanks)

    i also had good luck with this problem today.  go to Mac Mail Preferences.  Open Accounts.  Ensure that the Email Address field is exactly the same as the User Name field.  Wallah!

  • BobGeorge Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 3, 2012 8:42 AM (in response to relativitydrive)

    I have same problem as originally described by pieceolease; however in this case it is in Outlook 2011.  So, "fixes" described here that relate to Mac Mail do not work.

     

    It only started occurring after company moved our mail system to a new Exchange Server; think it was also happening on Windows version of Outlook, but I moved off that to Mac version (Outlook 2011) a while back so cannot test that right now.

     

    Any thoughts ?

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.