Skip navigation

Virgin Mobile Broadband2go Novatel MC760 Devise Not Working with MacBookPro

11263 Views 22 Replies Latest reply: Feb 26, 2012 11:40 AM by DerrisB RSS
1 2 Previous Next
warrioress Calculating status...
Currently Being Moderated
Feb 10, 2011 6:59 PM
I just purchased a Virgin Mobile Broadband2go Novatel MC760 USB to have internet connection on the go with my MacBookPro. I have never been able to get it connected. Is anyone having the same problems and has anyone found a solution? Here is my issue:

I installed the software from the USB device, got it activated and say "ready" to connect. When I click connect, my Mac asks me for my admin username and password, I enter and it just goes back to "ready" status and NEVER connects to the internet. I have several Macs in my house and a PC. The first macbookpro operating on Leopard Snow, does not connect to the internet with the device. My daughters MacbookPro is exactly the same...maybe 9 months newer and it connects to her. I just bought a 17 inch MacBookPro with the works. cost me over $3,000. I installed the device on it and IT DOES NOT WORK either. I have called Virgin Mobile several times over the last few days and troubleshooted with their techs. No one can get it to work. Even took my Mac to apple to see if I was having a harddrive malfunction. To no avail. can't be a hard drive issue becuase it doesn't work on the new 17 Mac either. This device is supposed to mbe compatible with Macs and as mentioned, does work on my daughters Mac but my two Mac's does not work with. What the heck? The only thing I can think of is that when I bought my new mac, I migrated all the files from my old Mac and both have the same settings and programs. I am thinking there is a software or driver conflict somewhere becuase when my daughter got her new laptop, we migrated my computers data to hers. However, she has deleted many programs off of hers and I am guessing she deleted a program on her Mac that I still have on mine that is conflicting with this device. I even had Virgin Mobile send me another device. Same problem. Neither one works on my Macs, but does on my daughters. Does anyone know of any software or driver conflicts with any mac software that would cause the device not to work...even on my new 17 inch. Since I am tired of working on this problem, I am returning the device back to Virgin Mobile. I have used Sprint aircards on my mac before and NEVER had a problem. I chose to use Virgin Mobile in the first place because of the "no contract" feature. I don't want to sign up for Sprint for two years like I did last time.

Does anyone have the same issue of not being able to connect with Virgin Mobiles Novatel MC760 USB device? I just keep thinking its a software or driver conflict but can't figure out what. I am going to take to an apple genius tomorrow. Was hoping to get this resolved tonight. In the meantime I am return this stupid aircard.

Thanks. Mrs. Very Frustrated At The Moment! grrrrr.
MacBookPro, Mac OS X (10.6.6), I have a 13 inch and 17 inch MacBookPro
  • babowa Level 7 Level 7 (22,060 points)
    Well, since it is not working with any of yours, but your daughter's, I decided to check their coverage map and, they only seem to have (decent signal) coverage in large cities, such as Atlanta, GA. So, I'd suggest checking their coverage for your exact neck of the woods (and your daughter's) first.
    27" 3.2 GHz iMac i3, 12 GB RAM, 13" white early '09 MB,, Mac OS X (10.6.6), LaCie d2 DVDRW, 2 LaCie d2 Quadra ext HD , Wacom tablet, Epson Artisan 810
  • Linc Davis Level 10 Level 10 (107,650 points)
    For future reference, the way you troubleshoot problems like this is by looking at the system logs. Without those, nobody will be able to help you much. I have the same device and it works for me.
    Mac OS X (10.6.6)
  • sixty_cycle_hum Calculating status...
    I have a very similar setup - mine works OK, but I suspect that the B2G drivers that were installed have compromised my Snow Leopard install. Not very impressed with the software at all, and the service could be better.

    Currently, if I do a cold boot on my MBP, I get the gray screen with the apple logo and a progress bar that takes a long time to ever get to the desktop. Once I'm booted up, I have zero problems. Coming back from sleep is fine too.
    iMac 24" 2.8, 13" MBP 2.6, Mac OS X (10.6.6)
  • ozonewaverider Calculating status...
    I am having the exact same problem. They sent me a new MC760 but still no connection. Have called tech support and he told me weak signal. Not the issue. Took my MBP to work and still had the same problem. I will probably end up sending this one back too for a refund.
    MacBook Pro 2.33 Core 2 Duo; G4 Mac Mini, Mac OS X (10.6.6)
  • ejnmbp Calculating status...
    I can't get the MC760 to work on my 2011 MBP 13 inch. New laptop, fresh install. Install and reboot work fine. When I try to create the connection in Preferences -> Network, I do not see the Novatel modem listed as an option. I have Ethernet, Airport, Firewire, BT DUN, VPN, PPPoE and 6 to 4.
    MBP13, Mac OS X (10.6.6)
  • Mury00 Calculating status...
    Same issue here. Used the MC760 via usb, installed the software and rebooted as directed. Once computer reboots and/or if you remove and insert the MC760 it again asks to install the software. Broadband2Go software will not respond or come out of this loop. It never detects the modem.

    This is a new MBP, modem worked fine with my previous Sony Vaio laptop.
    Macbook Pro 13" i5, Mac OS X (10.6.6)
  • Josh 90046 Level 1 Level 1 (10 points)
    The reason you are having a problem is that Sprint & Virgin Mobile both use products from Novatel causing a software issue. Oh...and Virgin Mobile uses the Sprint Network so they are basically the same exact thing. You will need to remove the old sprint software and find and remove any files under system/library/extensions referencing the same name. Once you do that and restart the computer you should not have an issues anymore.
    Mac OS X (10.6.4)
  • ozonewaverider Level 1 Level 1 (0 points)
    I found the following link:


    http://wiredpen.com/2010/03/10/virgin-broadband2go-service-ok-set-up-a-pain

    I followed her recommendations and I can now connect to my Broadband2go account and get my 3g. Just can't use the manager software that came on the MC760. I just use that to set up the modem with my account # and MSID number. But, using the network preferences in Snow Leopard is working fine so far. My usage is showing up on my Virgin Mobile account page.
    MacBook Pro 2.33 Core 2 Duo; G4 Mac Mini, Mac OS X (10.6.6)
  • ejnmbp Level 1 Level 1 (0 points)
    Thank you for the link. I went through it and still the MBP won't see the Novatel as an Network Option. So frustrating.
    MBP13, Mac OS X (10.6.6)
  • Zach-O-Matic Calculating status...
    @ozonewaverider: thanks for the link! I have this modem working with both a 2008 MacBook (non-uni) and the new 11" Air with the Broadband2Go software; both under Snow Leopard 10.6.6. I don't like the software, but it works. I also just got it working on my Air without Bb2Go software thanks to the post from Kathy in the link you provided.
    11" MacBook Air, Mac OS X (10.6.6)
  • LemuelG Calculating status...
    I'm having the same issue. Virgin Mobile sent me a replacement card and to no avail. Same results with that card. My original card works fine in an Ubuntu setup (really Linux Mint) as well as Windows XP. I've connected successfully with both.

    The furthest I've gotten is that the Broadband2Go software will indicate "Please wait..." once the device is inserted (and the mounted disk portion is unmounted).

    I found this thread about unmounting the drive and getting the native drivers to work (http://www.abdevelopment.ca/blog/using-novatel-u760-snow-lepoard-automatic-eject ing). The automatic unmounting works for me, however the modem is still not recognized (the more important matter).

    I've tried about every ovation driver I could get my hands on (http://www.novatelwireless.com/content/files/). The VMU folder has the Virgin Mobile software, but there are other mac drivers there. Again, to no avail.

    The Program Modem option (once it goes into the Please Wait mode) is enabled. However, when I go into that area there is no ESN number ... which there should be. Attempting to program it gives me an error.

    Lastly, the Network options do not show an interface for the Novatel Wireless Modem.

    As far as config, I have the new MB 15 with the i7 quad 2.2 processors and 10.6.6 Mac OS X.

    It's my first mac ... and i realize it's Novatel and Virgin Mobile that are to blame, but it's a little frustrating. I thought macs were supposed to be "easy" ...
    MacBook Pro 15 (2011 unibody), Mac OS X (10.6.6)
  • Al_________ Calculating status...
    It's because the driver is 32-bit and you MacBook pro defaults to 64-bit.
    To force your kernel to 32-bit mode reboot the laptop and hold the "3" and "2" keys down until the system comes back up.
    Why do so many "helpful" people make random gueses on this forum when they don't actually know anything?
    08/Pro/2.8, Mac OS X (10.5.6)
  • wingnut23 Calculating status...
    I just purchased a Virgin Mobile U760 USB Broadband2Go modem before I found this article. I too could not get this software to work. However, on seeing this thread, I did contact Virgin Mobile and they CONFIRMED that their software does not work on 64-Bit. I was a bit shocked and wish they would have listed this in the requirements. In any case, he could not give me an estimated date that an update would be released and suggested I buy a MiFi instead. While I would prefer the USB, the Virgin Mobile pricing is difficult to beat. I will be heading to Best Buy tomorrow to exchange this for a MiFi.
    MacBook Pro 15" 2011, Mac OS X (10.6.7)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.